PDA

View Full Version : Missing Kernel Config Options



stoge
20th April 2008, 06:35 PM
I am a little new to Fedora and I am having a real tough time with compiling a brand new Linux Kernel and could use some help...

I downloaded the latest Linux Kernel (2.6.24.x) from www.kernel.org. My intent is to compile a seperate kernel that will live in my NFS Root Dir for my diskless clients to boot from. My clients are running an i686 architecture and my main server is a x86_64 architecture. Bottom line, I need to compile a kernel with options totally different than my server's main kernel.

The problem:

The 'make menuconfig' is not giving me all of the available options to configure! Specifically, I am looking to change my CPU to a VIA C7 or i686 and the option is just not there. I have googled the hell out of the problem and most people have fixed missing kernel config options by running 'make oldconfig' after unpacking the newly downloaded kernel. This has not worked for me. I only get a few new options to choose from and CPU is not one of them.

Fedora Core 8
uname -r: 2.6.23.15-137.fc8

Please help!

Thanks,

SToGE

stevea
20th April 2008, 07:03 PM
make menuconfig
4 lines down, select "processor type & features"
8 lines down in submenu, select "Processor family".

Of course you *should* start with a valid .config file from one of the defconfigs.

Not sure what you are thinking, but putting the kernel in an NFS share doesn't make a lot of sense unless you have some magic bios that understands NFS. More likely you want this in a /tftpboot boot directory and you'll need to setup bootp protocol service with something like dnsmasq.

stoge
20th April 2008, 07:16 PM
You are correct...I am putting the kernel Image in /tftboot.

I think my menuconfig is missing a whole of of things other than the CPU I want. Even your instructions that "Processor Family" is 8 lines down doesn't match up to what I got. My "Processor Family" only EVER shows the following 4 options:

-Opteron/Athlon64/Hammer/K8
-Intel P4/older Netburst based Xeon
-Core 2/Newer Xeon
-Generic-x86-64

I have a feeling that I do not have a "valid" .config file as a starting point?

Thanks for your help! Please reply.

Brian1
20th April 2008, 08:03 PM
You are compiling on a 64bit machine. The easiest way is boot up a 32bit OS and compile 32bit kernels from there. Other is install VmWare and install a basic 32bit version of a distro. I do this to compile 32bit apps on 64bit systems. Beats all the changes that must be done to fake the system into thinking it is 32bit.

Brian

RupertPupkin
21st April 2008, 12:50 AM
Instead of the curses-style interface from menuconfig, try the Gtk+ interface (make gconfig) or Qt interface (make xconfig). Either one will give you a nice GUI that makes it a lot easier to see all the kernel options.

stoge
21st April 2008, 12:50 AM
That was actually my next move. I also have a FreeBSD box that runs on an i386 platform. I'm gonna try to compile the latest linux kernel there and drop the zImage file on the FC8 box and see what happens. I will give it a whirl there and report back.

Thanks!