PDA

View Full Version : xine not starting in xfce



Jongi
19th April 2008, 08:19 AM
When I try to run to run xine under xfce I get



[jongi:~#] xine
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
xiTK WARNING(_x_error_handler:258): X error received: 'BadWindow (invalid Window parameter)'
X Error of failed request: BadWindow (invalid Window parameter)
Major opcode of failed request: 20 (X_GetProperty)
Resource id in failed request: 0x600062
Serial number of failed request: 43
Current serial number in output stream: 43


I searched around and found this as a possible solution (http://sourceforge.net/mailarchive/message.php?msg_name=E1Iye9T-0007Dj-5I%40sc8-pr-cvs10.sourceforge.net). Though it seems to relate to the cvs version. Would I be able to use it on the xine from the livna repo? Is so how would I go about implementing it?

I also run compiz-fusion but I think I have ruled that out as an issue as xine works in gnome with compiz-fusion running.

Xine related packages


[root:~#] yum list | grep xine | grep installed
totem-xine.x86_64 2.20.1-1.lvn8 installed
totem-xine-devel.x86_64 2.20.1-1.lvn8 installed
xine.x86_64 0.99.5-1.lvn8 installed
xine-lib.x86_64 1.1.11.1-1.fc8.1 installed
xine-lib.i386 1.1.11.1-1.fc8.1 installed
xine-lib-arts.x86_64 1.1.11.1-1.fc8.1 installed
xine-lib-extras.x86_64 1.1.11.1-1.fc8.1 installed
xine-lib-extras-nonfree.x86_64 1.1.11.1-1.lvn8 installed

xfdesktop


[root:~#] yum list | grep xfdesktop | grep installed
xfdesktop.x86_64 4.4.2-1.fc8 installed

xfce related packages


[root:~#] yum list | grep xfce | grep installed
gtk-xfce-engine.i386 2.4.2-1.fc8 installed
gtk-xfce-engine.x86_64 2.4.2-1.fc8 installed
libxfce4mcs.i386 4.4.2-1.fc8 installed
libxfce4mcs.x86_64 4.4.2-1.fc8 installed
libxfce4mcs-devel.x86_64 4.4.2-1.fc8 installed
libxfce4util.x86_64 4.4.2-1.fc8 installed
libxfce4util.i386 4.4.2-1.fc8 installed
libxfce4util-devel.x86_64 4.4.2-1.fc8 installed
libxfcegui4.x86_64 4.4.2-1.fc8 installed
libxfcegui4.i386 4.4.2-1.fc8 installed
libxfcegui4-devel.x86_64 4.4.2-1.fc8 installed
xfce-mcs-manager.x86_64 4.4.2-1.fc8 installed
xfce-mcs-manager-devel.x86_64 4.4.2-1.fc8 installed
xfce-mcs-plugins.x86_64 4.4.2-2.fc8 installed
xfce-utils.x86_64 4.4.2-3.fc8 installed
xfce4-appfinder.x86_64 4.4.2-1.fc8 installed
xfce4-cpugraph-plugin.x86_64 0.4.0-2.fc8 installed
xfce4-datetime-plugin.x86_64 0.5.0-3.fc8 installed
xfce4-dev-tools.noarch 4.4.0-1.fc7 installed
xfce4-dict-plugin.x86_64 0.2.1-3.fc8 installed
xfce4-diskperf-plugin.x86_64 2.1.0-3.fc7 installed
xfce4-fsguard-plugin.x86_64 0.4.1-1.fc8 installed
xfce4-icon-theme.noarch 4.4.2-1.fc8 installed
xfce4-mailwatch-plugin.x86_64 1.0.1-7.fc8 installed
xfce4-minicmd-plugin.x86_64 0.4-7.fc8 installed
xfce4-mixer.x86_64 4.4.2-1.fc8 installed
xfce4-mount-plugin.x86_64 0.5.1-3.fc8 installed
xfce4-panel.i386 4.4.2-1.fc8 installed
xfce4-panel.x86_64 4.4.2-1.fc8 installed
xfce4-panel-devel.x86_64 4.4.2-1.fc8 installed
xfce4-places-plugin.x86_64 1.0.0-2.fc8 installed
xfce4-quicklauncher-plugin.x86_64 1.9.4-1.fc8 installed
xfce4-sensors-plugin.x86_64 0.10.99.2-3.fc8 installed
xfce4-session.x86_64 4.4.2-1.fc8 installed
xfce4-session.i386 4.4.2-1.fc8 installed
xfce4-session-devel.x86_64 4.4.2-1.fc8 installed
xfce4-session-engines.x86_64 4.4.2-1.fc8 installed
xfce4-smartbookmark-plugin.x86_64 0.4.2-5.fc8 installed
xfce4-systemload-plugin.x86_64 0.4.2-3.fc8 installed
xfce4-taskmanager.x86_64 0.4.0-0.2.rc2.fc6 installed
xfce4-volstatus-icon.x86_64 0.1.0-2.fc8 installed
xfce4-weather-plugin.x86_64 0.6.2-2.fc8 installed
xfce4-websearch-plugin.x86_64 0.1.1-0.6.20070428svn2 installed
xfce4-xfapplet-plugin.x86_64 0.1.0-4.fc8 installed
xfce4-xkb-plugin.x86_64 0.4.3-3.fc8 installed

glennzo
19th April 2008, 10:23 AM
Hi Jongi. What happens when you try to run xine under XFCE with Compiz-Fusion disabled?

Jongi
19th April 2008, 03:52 PM
Should have tried that. Yeah it would seem it is an error related to compiz-fusion.

glennzo
19th April 2008, 06:53 PM
Should have tried that. Yeah it would seem it is an error related to compiz-fusion.Well, sometimes the most obvious things are easily overlooked. :p

leigh123linux
19th April 2008, 07:05 PM
Solution

http://forums.fedoraforum.org/forum/showpost.php?p=998692&postcount=949

Jongi
20th April 2008, 11:37 AM
Leigh,

I've enabled that option and the same error occurs. Even after rebooting.

EDIT: Does it matter whether I am running gdm or kdm? for what it's worth I think I am running gdm



[root:~#] ps aux | grep gdm
root 2319 0.0 0.3 200856 3760 ? Ss 12:32 0:00 /usr/sbin/gdm-binary -nodaemon
root 2397 0.0 0.3 227332 3360 ? S 12:32 0:00 /usr/sbin/gdm-binary -nodaemon
root 2399 20.5 4.3 132220 44580 tty7 RLs+ 12:32 11:21 /usr/bin/X :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
root 17212 0.0 0.0 82240 756 pts/0 S+ 13:27 0:00 grep gdm
[root:~#] ps aux | grep kdm
root 17455 0.0 0.0 82236 752 pts/0 S+ 13:28 0:00 grep kdm

Jongi
25th April 2008, 10:37 PM
So Leigh, to confirm, you state that xine works for you in xfce using your compiz packages?

Can you provide me with xine and compiz packages installed? On your F8 x86_64 install.

leigh123linux
25th April 2008, 10:58 PM
So Leigh, to confirm, you state that xine works for you in xfce using your compiz packages?

Can you provide me with xine and compiz packages installed? On your F8 x86_64 install.


Xine works fine for me with compiz in XFCE !



[leigh@localhost ~]$ rpm -qa |grep xine
xine-0.99.5-1.lvn8
xine-lib-1.1.11.1-1.fc8.1
xine-lib-extras-nonfree-1.1.11.1-1.lvn8
totem-xine-2.20.1-1.lvn8
xine-lib-extras-1.1.11.1-1.fc8.1
[leigh@localhost ~]$ rpm -qa |grep 0.7.5
compizconfig-python-0.7.5-4.fc8
compizconfig-backend-gconf-0.7.5-4.fc8
emerald-0.7.5-4.fc8
compiz-fusion-plugins-extra-0.7.5-4.fc8
compiz-bcop-0.7.5-4.fc8
libcompizconfig-0.7.5-4.fc8
compiz-fusion-plugins-unsupported-0.7.5-4.fc8
emerald-themes-0.7.5-4.fc8
compiz-0.7.5-8.fc8
ccsm-0.7.5-5.fc8
compiz-fusion-plugins-main-0.7.5-5.fc8
[leigh@localhost ~]$