PDA

View Full Version : Networking Crashes Laptop since 2.6.24.4-64.fc8



tonypmartin
19th April 2008, 07:54 AM
I have been waiting to see if this turned out to be a common problem, or got fixed in an update. But it still happens if I boot into 2.6.24.4-64.fc8 kernel and allow NetworkManager, the bootup just freezes at that point.

If I boot interactively and do not enable NetworManager, then the system will start and wired networking is ok. If I look in network config, I always get a config for wlan0.bak. If I try to activate that, the PC freezes and I have to force power off.

If I try removing the bak, it just reappears, in addition to the the non bak profile. Again if I try to activate the new profile my PC freezes.

iwconfig yields

lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11 ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

The driver is rt2500pci
and I have tried modprobe -r/-i to with no improvement.

It all worked really well for this kernel version right up to the most recent update. Now, I can only run wireless on the old kernel version.

I dont know what to try - I can only think the driver has changed and is now incompatable in some way.
Please Help!
Tony

cappa72
23rd April 2008, 02:41 PM
Hi,

I had a similar problem with several distributions including Fedora, but my problem was that my pcmci card did not work with rt2500pci module anyhow. I turned off the allowance in the networkmanager to handle wlan0. I used a script instead.
Collecting the experiene I summarised them in a file that can be found in a Hungarian website (skl-projekt.hu) , but maybe usable for you.
Since the site is temporarily under maintenance in the attached file you can find my description. (I have to stress the facat that it is a possible workaround.)
Hopefully it helps. If not, please give feedback to me.

remark: I am using F7 currently (for some reason F8 did not want me...)

tonypmartin
24th April 2008, 07:08 AM
thanks for your response and the copy of the document, i am away for a couple of days, but when i get back i will give it a go. It will be an interesting exercise if nothing else.

There are a couple of responses at this thread
http://www.fedoraforum.org/forum/showthread.php?t=186625
which say that the driver problem should be fixed in the new kernel and that is now available in test version. So that is another possible approach.

Also, I shall be upgrading to F9 as soon as it is officially released, so hopefully, the problem will be solved one way or another

Thanks
Tonypm

bbfuller
24th April 2008, 09:28 AM
Hello tonypmartin

Certainly the Fedora 9 preview doesn't exhibit that problem.

tonypmartin
7th May 2008, 05:38 PM
Good news - With the latest kernel update, 2.6.24.5-85 it is now fixed.

Thanks to whoever, for that!!