PDA

View Full Version : Software Trouble in Fedora 8



Jamwa
18th April 2008, 09:37 PM
Hi,

I recently used you to update a lot of packages on my Fedora 7. All went well, thanks.

So it was gimp's turn.

yum update gimp

went the command and all was smooth. A reboot later and all was ok until I realized nautilus wasnt working thus I had to leave gnome and use kde. (Note that I have nothing against kde). So I tried running nautilus on the command line and what I get shocks me as I have no idea what on earth is going on:

[root@hedgehog arthur]# nautilus
nautilus: symbol lookup error: nautilus: undefined symbol: g_once_init_enter_impl
[root@hedgehog arthur]#

Gimp also fails running with the same error. And so does system-config-network:

[root@hedgehog arthur]# system-config-network
Component: system-config-network
Version: 1.4.7
Summary: TB20d3cafa __init__.py:13:<module>:ImportError: /usr/lib/libgnomevfs-2.so.0: undefined symbol: g_once_init_enter_impl

Traceback (most recent call last):
File "/usr/sbin/system-config-network-gui", line 139, in runit
import gnome
File "/usr/lib/python2.5/site-packages/gtk-2.0/gnome/__init__.py", line 13, in <module>
from _gnome import *
ImportError: /usr/lib/libgnomevfs-2.so.0: undefined symbol: g_once_init_enter_impl

Local variables in innermost frame:
__builtins__: {'IndexError': <type 'exceptions.IndexError'>, 'all': <built-in function all>, 'help': Type help() for interactive help, or help(object) for help about obj....
// I have truncated this


What do I do? A lot of googling around hasnt helped me much

ryptyde
19th April 2008, 12:26 AM
Create another user or login to one if you have created one in advance in the event of a desktop glitch. A good place to start ad maybe easy to remedy, has worked for me in the past without having to reinstall. :)

EDIT: Also try booting to a previous kernel!

Jamwa
19th April 2008, 12:03 PM
Am afraid but a new account still hasnt solved the issue

leigh123linux
19th April 2008, 12:07 PM
Try



su
yum install yum-utils


Then post



su
package-cleanup --problems
package-cleanup --dupes

Jamwa
19th April 2008, 12:57 PM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# yum install yum-utils
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 11:51:15 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/i386/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package yum-utils.noarch 0:1.1.11-1.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
yum-utils noarch 1.1.11-1.fc8 updates 52 k

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 52 k
Is this ok [y/N]: y
Downloading Packages:
(1/1): yum-utils-1.1.11-1 100% |=========================| 52 kB 00:02
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: yum-utils ######################### [1/1]

Installed: yum-utils.noarch 0:1.1.11-1.fc8
Complete!
[root@hedgehog arthur]#
[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package mono-web requires mono-core = 1.1.13.4-2
Package ant-apache-log4j requires libgcj.so.7
Package unixODBC-kde requires unixODBC = 2.2.11-6.2.1
Package gcc-gnat requires gcc = 4.1.0-3
Package freeradius requires libpq.so.4
Package java-1.4.2-gcj-compat-src requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_83rh
Package f-spot requires mono(gconf-sharp) = 2.8.0.0
Package f-spot requires mono(gdk-sharp) = 2.8.0.0
Package f-spot requires mono(glade-sharp) = 2.8.0.0
Package f-spot requires mono(glib-sharp) = 2.8.0.0
Package f-spot requires mono(gnome-sharp) = 2.8.0.0
Package f-spot requires mono(gnome-vfs-sharp) = 2.8.0.0
Package f-spot requires mono(gtk-sharp) = 2.8.0.0
Package f-spot requires mono(gtkhtml-sharp) = 2.8.0.0
Package f-spot requires mono(pango-sharp) = 2.8.0.0
Package postgresql-odbc requires libpq.so.4
Package geronimo-specs requires libgcj.so.7
Package mono-data-sqlite requires mono-core = 1.1.13.4-2
Package neon-devel requires neon = 0.25.5-1.2
Package dbus-sharp requires dbus = 0.61-3
Package java-1.4.2-gcj-compat-javadoc requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_83rh
Package libswt3-gtk2 requires libgcj.so.7
Package ant-swing requires libgcj.so.7
Package nmap-frontend requires nmap = 2:4.00
Package ant-junit requires libgcj.so.7
Package kdesdk-devel requires kdesdk = 3.5.1-1.2
Package devhelp requires gecko-libs = 1.8.1.3
Package ruby-devel requires ruby-libs = 1.8.4-3.2
Package openldap-servers requires openldap = 2.3.19-4
Package ant requires libgcj.so.7
Package gcc-objc requires gcc = 4.1.0-3
Package ant-apache-regexp requires libgcj.so.7
Package compat-openldap requires openldap = 2.3.19-4
Package postgresql-pl requires libpython2.4.so.1.0
Package postgresql-pl requires postgresql = 8.1.3-1
Package postgresql-pl requires postgresql-server = 8.1.3-1
Package libusb-devel requires libusb = 0.1.11
Package yelp requires gecko-libs = 1.8.1.3
Package xchat requires libdbus-1.so.2
Package ant-javamail requires libgcj.so.7
Package libgconf-java requires libgcj.so.7
Package gnucash requires libguile-ltdl.so.1
Package gnucash requires libguile.so.12
Package gnucash requires libqthreads.so.12
Package libvte-java requires libgcj.so.7
Package libvte-java requires libvte.so.4
Package cairo-java requires libgcj.so.7
Package hal-gnome requires hal = 0.5.7-3
Package ant-trax requires libgcj.so.7
Package kdeedu requires libpython2.4.so.1.0
Package ant-apache-resolver requires libgcj.so.7
Package g-wrap requires libguile-ltdl.so.1
Package g-wrap requires libguile.so.12
Package g-wrap requires libqthreads.so.12
Package qt-ODBC requires qt = 1:3.3.5-13
Package ant-apache-bsf requires libgcj.so.7
Package postgresql-tcl requires libpq.so.4
Package ant-apache-bcel requires libgcj.so.7
Package avahi-tools requires avahi = 0.6.9
Package avahi-tools requires libavahi-core.so.4
Package avahi-tools requires libdbus-1.so.2
Package avahi-tools requires python(abi) = 2.4
Package aqbanking requires python(abi) = 2.4
Package postgresql-test requires postgresql = 8.1.3-1
Package postgresql-test requires postgresql-server = 8.1.3-1
Package ant-nodeps requires libgcj.so.7
Package krb5-server requires krb5-libs = 1.4.3-4.1
Package xmlrpc requires libgcj.so.7
Package evolution-connector requires libcamel-1.2.so.0
Package evolution-connector requires libcamel-provider-1.2.so.8
Package evolution-connector requires libebook-1.2.so.5
Package evolution-connector requires libecal-1.2.so.3
Package evolution-connector requires libedata-cal-1.2.so.1
Package evolution-connector requires libedataserver-1.2.so.7
Package evolution-connector requires libedataserverui-1.2.so.6
Package evolution-connector requires libexchange-storage-1.2.so.1
Package evolution-connector requires libgnutls.so.12
Package libgtk-java requires libgcj.so.7
Package libgnome-java requires libgcj.so.7
Package netatalk requires libgssapi.so.1
Package net-snmp-utils requires libnetsnmp.so.10
Package net-snmp-utils requires net-snmp = 5.3
Package lucene requires libgcj.so.7
Package jsch requires libgcj.so.7
Package xalan-j2-xsltc requires libgcj.so.7
Package mysql-bench requires mysql = 5.0.18-2.1
Package bluez-utils-cups requires libbluetooth.so.1
Package postgresql-docs requires postgresql = 8.1.3-1
Package vim-X11 requires vim-common = 1:6.4.007-4
Package ant-commons-logging requires libgcj.so.7
Package openoffice.org-testtools requires openoffice.org-core = 1:2.0.2-5.2.2
Package ant-jdepend requires libgcj.so.7
Package xalan-j2-demo requires libgcj.so.7
Package xalan-j2-demo requires xalan-j2 = 0:2.6.0-3jpp_9fc
Package libglade-java requires libgcj.so.7
Package ant-antlr requires libgcj.so.7
Package mono-data requires mono-core = 1.1.13.4-2
Package lucene-demo requires libgcj.so.7
Package gnutls-utils requires gnutls = 1.2.10-1
Package gnutls-utils requires libgnutls-extra.so.12
Package gnutls-utils requires libgnutls-extra.so.12(GNUTLS_1_2)
Package gnutls-utils requires libgnutls.so.12
Package gnutls-utils requires libgnutls.so.12(GNUTLS_1_2)
Package ant-apache-oro requires libgcj.so.7
Package gamin-devel requires gamin = 0.1.7
Package qt-MySQL requires qt = 1:3.3.5-13
Package krbafs-utils requires krbafs = 1.2.2-9.2.1
Package xerces-j2-scripts requires xerces-j2 = 0:2.7.1-6jpp_7fc
Package ant-jsch requires libgcj.so.7
Package evolution-sharp requires libebook-1.2.so.5
Package evolution-sharp requires libecal-1.2.so.3
Package evolution-sharp requires libedataserver-1.2.so.7
Package evolution-sharp requires mono(glib-sharp) = 2.8.0.0
Package postgresql-contrib requires libpq.so.4
Package postgresql-contrib requires postgresql = 8.1.3-1
Package xml-commons-which requires libgcj.so.7
Package xml-commons-which requires xml-commons = 0:1.3.02-0.b2.7jpp_7fc
Package php-mbstring requires php = 5.1.2-5
Package xerces-j2-demo requires libgcj.so.7
Package xerces-j2-demo requires xerces-j2 = 0:2.7.1-6jpp_7fc
Package gsf-sharp requires libgsf-1.so.113
Package gsf-sharp requires libgsf-gnome-1.so.113
Package gsf-sharp requires mono(glib-sharp) = 2.8.0.0
Package mysql-devel requires mysql = 5.0.18-2.1
[root@hedgehog arthur]#

[root@hedgehog arthur]# package-cleanup --dupes
Setting up yum
gutenprint-5.0.1-5.fc8.i386
gutenprint-5.0.1-3.fc7.i386
[root@hedgehog arthur]#

leigh123linux
19th April 2008, 01:09 PM
Well that don't look good , you have a lot of broken deps


post


rpm -qa |grep mono


rpm -qa |grep mysql

Jamwa
19th April 2008, 01:17 PM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm -qa |grep mono
mono-web-1.1.13.4-2
mono-core-1.2.3-3.fc7
mono-data-1.1.13.4-2
mono-data-sqlite-1.1.13.4-2
[root@hedgehog arthur]# rpm -qa |grep mysql
mysql-connector-odbc-3.51.12-2.2
mysql-workbench-5.0r3-1fc5
mysql-devel-5.0.18-2.1
mysql-administrator-5.0r3-1fc5
mysql-5.0.37-2.fc7
libdbi-dbd-mysql-0.8.1a-2.fc7
mysql-libs-5.0.37-2.fc7
mysql-server-5.0.37-2.fc7
php-mysql-5.2.2-3
mysql-bench-5.0.18-2.1
mysql-query-browser-5.0r3-1fc5
mod_auth_mysql-3.0.0-3.1
mysql-gui-tools-5.0r3-1fc5
[root@hedgehog arthur]#

leigh123linux
19th April 2008, 01:26 PM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm -qa |grep mono
mono-web-1.1.13.4-2
mono-core-1.2.3-3.fc7
mono-data-1.1.13.4-2
mono-data-sqlite-1.1.13.4-2
[root@hedgehog arthur]# rpm -qa |grep mysql
mysql-connector-odbc-3.51.12-2.2
mysql-workbench-5.0r3-1fc5
mysql-devel-5.0.18-2.1
mysql-administrator-5.0r3-1fc5
mysql-5.0.37-2.fc7
libdbi-dbd-mysql-0.8.1a-2.fc7
mysql-libs-5.0.37-2.fc7
mysql-server-5.0.37-2.fc7
php-mysql-5.2.2-3
mysql-bench-5.0.18-2.1
mysql-query-browser-5.0r3-1fc5
mod_auth_mysql-3.0.0-3.1
mysql-gui-tools-5.0r3-1fc5
[root@hedgehog arthur]#


Try


su
yum update mono-core mono-data-sqlite mono-data mono-web
yum update mysql*

Post the output

Jamwa
19th April 2008, 01:49 PM
Whilst it downloads the packages, may I inquire about what the mono package does?

leigh123linux
19th April 2008, 02:32 PM
Whilst it downloads the packages, may I inquire about what the mono package does?


It's needed as a dep for f-spot & evolution-sharp

http://www.mono-project.com/Main_Page

I am just working my way through that large list of broken deps

Jamwa
19th April 2008, 02:43 PM
[root@hedgehog arthur]# yum update mono-core mono-data-sqlite mono-data mono-web
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 12:42:55 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:01
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mono-web.i386 0:1.2.5.1-3.fc8 set to be updated
--> Processing Dependency: mono(System.Windows.Forms) = 2.0.0.0 for package: mono-web
---> Package mono-core.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data-sqlite.i386 0:1.2.5.1-3.fc8 set to be updated
--> Running transaction check
---> Package mono-winforms.i386 0:1.2.5.1-3.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
mono-core i386 1.2.5.1-3.fc8 updates 12 M
mono-data i386 1.2.5.1-3.fc8 updates 1.8 M
mono-data-sqlite i386 1.2.5.1-3.fc8 updates 173 k
mono-web i386 1.2.5.1-3.fc8 updates 2.7 M
Installing for dependencies:
mono-winforms i386 1.2.5.1-3.fc8 updates 3.6 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 4 Package(s)
Remove 0 Package(s)

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): mono-data-sqlite-1 100% |=========================| 173 kB 00:22
(2/5): mono-data-1.2.5.1- 100% |=========================| 1.8 MB 02:45
(3/5): mono-winforms-1.2. 100% |=========================| 3.6 MB 05:58
(4/5): mono-core-1.2.5.1- 100% |=========================| 9.0 MB 14:09
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/i386/mono-core-1.2.5.1-3.fc8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(4/5): mono-core-1.2.5.1- 100% |=========================| 12 MB 19:03
(5/5): mono-web-1.2.5.1-3 100% |=========================| 2.7 MB 04:40
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : mono-core ######################### [1/9]
Updating : mono-data ######################### [2/9]
Updating : mono-data-sqlite ######################### [3/9]
Updating : mono-web ######################### [4/9]
Installing: mono-winforms ######################### [5/9]
Cleanup : mono-web ######################### [6/9]
Cleanup : mono-core ######################### [7/9]
Cleanup : mono-data ######################### [8/9]
Cleanup : mono-data-sqlite ######################### [9/9]

Dependency Installed: mono-winforms.i386 0:1.2.5.1-3.fc8
Updated: mono-core.i386 0:1.2.5.1-3.fc8 mono-data.i386 0:1.2.5.1-3.fc8 mono-data-sqlite.i386 0:1.2.5.1-3.fc8 mono-web.i386 0:1.2.5.1-3.fc8
Complete!
[root@hedgehog arthur]# yum update mysql*
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 13:36:56 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-administrator.i386 0:5.0r12-4.fc8 set to be updated
--> Processing Dependency: mysql-gui-common = 5.0r12-4.fc8 for package: mysql-administrator
---> Package mysql-gui-tools.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-server.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-connector-odbc.i386 0:3.51.14r248-2.fc8 set to be updated
--> Processing Dependency: mysql-gui-tools = 5.0r3 for package: mysql-workbench
---> Package mysql.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-devel.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-query-browser.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-libs.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-bench.i386 0:5.0.45-6.fc8 set to be updated
--> Running transaction check
--> Processing Dependency: mysql-gui-tools = 5.0r3 for package: mysql-workbench
---> Package mysql-gui-common.i386 0:5.0r12-4.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: mysql-gui-tools = 5.0r3 is needed by package mysql-workbench
[root@hedgehog arthur]#

stevea
19th April 2008, 02:44 PM
The symbol that nautilus was missing is in /lib/libglib-2.0.so.0 which is part of the package. glib2-2.14.6-1.fc8 in the current F8.

ldd /usr/bin/nautilus
should show you the necessary libraries and indicate the missing ones.

I have no idea why you have so many missing libraries. Something went horribly wrong.

leigh123linux
19th April 2008, 03:06 PM
[root@hedgehog arthur]# yum update mono-core mono-data-sqlite mono-data mono-web
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 12:42:55 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:01
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mono-web.i386 0:1.2.5.1-3.fc8 set to be updated
--> Processing Dependency: mono(System.Windows.Forms) = 2.0.0.0 for package: mono-web
---> Package mono-core.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data.i386 0:1.2.5.1-3.fc8 set to be updated
---> Package mono-data-sqlite.i386 0:1.2.5.1-3.fc8 set to be updated
--> Running transaction check
---> Package mono-winforms.i386 0:1.2.5.1-3.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
mono-core i386 1.2.5.1-3.fc8 updates 12 M
mono-data i386 1.2.5.1-3.fc8 updates 1.8 M
mono-data-sqlite i386 1.2.5.1-3.fc8 updates 173 k
mono-web i386 1.2.5.1-3.fc8 updates 2.7 M
Installing for dependencies:
mono-winforms i386 1.2.5.1-3.fc8 updates 3.6 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 4 Package(s)
Remove 0 Package(s)

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): mono-data-sqlite-1 100% |=========================| 173 kB 00:22
(2/5): mono-data-1.2.5.1- 100% |=========================| 1.8 MB 02:45
(3/5): mono-winforms-1.2. 100% |=========================| 3.6 MB 05:58
(4/5): mono-core-1.2.5.1- 100% |=========================| 9.0 MB 14:09
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/i386/mono-core-1.2.5.1-3.fc8.i386.rpm: [Errno 4] Socket Error: timed out
Trying other mirror.
(4/5): mono-core-1.2.5.1- 100% |=========================| 12 MB 19:03
(5/5): mono-web-1.2.5.1-3 100% |=========================| 2.7 MB 04:40
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : mono-core ######################### [1/9]
Updating : mono-data ######################### [2/9]
Updating : mono-data-sqlite ######################### [3/9]
Updating : mono-web ######################### [4/9]
Installing: mono-winforms ######################### [5/9]
Cleanup : mono-web ######################### [6/9]
Cleanup : mono-core ######################### [7/9]
Cleanup : mono-data ######################### [8/9]
Cleanup : mono-data-sqlite ######################### [9/9]

Dependency Installed: mono-winforms.i386 0:1.2.5.1-3.fc8
Updated: mono-core.i386 0:1.2.5.1-3.fc8 mono-data.i386 0:1.2.5.1-3.fc8 mono-data-sqlite.i386 0:1.2.5.1-3.fc8 mono-web.i386 0:1.2.5.1-3.fc8
Complete!
[root@hedgehog arthur]# yum update mysql*
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 13:36:56 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-administrator.i386 0:5.0r12-4.fc8 set to be updated
--> Processing Dependency: mysql-gui-common = 5.0r12-4.fc8 for package: mysql-administrator
---> Package mysql-gui-tools.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-server.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-connector-odbc.i386 0:3.51.14r248-2.fc8 set to be updated
--> Processing Dependency: mysql-gui-tools = 5.0r3 for package: mysql-workbench
---> Package mysql.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-devel.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-query-browser.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-libs.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-bench.i386 0:5.0.45-6.fc8 set to be updated
--> Running transaction check
--> Processing Dependency: mysql-gui-tools = 5.0r3 for package: mysql-workbench
---> Package mysql-gui-common.i386 0:5.0r12-4.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: mysql-gui-tools = 5.0r3 is needed by package mysql-workbench
[root@hedgehog arthur]#


Try



su
rpm -e mysql-workbench
yum update mysql*

Jamwa
19th April 2008, 03:07 PM
[root@hedgehog arthur]# ldd /usr/bin/nautilus
linux-gate.so.1 => (0x00110000)
libnautilus-extension.so.1 => /usr/lib/libnautilus-extension.so.1 (0x00ce2000)
libeel-2.so.2 => /usr/lib/libeel-2.so.2 (0x00d39000)
libgailutil.so.18 => /usr/lib/libgailutil.so.18 (0x07fe2000)
libglade-2.0.so.0 => /usr/lib/libglade-2.0.so.0 (0x078ad000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0x0287e000)
librsvg-2.so.2 => /usr/lib/librsvg-2.so.2 (0x0629e000)
libesd.so.0 => /usr/lib/libesd.so.0 (0x05cce000)
libaudiofile.so.0 => /usr/lib/libaudiofile.so.0 (0x07fb5000)
libgnome-desktop-2.so.2 => /usr/lib/libgnome-desktop-2.so.2 (0x06282000)
libgnomeui-2.so.0 => /usr/lib/libgnomeui-2.so.0 (0x06182000)
libSM.so.6 => /usr/lib/libSM.so.6 (0x00c17000)
libICE.so.6 => /usr/lib/libICE.so.6 (0x00be8000)
libbonoboui-2.so.0 => /usr/lib/libbonoboui-2.so.0 (0x0621a000)
libgnomecanvas-2.so.0 => /usr/lib/libgnomecanvas-2.so.0 (0x07e4c000)
libgnome-2.so.0 => /usr/lib/libgnome-2.so.0 (0x0616a000)
libpopt.so.0 => /lib/libpopt.so.0 (0x02598000)
libbonobo-2.so.0 => /usr/lib/libbonobo-2.so.0 (0x07cbe000)
libbonobo-activation.so.4 => /usr/lib/libbonobo-activation.so.4 (0x07d24000)
libart_lgpl_2.so.2 => /usr/lib/libart_lgpl_2.so.2 (0x00152000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0x00327000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0x00205000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0x00309000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0x0016b000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0x006c7000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0x00294000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0x00184000)
libgnomevfs-2.so.0 => /usr/lib/libgnomevfs-2.so.0 (0x06106000)
libgconf-2.so.4 => /usr/lib/libgconf-2.so.4 (0x07be7000)
libgmodule-2.0.so.0 => /lib/libgmodule-2.0.so.0 (0x00142000)
libdl.so.2 => /lib/libdl.so.2 (0x00963000)
libORBit-2.so.0 => /usr/lib/libORBit-2.so.0 (0x07b8d000)
libgthread-2.0.so.0 => /lib/libgthread-2.0.so.0 (0x006ed000)
librt.so.1 => /lib/librt.so.1 (0x00147000)
libgobject-2.0.so.0 => /lib/libgobject-2.0.so.0 (0x006f2000)
libglib-2.0.so.0 => /lib/libglib-2.0.so.0 (0x00c38000)
libstartup-notification-1.so.0 => /usr/lib/libstartup-notification-1.so.0 (0x007a0000)
libX11.so.6 => /usr/lib/libX11.so.6 (0x0099f000)
libexif.so.12 => /usr/lib/libexif.so.12 (0x07f1f000)
libm.so.6 => /lib/libm.so.6 (0x00938000)
libpthread.so.0 => /lib/libpthread.so.0 (0x0097f000)
libc.so.6 => /lib/libc.so.6 (0x007dd000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0x00b49000)
libgnome-menu.so.2 => /usr/lib/libgnome-menu.so.2 (0x00cfa000)
libgnome-keyring.so.0 => /usr/lib/libgnome-keyring.so.0 (0x07dd4000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0x002d8000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0x00bc5000)
libXext.so.6 => /usr/lib/libXext.so.6 (0x00aab000)
libz.so.1 => /lib/libz.so.1 (0x0096a000)
libgsf-1.so.114 => /usr/lib/libgsf-1.so.114 (0x07eb4000)
libcroco-0.6.so.3 => /usr/lib/libcroco-0.6.so.3 (0x02117000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00b94000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00abd000)
libasound.so.2 => /lib/libasound.so.2 (0x05bed000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x00dd4000)
libORBitCosNaming-2.so.0 => /usr/lib/libORBitCosNaming-2.so.0 (0x00799000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00c10000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0x00be3000)
libXi.so.6 => /usr/lib/libXi.so.6 (0x00bd0000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0x00bda000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0x00c04000)
libdbus-glib-1.so.2 => /usr/lib/libdbus-glib-1.so.2 (0x00775000)
libdbus-1.so.3 => /lib/libdbus-1.so.3 (0x07b50000)
libssl.so.6 => /lib/libssl.so.6 (0x07ad4000)
libcrypto.so.6 => /lib/libcrypto.so.6 (0x078e0000)
libavahi-glib.so.1 => /usr/lib/libavahi-glib.so.1 (0x00794000)
libavahi-common.so.3 => /usr/lib/libavahi-common.so.3 (0x07f70000)
libavahi-client.so.3 => /usr/lib/libavahi-client.so.3 (0x07f7e000)
libresolv.so.2 => /lib/libresolv.so.2 (0x00c22000)
libselinux.so.1 => /lib/libselinux.so.1 (0x00751000)
libutil.so.1 => /lib/libutil.so.1 (0x00df8000)
/lib/ld-linux.so.2 (0x007be000)
libXau.so.6 => /usr/lib/libXau.so.6 (0x0099a000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00aa3000)
libfam.so.0 => /usr/lib/libfam.so.0 (0x00cd9000)
libbz2.so.1 => /usr/lib/libbz2.so.1 (0x07f9c000)
libexpat.so.0 => /lib/libexpat.so.0 (0x00b71000)
libnsl.so.1 => /lib/libnsl.so.1 (0x006d2000)
libcap.so.1 => /lib/libcap.so.1 (0x07b4b000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x07b1b000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x07a14000)
libcom_err.so.2 => /lib/libcom_err.so.2 (0x007ad000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x07aa7000)
libsepol.so.1 => /lib/libsepol.so.1 (0x00dfc000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x007b2000)
libkeyutils.so.1 => /lib/libkeyutils.so.1 (0x07acf000)
[root@hedgehog arthur]#

Jamwa
19th April 2008, 04:26 PM
[root@hedgehog arthur]# rpm -e mysql-workbench
[root@hedgehog arthur]# yum update mysql*
livna 100% |=========================| 2.1 kB 00:00
http://fedora.ifc.unam.mx/releases/8/Everything/i386/os/repodata/repomd.xml: [Errno 14] HTTP Error 403: Date: Sat, 19 Apr 2008 14:58:39 GMT
Server: Apache/2.2.8 (Fedora)
Content-Length: 334
Content-Type: text/html; charset=iso-8859-1

Trying other mirror.
fedora 100% |=========================| 2.1 kB 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
updates 100% |=========================| 2.3 kB 00:00
freshrpms 100% |=========================| 2.1 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql-administrator.i386 0:5.0r12-4.fc8 set to be updated
--> Processing Dependency: mysql-gui-common = 5.0r12-4.fc8 for package: mysql-administrator
---> Package mysql-gui-tools.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-server.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-connector-odbc.i386 0:3.51.14r248-2.fc8 set to be updated
---> Package mysql.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-devel.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-query-browser.i386 0:5.0r12-4.fc8 set to be updated
---> Package mysql-libs.i386 0:5.0.45-6.fc8 set to be updated
---> Package mysql-bench.i386 0:5.0.45-6.fc8 set to be updated
--> Running transaction check
---> Package mysql-gui-common.i386 0:5.0r12-4.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
mysql i386 5.0.45-6.fc8 updates 2.7 M
mysql-administrator i386 5.0r12-4.fc8 updates 1.6 M
mysql-bench i386 5.0.45-6.fc8 updates 507 k
mysql-connector-odbc i386 3.51.14r248-2.fc8 fedora 147 k
mysql-devel i386 5.0.45-6.fc8 updates 2.4 M
mysql-gui-tools i386 5.0r12-4.fc8 updates 11 k
mysql-libs i386 5.0.45-6.fc8 updates 1.5 M
mysql-query-browser i386 5.0r12-4.fc8 updates 1.4 M
mysql-server i386 5.0.45-6.fc8 updates 9.8 M
Installing for dependencies:
mysql-gui-common i386 5.0r12-4.fc8 updates 216 k

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 9 Package(s)
Remove 0 Package(s)

Total download size: 20 M
Is this ok [y/N]: y
Downloading Packages:
http://mirror.cogentco.com/pub/linux/fedora/linux/updates/8/i386/mysql-bench-5.0.45-6.fc8.i386.rpm: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
(1/7): mysql-bench-5.0.45 100% |=========================| 507 kB 00:44
(2/7): mysql-query-browse 100% |=========================| 1.4 MB 02:05
(3/7): mysql-devel-5.0.45 100% |=========================| 2.4 MB 03:37
(4/7): mysql-gui-common-5 100% |=========================| 216 kB 00:22
(5/7): mysql-connector-od 100% |=========================| 147 kB 00:04
(6/7): mysql-gui-tools-5. 100% |=========================| 11 kB 00:00
(7/7): mysql-administrato 100% |=========================| 1.6 MB 02:28
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : mysql-libs ####################### [ 1/19]
Updating : mysql ####################### [ 2/19]
Updating : mysql-server ####################### [ 3/19]
Updating : mysql-connector-odbc ####################### [ 4/19]
Installing: mysql-gui-common ####################### [ 5/19]
Updating : mysql-devel ####################### [ 6/19]
Updating : mysql-bench ####################### [ 7/19]
Updating : mysql-administrator ####################### [ 8/19]
Updating : mysql-query-browser ####################### [ 9/19]
Updating : mysql-gui-tools ####################### [10/19]
Cleanup : mysql-administrator ####################### [11/19]
Cleanup : mysql-gui-tools ####################### [12/19]
Cleanup : mysql-server ####################### [13/19]
Cleanup : mysql-connector-odbc ####################### [14/19]
Cleanup : mysql ####################### [15/19]
Cleanup : mysql-devel ####################### [16/19]
Cleanup : mysql-query-browser ####################### [17/19]
Cleanup : mysql-libs ####################### [18/19]
Cleanup : mysql-bench ####################### [19/19]

Dependency Installed: mysql-gui-common.i386 0:5.0r12-4.fc8
Updated: mysql.i386 0:5.0.45-6.fc8 mysql-administrator.i386 0:5.0r12-4.fc8 mysql-bench.i386 0:5.0.45-6.fc8 mysql-connector-odbc.i386 0:3.51.14r248-2.fc8 mysql-devel.i386 0:5.0.45-6.fc8 mysql-gui-tools.i386 0:5.0r12-4.fc8 mysql-libs.i386 0:5.0.45-6.fc8 mysql-query-browser.i386 0:5.0r12-4.fc8 mysql-server.i386 0:5.0.45-6.fc8
Complete!
[root@hedgehog arthur]#

leigh123linux
19th April 2008, 04:54 PM
Post



su
package-cleanup --problems

Jamwa
19th April 2008, 04:59 PM
Now there is even more trouble:

[root@hedgehog arthur]# xmms
/usr/libexec/xmms: error while loading shared libraries: libglib-1.2.so.0: cannot open shared object file: No such file or directory
[root@hedgehog arthur]#

:)

Jamwa
19th April 2008, 05:02 PM
[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package ant-apache-log4j requires libgcj.so.7
Package unixODBC-kde requires unixODBC = 2.2.11-6.2.1
Package gcc-gnat requires gcc = 4.1.0-3
Package freeradius requires libpq.so.4
Package java-1.4.2-gcj-compat-src requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_83rh
Package f-spot requires mono(gconf-sharp) = 2.8.0.0
Package f-spot requires mono(gdk-sharp) = 2.8.0.0
Package f-spot requires mono(glade-sharp) = 2.8.0.0
Package f-spot requires mono(glib-sharp) = 2.8.0.0
Package f-spot requires mono(gnome-sharp) = 2.8.0.0
Package f-spot requires mono(gnome-vfs-sharp) = 2.8.0.0
Package f-spot requires mono(gtk-sharp) = 2.8.0.0
Package f-spot requires mono(gtkhtml-sharp) = 2.8.0.0
Package f-spot requires mono(pango-sharp) = 2.8.0.0
Package postgresql-odbc requires libpq.so.4
Package geronimo-specs requires libgcj.so.7
Package neon-devel requires neon = 0.25.5-1.2
Package dbus-sharp requires dbus = 0.61-3
Package java-1.4.2-gcj-compat-javadoc requires java-1.4.2-gcj-compat = 0:1.4.2.0-40jpp_83rh
Package libswt3-gtk2 requires libgcj.so.7
Package ant-swing requires libgcj.so.7
Package nmap-frontend requires nmap = 2:4.00
Package ant-junit requires libgcj.so.7
Package kdesdk-devel requires kdesdk = 3.5.1-1.2
Package devhelp requires gecko-libs = 1.8.1.3
Package ruby-devel requires ruby-libs = 1.8.4-3.2
Package openldap-servers requires openldap = 2.3.19-4
Package ant requires libgcj.so.7
Package gcc-objc requires gcc = 4.1.0-3
Package ant-apache-regexp requires libgcj.so.7
Package compat-openldap requires openldap = 2.3.19-4
Package postgresql-pl requires libpython2.4.so.1.0
Package postgresql-pl requires postgresql = 8.1.3-1
Package postgresql-pl requires postgresql-server = 8.1.3-1
Package libusb-devel requires libusb = 0.1.11
Package yelp requires gecko-libs = 1.8.1.3
Package xchat requires libdbus-1.so.2
Package ant-javamail requires libgcj.so.7
Package libgconf-java requires libgcj.so.7
Package gnucash requires libguile-ltdl.so.1
Package gnucash requires libguile.so.12
Package gnucash requires libqthreads.so.12
Package libvte-java requires libgcj.so.7
Package libvte-java requires libvte.so.4
Package cairo-java requires libgcj.so.7
Package hal-gnome requires hal = 0.5.7-3
Package ant-trax requires libgcj.so.7
Package kdeedu requires libpython2.4.so.1.0
Package ant-apache-resolver requires libgcj.so.7
Package g-wrap requires libguile-ltdl.so.1
Package g-wrap requires libguile.so.12
Package g-wrap requires libqthreads.so.12
Package qt-ODBC requires qt = 1:3.3.5-13
Package ant-apache-bsf requires libgcj.so.7
Package postgresql-tcl requires libpq.so.4
Package ant-apache-bcel requires libgcj.so.7
Package avahi-tools requires avahi = 0.6.9
Package avahi-tools requires libavahi-core.so.4
Package avahi-tools requires libdbus-1.so.2
Package avahi-tools requires python(abi) = 2.4
Package aqbanking requires python(abi) = 2.4
Package postgresql-test requires postgresql = 8.1.3-1
Package postgresql-test requires postgresql-server = 8.1.3-1
Package ant-nodeps requires libgcj.so.7
Package krb5-server requires krb5-libs = 1.4.3-4.1
Package xmlrpc requires libgcj.so.7
Package evolution-connector requires libcamel-1.2.so.0
Package evolution-connector requires libcamel-provider-1.2.so.8
Package evolution-connector requires libebook-1.2.so.5
Package evolution-connector requires libecal-1.2.so.3
Package evolution-connector requires libedata-cal-1.2.so.1
Package evolution-connector requires libedataserver-1.2.so.7
Package evolution-connector requires libedataserverui-1.2.so.6
Package evolution-connector requires libexchange-storage-1.2.so.1
Package evolution-connector requires libgnutls.so.12
Package libgtk-java requires libgcj.so.7
Package libgnome-java requires libgcj.so.7
Package netatalk requires libgssapi.so.1
Package net-snmp-utils requires libnetsnmp.so.10
Package net-snmp-utils requires net-snmp = 5.3
Package lucene requires libgcj.so.7
Package jsch requires libgcj.so.7
Package xalan-j2-xsltc requires libgcj.so.7
Package bluez-utils-cups requires libbluetooth.so.1
Package postgresql-docs requires postgresql = 8.1.3-1
Package vim-X11 requires vim-common = 1:6.4.007-4
Package ant-commons-logging requires libgcj.so.7
Package openoffice.org-testtools requires openoffice.org-core = 1:2.0.2-5.2.2
Package ant-jdepend requires libgcj.so.7
Package xalan-j2-demo requires libgcj.so.7
Package xalan-j2-demo requires xalan-j2 = 0:2.6.0-3jpp_9fc
Package libglade-java requires libgcj.so.7
Package ant-antlr requires libgcj.so.7
Package lucene-demo requires libgcj.so.7
Package gnutls-utils requires gnutls = 1.2.10-1
Package gnutls-utils requires libgnutls-extra.so.12
Package gnutls-utils requires libgnutls-extra.so.12(GNUTLS_1_2)
Package gnutls-utils requires libgnutls.so.12
Package gnutls-utils requires libgnutls.so.12(GNUTLS_1_2)
Package ant-apache-oro requires libgcj.so.7
Package gamin-devel requires gamin = 0.1.7
Package qt-MySQL requires qt = 1:3.3.5-13
Package krbafs-utils requires krbafs = 1.2.2-9.2.1
Package xerces-j2-scripts requires xerces-j2 = 0:2.7.1-6jpp_7fc
Package ant-jsch requires libgcj.so.7
Package evolution-sharp requires libebook-1.2.so.5
Package evolution-sharp requires libecal-1.2.so.3
Package evolution-sharp requires libedataserver-1.2.so.7
Package evolution-sharp requires mono(glib-sharp) = 2.8.0.0
Package postgresql-contrib requires libpq.so.4
Package postgresql-contrib requires postgresql = 8.1.3-1
Package xml-commons-which requires libgcj.so.7
Package xml-commons-which requires xml-commons = 0:1.3.02-0.b2.7jpp_7fc
Package php-mbstring requires php = 5.1.2-5
Package xerces-j2-demo requires libgcj.so.7
Package xerces-j2-demo requires xerces-j2 = 0:2.7.1-6jpp_7fc
Package gsf-sharp requires libgsf-1.so.113
Package gsf-sharp requires libgsf-gnome-1.so.113
Package gsf-sharp requires mono(glib-sharp) = 2.8.0.0
[root@hedgehog arthur]#

Jamwa
19th April 2008, 05:04 PM
Just as a word of note that may be of assist, I started with Fedora Core 5 which I upgraded successfully via DVD to 7. Then started the mass upgrade via yum and that spelt the beginning of my woes

leigh123linux
19th April 2008, 05:25 PM
Just as a word of note that may be of assist, I started with Fedora Core 5 which I upgraded successfully via DVD to 7. Then started the mass upgrade via yum and that spelt the beginning of my woes

I had already gathered it was a upgrade

Try



su
yum update

and post the errors

Jamwa
19th April 2008, 06:15 PM
---> Package libgsf-gnome.i386 0:1.14.7-1.fc8 set to be updated
---> Package perl-HTML-TableExtract.noarch 0:2.10-1.fc7 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libxcb = 1.0-4.fc8 is needed by package libxcb-devel
Error: Missing Dependency: libx264.so.56 is needed by package ffmpeg-libs
Error: Missing Dependency: libgnomecanvaspixbuf.so.1 is needed by package gtkhtml


Thats the error message

leigh123linux
19th April 2008, 06:24 PM
Try



su
rpm -Uvh --replacefiles --replacepkgs http://rpm.livna.org/livna-release-8.rpm
rpm -e --nodeps gtkhtml
yum install gtkhtml2
yum install libxcb
yum update

Jamwa
19th April 2008, 07:01 PM
[root@hedgehog arthur]# yum install libxcb
Setting up Install Process
Parsing package install arguments
Nothing to do
[root@hedgehog arthur]# yum update
...
---> Package libgsf-gnome.i386 0:1.14.7-1.fc8 set to be updated
---> Package perl-HTML-TableExtract.noarch 0:2.10-1.fc7 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libxcb = 1.0-4.fc8 is needed by package libxcb-devel
Error: Missing Dependency: libx264.so.56 is needed by package ffmpeg-libs

leigh123linux
19th April 2008, 07:13 PM
Post


rpm -qa |grep libxcb



su
rpm -e fedora-release livna-release
rm -rf /etc/yum.repos.d/*
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
rpm -ivh http://rpm.livna.org/livna-release-8.rpm
yum clean all
yum install x264 libxcb
yum update

A

Jamwa
19th April 2008, 07:22 PM
[root@hedgehog arthur]# rpm -qa |grep libxcb
libxcb-1.1-1.fc7
[root@hedgehog arthur]#

Jamwa
19th April 2008, 07:23 PM
[root@hedgehog arthur]# rpm -e fedora-release livna-release
error: Failed dependencies:
redhat-release is needed by (installed) openoffice.org-redhat-menus-2.3-9238.noarch
/etc/redhat-release is needed by (installed) initscripts-8.54-1.i386
[root@hedgehog arthur]# rm -rf /etc/yum.repos.d/*
[root@hedgehog arthur]#

Jamwa
19th April 2008, 07:24 PM
[root@hedgehog arthur]# rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
Retrieving http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
Preparing... ########################################### [100%]
file /etc/yum.repos.d/fedora-updates-testing.repo from install of fedora-release-8-5.noarch conflicts with file from package fedora-release-8-3.noarch
file /usr/share/fedora-release/f8-fedora.ks from install of fedora-release-8-5.noarch conflicts with file from package fedora-release-8-3.noarch
file /usr/share/fedora-release/livecd-fedora-base-desktop.ks from install of fedora-release-8-5.noarch conflicts with file from package fedora-release-8-3.noarch
[root@hedgehog arthur]# rpm -ivh http://rpm.livna.org/livna-release-8.rpm
Retrieving http://rpm.livna.org/livna-release-8.rpm
Preparing... ########################################### [100%]
package livna-release-8-1.noarch is already installed
[root@hedgehog arthur]# yum clean all
Cleaning up Everything
[root@hedgehog arthur]#

Jamwa
19th April 2008, 07:25 PM
[root@hedgehog arthur]# yum install x264 libxcb
Setting up Install Process
Parsing package install arguments
No package x264 available.
No package libxcb available.
Nothing to do

leigh123linux
19th April 2008, 07:29 PM
Do it again as the first command failed



su
rpm -e --nodeps fedora-release livna-release
rm -rf /etc/yum.repos.d/*
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
rpm -ivh http://rpm.livna.org/livna-release-8.rpm
yum clean all
yum install x264 libxcb
yum update

Jamwa
19th April 2008, 08:17 PM
[root@hedgehog arthur]# rpm -e --nodeps fedora-release livna-release
[root@hedgehog arthur]# rm -rf /etc/yum.repos.d/*
[root@hedgehog arthur]# rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
Retrieving http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/fedora-release-8-5.noarch.rpm
Preparing... ########################################### [100%]
1:fedora-release ########################################### [100%]
[root@hedgehog arthur]# rpm -ivh http://rpm.livna.org/livna-release-8.rpm
Retrieving http://rpm.livna.org/livna-release-8.rpm
Preparing... ########################################### [100%]
1:livna-release ########################################### [100%]
[root@hedgehog arthur]# yum clean all
Cleaning up Everything
[root@hedgehog arthur]# yum install x264 libxcb
fedora 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 4.9 MB 01:54
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 336 kB 00:06
updates 100% |=========================| 2.3 kB 00:00
primary.sqlite.bz2 100% |=========================| 2.1 MB 00:42
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
--> Processing Dependency: libx264.so.54 for package: ffmpeg-libs
---> Package x264.i386 0:0-0.10.20070819.lvn8 set to be updated
--> Running transaction check
---> Package ffmpeg-libs.i386 0:0.4.9-0.41.20071011.lvn8 set to be updated
--> Processing Dependency: faad2 = 1:2.0 for package: ffmpeg-libs
--> Running transaction check
---> Package faad2.i386 1:2.0-21.20050131.lvn8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
faad2 i386 1:2.0-21.20050131.lvn8 livna 210 k
x264 i386 0-0.10.20070819.lvn8 livna 245 k
Updating for dependencies:
ffmpeg-libs i386 0.4.9-0.41.20071011.lvn8 livna 1.8 M

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 3 Package(s)
Remove 0 Package(s)

Total download size: 2.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): x264-0-0.10.200708 100% |=========================| 245 kB 00:05
(2/3): faad2-2.0-21.20050 100% |=========================| 210 kB 00:03
(3/3): ffmpeg-libs-0.4.9- 100% |=========================| 1.8 MB 00:34
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : faad2 ######################### [1/6]
Updating : x264 ######################### [2/6]
Updating : ffmpeg-libs ######################### [3/6]
Cleanup : ffmpeg-libs ######################### [4/6]
Cleanup : faad2 ######################### [5/6]
Cleanup : x264 ######################### [6/6]

Updated: faad2.i386 1:2.0-21.20050131.lvn8 x264.i386 0:0-0.10.20070819.lvn8
Dependency Updated: ffmpeg-libs.i386 0:0.4.9-0.41.20071011.lvn8
Complete!
[root@hedgehog arthur]#yum update
...
--> Finished Dependency Resolution
Error: Missing Dependency: libxcb = 1.0-4.fc8 is needed by package libxcb-devel
[root@hedgehog arthur]#

leigh123linux
19th April 2008, 08:22 PM
Ok


Try


su
yumdownloader libxcb
rpm -Uvh --oldpackage libxcb*rpm
yum update

Jamwa
19th April 2008, 08:52 PM
[root@hedgehog arthur]# yumdownloader libxcb

fedora 100% |=========================| 2.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
libxcb-1.0-4.fc8.i386.rpm 100% |=========================| 117 kB 00:03
[root@hedgehog arthur]# rpm -Uvh --oldpackage libxcb*rpm
Preparing... ########################################### [100%]
1:libxcb ########################################### [100%]
[root@hedgehog arthur]# yum update
...

Transaction Summary
================================================== ===========================
Install 126 Package(s)
Update 1391 Package(s)
Remove 0 Package(s)

Total download size: 1.5 G
Is this ok [y/N]:

leigh123linux
19th April 2008, 09:08 PM
When it's complete post



su
package-cleanup --problems
package-cleanup --dupes

Jamwa
19th April 2008, 09:19 PM
I sure will.

Meanwhile my connection aint so fast neither is it so reliable. Must I sit here overnight for it to finish? Or rather is there a way of pausing it to proceed later in case I have to leave?

Jamwa
19th April 2008, 09:22 PM
I sure will.

Meanwhile my connection aint so fast neither is it so reliable. Must I sit here overnight for it to finish? Or rather is there a way of pausing it to proceed later in case I have to leave?

We currently are at
(32/1517): aspell-en-6.0- 100% |=========================| 1.5 MB 00:31
(33/1517): perl-XML-Simpl 100% |=========================| 72 kB 00:01
(34/1517): fonts-japanese 100% |=========================| 22 MB 08:28
(35/1517): clucene-core-0 100% |=========================| 356 kB 00:08
(36/1517): ant-antlr-1.7. 100% |=========================| 36 kB 00:01
(37/1517): perl-ExtUtils- 100% |=========================| 290 kB 00:07
(38/1517): openoffice.org 15% |=== | 16 MB 22:07 ETA

leigh123linux
19th April 2008, 09:27 PM
To pause it hit Ctrl + c ( don't reboot as I believe it flushes the yum cache ) and to resume just run yum update again .
You could leave it unattended to finish .

Jamwa
19th April 2008, 09:43 PM
Thanks. Will get back as soon as done

Jamwa
22nd April 2008, 12:53 AM
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package kdesdk needs perl(DCOP), this is not available.
Complete!
[root@hedgehog arthur]#

is the output

leigh123linux
22nd April 2008, 01:01 AM
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package kdesdk needs perl(DCOP), this is not available.
Complete!
[root@hedgehog arthur]#

is the output


Try



su
rpm -e --nodeps kdesdk kdesdk-devel
yum update

Jamwa
22nd April 2008, 11:09 AM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm -e --nodeps kdesdk kdesdk-devel
[root@hedgehog arthur]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xfce4-session-engines.i386 0:4.4.2-1.fc8 set to be updated
---> Package perl-Archive-Tar.noarch 0:1.34-1.fc8 set to be updated
---> Package gnome-panel.i386 0:2.20.3-1.fc8 set to be updated
---> Package cracklib.i386 0:2.8.10-3 set to be updated
---> Package libgnome-java.i386 0:2.12.4-7.fc8 set to be updated
---> Package am-utils.i386 5:6.1.
...
Transaction Summary
================================================== ===========================
Install 127 Package(s)
Update 1388 Package(s)
Remove 0 Package(s)

Total download size: 1.4 G
Is this ok [y/N]: y
Downloading Packages:
(1/1): kdebindings-dcoppe 100% |=========================| 44 kB 00:01
Running rpm_check_debug
Running Transaction Test

It has been "Running Transaction Test" for the last 40 minutes. Let me just be patient to see whats up

leigh123linux
22nd April 2008, 11:45 AM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm -e --nodeps kdesdk kdesdk-devel
[root@hedgehog arthur]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xfce4-session-engines.i386 0:4.4.2-1.fc8 set to be updated
---> Package perl-Archive-Tar.noarch 0:1.34-1.fc8 set to be updated
---> Package gnome-panel.i386 0:2.20.3-1.fc8 set to be updated
---> Package cracklib.i386 0:2.8.10-3 set to be updated
---> Package libgnome-java.i386 0:2.12.4-7.fc8 set to be updated
---> Package am-utils.i386 5:6.1.
...
Transaction Summary
================================================== ===========================
Install 127 Package(s)
Update 1388 Package(s)
Remove 0 Package(s)

Total download size: 1.4 G
Is this ok [y/N]: y
Downloading Packages:
(1/1): kdebindings-dcoppe 100% |=========================| 44 kB 00:01
Running rpm_check_debug
Running Transaction Test

It has been "Running Transaction Test" for the last 40 minutes. Let me just be patient to see whats up

The transaction test can take up to a couple of hours on a old CPU !


When the update is complete I will sort out the broken deps from removing kdesdk !

leigh123linux
22nd April 2008, 11:51 AM
[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm -e --nodeps kdesdk kdesdk-devel
[root@hedgehog arthur]# yum update
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package xfce4-session-engines.i386 0:4.4.2-1.fc8 set to be updated
---> Package perl-Archive-Tar.noarch 0:1.34-1.fc8 set to be updated
---> Package gnome-panel.i386 0:2.20.3-1.fc8 set to be updated
---> Package cracklib.i386 0:2.8.10-3 set to be updated
---> Package libgnome-java.i386 0:2.12.4-7.fc8 set to be updated
---> Package am-utils.i386 5:6.1.
...
Transaction Summary
================================================== ===========================
Install 127 Package(s)
Update 1388 Package(s)
Remove 0 Package(s)

Total download size: 1.4 G
Is this ok [y/N]: y
Downloading Packages:
(1/1): kdebindings-dcoppe 100% |=========================| 44 kB 00:01
Running rpm_check_debug
Running Transaction Test

It has been "Running Transaction Test" for the last 40 minutes. Let me just be patient to see whats up


Also your missing dep has appeared :cool:


http://koji.fedoraproject.org/koji/rpminfo?rpmID=421133



Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
Package kdesdk needs perl(DCOP), this is not available.
Complete!
[root@hedgehog arthur]#

is the output

Jamwa
22nd April 2008, 12:25 PM
Finished Transaction Test


Transaction Check Error:
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.database.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.formula.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-master.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-web.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch

Jamwa
22nd April 2008, 12:26 PM
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.openofficeorg.extension.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.base.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.calc.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.calc.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.draw.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.draw.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.impress.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.impress.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.math.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.writer.global.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.writer.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.database.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.formula.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-master.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-web.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.openofficeorg.extension.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.base.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.calc.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.calc.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.draw.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.draw.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.impress.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.impress.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.math.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch

Jamwa
22nd April 2008, 12:26 PM
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.writer.global.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.writer.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.database.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.formula.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.graphics.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.presentation.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.spreadsheet.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-master.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text-web.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.oasis.opendocument.text.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.openofficeorg.extension.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.base.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.calc.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.calc.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.draw.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.draw.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.impress.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.impress.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.math.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.writer.global.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.writer.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of openoffice.org-core-2.3.0-6.11.fc8.i386 conflicts with file from package openoffice.org-redhat-menus-2.3-9238.noarch

Error Summary
-------------

[root@hedgehog arthur]#

leigh123linux
22nd April 2008, 01:28 PM
Try this ( you may have to remove the non repo provided version of openoffice )





su
yum --exclude=openoffice* update

Jamwa
22nd April 2008, 02:04 PM
--> Processing Dependency: libicuuc.so.36 for package: openoffice.org-core
--> Processing Dependency: libneon.so.25 for package: openoffice.org-core
--> Finished Dependency Resolution
Error: Missing Dependency: libicui18n.so.36 is needed by package openoffice.org-core
Error: Missing Dependency: libneon.so.25 is needed by package openoffice.org-core
Error: Missing Dependency: libicule.so.36 is needed by package openoffice.org-core
Error: Missing Dependency: libicuuc.so.36 is needed by package openoffice.org-core
[root@hedgehog arthur]#

leigh123linux
22nd April 2008, 02:15 PM
Ok remove openoffice


do a search


rpm -qa |grep 2.3-9238


And remove all the packages listed using



su
yum erase packagenames_to_be_removed

Then try to update



su
yum update

Jamwa
22nd April 2008, 02:24 PM
[root@hedgehog openoffice.org2.3]# rpm -qa |grep 2.3-9238
openoffice.org-redhat-menus-2.3-9238
[root@hedgehog openoffice.org2.3]# yum erase openoffice.org-redhat-menus-2.3-9238
Setting up Remove Process
fedora 100% |=========================| 2.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package openoffice.org-redhat-menus.noarch 0:2.3-9238 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
openoffice.org-redhat-menus noarch 2.3-9238 installed 763 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 1 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : openoffice.org-redhat-menus ######################### [1/1]
/usr/bin/gtk-update-icon-cache
Cache file created successfully.
/usr/bin/gtk-update-icon-cache
Cache file created successfully.

Removed: openoffice.org-redhat-menus.noarch 0:2.3-9238
Complete!
[root@hedgehog openoffice.org2.3]#

leigh123linux
22nd April 2008, 02:30 PM
See if it will update now



su
yum update

Jamwa
22nd April 2008, 05:07 PM
I think all went ok, the problem is now space. Some packages say "I need 1031 mb of space" whereas I have 700 left. However I have space on other partitions and I was wondering how I could resize

Jamwa
22nd April 2008, 05:36 PM
I start feeling frustrated. GParted is refusing to work. Is it because of this:

[arthur@hedgehog ~]$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
12G 11G 803M 93% /
/dev/sda7 92M 19M 68M 22% /boot
tmpfs 248M 0 248M 0% /dev/shm

leigh123linux
22nd April 2008, 05:46 PM
I start feeling frustrated. GParted is refusing to work. Is it because of this:

[arthur@hedgehog ~]$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
12G 11G 803M 93% /
/dev/sda7 92M 19M 68M 22% /boot
tmpfs 248M 0 248M 0% /dev/shm

Try deleting some old files from /tmp & /home

Jamwa
22nd April 2008, 07:55 PM
After several deletions, I have now managed to recover to 1.1G from 300Mb. However there is something am just not getting. Why does it claim that

Total download size: 1.4 G
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction


[('installing package firefox-2.0.0.13-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38289408L)), ('installing package libbonobo-devel-2.20.3-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38354944L)), ('installing package perl-devel-5.8.8-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38354944L)), ('installing package libglade2-devel-2.6.2-3.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38359040L)), ('installing package libgnomecanvas-devel-2.20.1-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package gail-devel-1.20.2-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package perl-Test-Harness-2.56-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package perl-ExtUtils-MakeMaker-6.30-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package GConf2-devel-2.20.1-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38412288L)), ('installing package python-devel-2.5.1-15.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package java-1.5.0-gcj-devel-1.5.0.0-17.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package perl-CPAN-1.76_02-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package gnome-doc-utils-0.12.0-1.fc8.noarch needs 38MB on the / filesystem', (9, '/', 38993920L)), ('installing package pycairo-devel-1.4.12-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 38993920L)), ('installing package perl-Test-Simple-0.62-38.fc8.i386 needs 38MB on the / filesystem', (9, '/', 38998016L)), ('installing package libgnomeprint22-devel-2.18.2-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39014400L)), ('installing package libsoup-devel-2.2.104-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39047168L)), ('installing package libxslt-devel-1.1.22-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39792640L)), ('installing package libgnome-devel-2.20.1-2.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39796736L)), ('installing package pygobject2-devel-2.14.0-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39800832L)), ('installing package system-config-firewall-tui-1.0.12-4.fc8.noarch needs 40MB on the / filesystem', (9, '/', 41123840L)), ('installing package python-urlgrabber-3.0.0-3.fc8.noarch needs 40MB on the / filesystem', (9, '/', 41201664L)), ('install
....

I mean, I have 1 GB!

[root@hedgehog opt]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
12G 9.9G 1.1G 91% /
/dev/sda7 92M 19M 68M 22% /boot
tmpfs 248M 0 248M 0% /dev/shm
/dev/sda6 40G 35G 4.8G 88% /windows/jukebox
/dev/sda5 15G 9.7G 5.0G 66% /windows/data
/dev/sda1 5.4G 5.1G 310M 95% /windows/core
[root@hedgehog opt]#

leigh123linux
22nd April 2008, 08:06 PM
After several deletions, I have now managed to recover to 1.1G from 300Mb. However there is something am just not getting. Why does it claim that

Total download size: 1.4 G
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction


[('installing package firefox-2.0.0.13-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38289408L)), ('installing package libbonobo-devel-2.20.3-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38354944L)), ('installing package perl-devel-5.8.8-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38354944L)), ('installing package libglade2-devel-2.6.2-3.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38359040L)), ('installing package libgnomecanvas-devel-2.20.1-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package gail-devel-1.20.2-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package perl-Test-Harness-2.56-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package perl-ExtUtils-MakeMaker-6.30-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38379520L)), ('installing package GConf2-devel-2.20.1-1.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38412288L)), ('installing package python-devel-2.5.1-15.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package java-1.5.0-gcj-devel-1.5.0.0-17.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package perl-CPAN-1.76_02-38.fc8.i386 needs 37MB on the / filesystem', (9, '/', 38428672L)), ('installing package gnome-doc-utils-0.12.0-1.fc8.noarch needs 38MB on the / filesystem', (9, '/', 38993920L)), ('installing package pycairo-devel-1.4.12-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 38993920L)), ('installing package perl-Test-Simple-0.62-38.fc8.i386 needs 38MB on the / filesystem', (9, '/', 38998016L)), ('installing package libgnomeprint22-devel-2.18.2-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39014400L)), ('installing package libsoup-devel-2.2.104-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39047168L)), ('installing package libxslt-devel-1.1.22-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39792640L)), ('installing package libgnome-devel-2.20.1-2.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39796736L)), ('installing package pygobject2-devel-2.14.0-1.fc8.i386 needs 38MB on the / filesystem', (9, '/', 39800832L)), ('installing package system-config-firewall-tui-1.0.12-4.fc8.noarch needs 40MB on the / filesystem', (9, '/', 41123840L)), ('installing package python-urlgrabber-3.0.0-3.fc8.noarch needs 40MB on the / filesystem', (9, '/', 41201664L)), ('install
....

I mean, I have 1 GB!

[root@hedgehog opt]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
12G 9.9G 1.1G 91% /
/dev/sda7 92M 19M 68M 22% /boot
tmpfs 248M 0 248M 0% /dev/shm
/dev/sda6 40G 35G 4.8G 88% /windows/jukebox
/dev/sda5 15G 9.7G 5.0G 66% /windows/data
/dev/sda1 5.4G 5.1G 310M 95% /windows/core
[root@hedgehog opt]#


I think you need another 50 Mb of free space for the transaction !

Jamwa
22nd April 2008, 08:07 PM
ok. let me delete some more...

leigh123linux
22nd April 2008, 08:36 PM
ok. let me delete some more...



Try this to free up some space ( yum installs the new package first then removes the old package i.e 100Mb update requires 100Mb for the package download + 100Mb of free space to install it )



su
yum update kernel



Then post


rpm -qa |grep kernel


And I will see if there is anything that can be deleted

Jamwa
22nd April 2008, 08:40 PM
I have just secured a more 100 mb. Let it finish the transaction check. If it fails, then I will do that. Is that OK?

leigh123linux
22nd April 2008, 08:43 PM
I have just secured a more 100 mb. Let it finish the transaction check. If it fails, then I will do that. Is that OK?


Yes , 100Mb should be enough to finish the transaction .

Jamwa
22nd April 2008, 11:16 PM
Updating : libXt-devel ################### [ 926/2952]
Updating : jakarta-commons-collections ################### [ 927/2952]
Updating : jakarta-commons-digester ################### [ 928/2952]
Updating : pango-devel ################### [ 929/2952]
Updating : gtk2-devel ################### [ 930/2952]
Updating : eclipse-ecj ################### [ 931/2952]
Updating : junit ################### [ 932/2952]
Updating : gtksourceview ################### [ 933/2952]

is where I currently am at

Jamwa
23rd April 2008, 02:13 PM
All finished successful. I rebooted to a working installation, thanks. This is the output as requested:

[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package avahi requires libexpat.so.0
Package krbafs-utils requires krbafs = 1.2.2-9.2.1
[root@hedgehog arthur]# package-cleanup --dupes
Setting up yum
avahi-0.6.17-1.fc7.i386
avahi-0.6.21-8.fc8.i386
[root@hedgehog arthur]#

leigh123linux
23rd April 2008, 02:41 PM
Try



su
yum install compat-expat1 kdesdk kdesdk-devel
yum erase krbafs-utils
rpm -e --noscripts avahi-0.6.17-1.fc7.i386


then post


su
package-cleanup --problems
package-cleanup --dupes

Jamwa
23rd April 2008, 04:16 PM
Installed: compat-expat1.i386 0:1.95.8-3 kdesdk-devel.i386 0:3.5.9-1.fc8
Complete!
[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
Missing dependencies:
Package krbafs-utils requires krbafs = 1.2.2-9.2.1
[root@hedgehog arthur]# package-cleanup --dupes
Setting up yum
avahi-0.6.17-1.fc7.i386
avahi-0.6.21-8.fc8.i386
[root@hedgehog arthur]#

leigh123linux
23rd April 2008, 06:10 PM
Post the output for



su
rpm -e --noscripts avahi-0.6.17-1
rpm -qa |grep krbafs
rpm -q avahi

Jamwa
29th April 2008, 06:14 AM
Sorry I was away for a while

[root@hedgehog ~]# rpm -e --noscripts avahi-0.6.17-1
error: package avahi-0.6.17-1 is not installed
[root@hedgehog ~]# rpm -qa |grep krbafs
krbafs-1.2.2-10.1
krbafs-utils-1.2.2-9.2.1
krbafs-devel-1.2.2-10.1
[root@hedgehog ~]# rpm -q avahi
avahi-0.6.17-1.fc7
avahi-0.6.21-8.fc8
[root@hedgehog ~]#


is the output

leigh123linux
29th April 2008, 08:10 AM
Try



su
rpm --noscripts -e avahi-0.6.17-1.fc7

post any errors



Does krbafs still work ? , if it doesn't remove it.



su
yum erase krbafs-devel krbafs krbafs-utils


If you get no errors from either command post


su
package-cleanup --problems
package-cleanup --dupes

Jamwa
29th April 2008, 09:17 AM
I have no idea what krbafs does and whether it is in use or not. My output is

[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm --noscripts -e avahi-0.6.17-1.fc7
[root@hedgehog arthur]# yum erase krbafs-devel krbafs krbafs-utils
Setting up Remove Process
fedora 100% |=========================| 2.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package krbafs-devel.i386 0:1.2.2-10.1 set to be erased
---> Package krbafs-utils.i386 0:1.2.2-9.2.1 set to be erased
---> Package krbafs.i386 0:1.2.2-10.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
krbafs i386 1.2.2-10.1 installed 41 k
krbafs-devel i386 1.2.2-10.1 installed 8.1 k
krbafs-utils i386 1.2.2-9.2.1 installed 33 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 3 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : krbafs-devel ######################### [1/3]
Erasing : krbafs-utils ######################### [2/3]
Erasing : krbafs ######################### [3/3]

Removed: krbafs.i386 0:1.2.2-10.1 krbafs-devel.i386 0:1.2.2-10.1 krbafs-utils.i386 0:1.2.2-9.2.1
Complete!
[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found
[root@hedgehog arthur]# package-cleanup --dupes
Setting up yum
[root@hedgehog arthur]#

leigh123linux
29th April 2008, 09:25 AM
I have no idea what krbafs does and whether it is in use or not. My output is

[arthur@hedgehog ~]$ sudo su
[root@hedgehog arthur]# rpm --noscripts -e avahi-0.6.17-1.fc7
[root@hedgehog arthur]# yum erase krbafs-devel krbafs krbafs-utils
Setting up Remove Process
fedora 100% |=========================| 2.1 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
updates 100% |=========================| 2.3 kB 00:00
Resolving Dependencies
--> Running transaction check
---> Package krbafs-devel.i386 0:1.2.2-10.1 set to be erased
---> Package krbafs-utils.i386 0:1.2.2-9.2.1 set to be erased
---> Package krbafs.i386 0:1.2.2-10.1 set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Removing:
krbafs i386 1.2.2-10.1 installed 41 k
krbafs-devel i386 1.2.2-10.1 installed 8.1 k
krbafs-utils i386 1.2.2-9.2.1 installed 33 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 0 Package(s)
Remove 3 Package(s)

Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Erasing : krbafs-devel ######################### [1/3]
Erasing : krbafs-utils ######################### [2/3]
Erasing : krbafs ######################### [3/3]

Removed: krbafs.i386 0:1.2.2-10.1 krbafs-devel.i386 0:1.2.2-10.1 krbafs-utils.i386 0:1.2.2-9.2.1
Complete!
[root@hedgehog arthur]# package-cleanup --problems
Setting up yum
Reading local RPM database
Processing all local requires
No problems found
[root@hedgehog arthur]# package-cleanup --dupes
Setting up yum
[root@hedgehog arthur]#


Your install is clean now , no errors .
Is everything working OK ?

Jamwa
29th April 2008, 09:45 AM
Yes, all is working, from gimp to nautilus to kopete...

Thanks a million leigh123@linux. I owe you one