PDA

View Full Version : gecko-sharp2 dependency problem



corelon
18th April 2008, 04:52 PM
Hello,

I am using fedora core 8 and I am trying to update gecko-sharp2 package which fails as it asks for gtk-shark 2.8 version (and another one which I cannot remember) while I already have 2.10 for these packages.
This happened since I added mono.repo in my repositories.
Can anyone help me on that?

Regards,
Nick

ronin1982
18th April 2008, 06:32 PM
Hi, use this repo: http://download.opensuse.org/repositories/Mono/Fedora_7/Mono.repo
Even if its for F7 it's more up to date, it seems.
For installing packages from Mono repo, you need to remove first all packages related to Mono installed from Fedora repos:
> yum remove mono*
>yum remove gtk-sharp*

See if there are others packages related, but this will work.
Install yum-utils in order to lock these packages to Mono repository and then install Mono packages you need.

I hope this helps you,
Adrian.

corelon
5th May 2008, 01:28 PM
Hello again and thanks for the advice.

How do I lock a package to a specific repo?

ronin1982
5th May 2008, 03:30 PM
Hi, I think it's automatic if you install yum-utils package.

Adrian