PDA

View Full Version : very choppy video?



daviddoria
18th April 2008, 01:07 PM
I have an nvidia fx 5900xt. I get 6047.471 FPS with glxgears. But if I try to play a video (say youtube or something) fullscreen, I get about ONE fps, it is VERY choppy. I am using the 169.12 driver from nvidias website and a dell 2208 monitor.

Is this normal? Or have I done something wrong?

Thanks,

Dave

multescugeorge@
18th April 2008, 01:41 PM
if you have compiz/beryl running, try to disable them

There are ways to make compiz/beryl play nice with video streams and it involves configuring some stuff in /etc/X11/xorg.conf and in beryl itself, i have yet to find a simple HowTo on it.

As i understood it basically what happens is compiz wanting to go full-screen and thinking it's all alone, then the video comes along and the two start to fight for supremacy.

daviddoria
18th April 2008, 01:46 PM
I don't think I do - I just installed and I dont think that is installed by default?

If I dont then is there any other reason it would not be able to handle this?

multescugeorge@
18th April 2008, 03:27 PM
i played videos with no problems on a integrated "via" video card with 8Mb shared memory, so i think your card ought to handle it ;)
There must be some hickup in your configuration somwere

forkbomb
18th April 2008, 07:04 PM
I don't think the problem is necessarily your video drivers. If you have a good framerate with GLXGears, you should get a decent framerate playing videos. You mentioned YouTube... Sounds like it could be a flash issue. (If you're using Firefox with Flash, that combination is known to be glitchy and can have memory leaks, processor spikes, and other nasty stuff.)