PDA

View Full Version : Problem saving tif images to NFS shares.



ragtag
18th April 2008, 11:11 AM
Hi all,

I'm using a workstation:

Linux bla.blablaabeba.no 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:18:33 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

and a server:

Linux goofy 2.6.18-1.2798.fc6 #1 SMP Mon Oct 16 14:39:22 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux


And have a strange problem with saving tif images to an NFS share. This works fine on a FC6 32bit client on the same network.

To create the problem, I simply make an image and GIMP and save it to somewhere on the NFS share. The image gets saved, but the resulting file is corrupt. The same problem happens with other tools that save images to the nfs share, such as renderman's txmake.

If I save the image to a local drive, and later copy it to the nfs share the image is fine. Also, if I save it in a different format to the nfs share, such as png, everything works fine.

My guess it's either a problem with the 64bit tiff libraries or the nfs libraries in FC8 64bit.

Has anyone encountered this? Or have any suggestions how to fix this?

Cheers

ragtag
2nd May 2008, 12:57 PM
I'm just going to reply to my own post, since none other have. :)

I wasn't able to figure out the problem, but tried using CentOS instead (partially because of this, and partially because of obscure hardware I needed to run that came with RedHat drivers that wouldn't compile easily on Fedora), and the tif problem was gone.

I guess Fedora was a bit to cutting edge for what I needed to do. :)

stevea
2nd May 2008, 02:28 PM
No clue, but a very very interesting problem.

Is this only related to image files ? If you use gedit to save a text file is it corrumpted ?
Is the file corrupt from both the host and server point of view ?
Does the corruption occur if you copy a file with "cp" ?

This is a real error. It's unclear if yo are seeing an error in the NFS(64-64) or if the 64bit tiff. I'd be more suspicion of the latter (same as you).

I would *STRONGLY* suggest that you report this error on bugzilla.redhat.com .
You've already collected all the info for an initial report. In my experience
you'll get a rapid response to such a bug, and this benefits everyone.

ragtag
2nd May 2008, 09:37 PM
The problem seems very specific. It happens only when saving .tif files, not .jpg, .tga, .txt and others, from GIMP or txmake (I assume it happens with other software too). And only when saving the .tif file to an NFS share from a Fedora Core 8 64bit client (to a couple of different servers and NFS shares). The .tif itself is just a normal 8 bit per channel image. Saving the .tif file to local storage works fine, and copying it to the NFS share works fine too. I'm guessing it may be a bug in the libtiff 64 bit version.

Saving .tif from Fedora 6 32bit and CentOS 5.1 64bit to the same NFS shares works fine. I will look into this a bit closer and send a bug report when I've got some more detail. I need to restore the FedoraCore 8 64bit installation first, I copied it to a different hard drive to install CentOS on my machine.

gurkx
7th August 2008, 08:09 PM
I discovered the same problem today on Fedora 8 32bit and an HP-UX 11.i-NFS server. All tiff-files I have edited
with gimp today via the network are lost and destroyed forever!!! If I open and edit tiff files on my local disk all
works fine, if I do the same with tiff-files on the HP-Server via NFS they are be saved nicely but become a heap
of junk! The tragic thing is that you recognize the loss not before you load the same file again. The problem
don't occur with other file types, only tiff seems affected.

I tried the same with an Fedora 4 32bit NFS-Server instead of the HP-UX-NFS-Server. The result: all tiffs saved
on the NFS-server from GIMP via network are junk!

I tried the GIMP on an older Fedora 6 (32bit) system together with the Fedora 4 NFS-Server. Same as before,
tiffs which are saved via NFS-mounts will be destroyed!

I tried XV instead of GIMP and all works fine, cross all systems, no problems at all!

I suppose it has something to do with the libtiff. All systems involved here (besides the HP of course) were 32 bit.

Thetargos
8th August 2008, 12:13 AM
This is certainly most interesting. And is strongly pointing towards libtiff. I see this has already been reported, I'll most likely end up following up this particular bug. For anyone interested this is Bug 458371 (https://bugzilla.redhat.com/show_bug.cgi?id=458371)