PDA

View Full Version : Xine/gstreamer and fedora 8



quiet_identity
17th April 2008, 12:50 PM
Have added the xine-lib extras-nonfree to the now IP proof Xine, among numerous other "fixes" to no avail.

DVD playback
Xine
I thought this was supposed to handle DVD playback but Kaffiene just responds that there is no DVD in the drive or no plugins to handle the DVD.

Gstreamer
I've also got all of the gstreamer plugins, ugly etc (including fluendo's at 28 e.) which also don't allow DVD playback. Maybe I haven't installed the Ugly ones properly.?! how can I tell, in the terminal I tried installing them again, but the ugly gstreamer DVD plugins werent found (using Livna) although it said the other ugly ones were found. If someone could give me a quick tutorial on how to fix this I'd appreciate that.

.MP4 .DiVx .Mpeg4 video playback etc


While my new cohort of codecs doesn't play DVD's they do allow ripped dvd's, but when I enlarge the player from a tiny wee box to full screen they lag up big time. This has to be something to do with the codecs or the media player settings as my comp can easily handle this stuff. I have tested both Xine and Gstreamer which both do pretty much the same thing. Fine when small, bad when big. VLC doesn't like it at all either.

Thanks for your help :-)


I'm also having problems using flash, I have gnash installed which I did coz I'm an ex gnome user. Guess this clashes with KDE. Installed the official linux flash plugin but gnash still seems to take over. Should I uninstall gnash, or is this what I should use in KDE as well.

Agares
17th April 2008, 02:05 PM
I would recommend uninstalling gnash then seeing what happens. As for gstreamer I have had similar issues and they were fixed after I did:

yum install gstreamer*

hope this helps. :)

Agares
17th April 2008, 02:07 PM
This link may give you some help to.

http://www.gagme.com/greg/linux/f8-tips.php

posguy99
19th April 2008, 07:30 PM
>Have added the xine-lib extras-nonfree to the now IP proof Xine, among numerous other "fixes" to no avail.

And have you installed libdvdcss?

georgeisava
22nd April 2008, 06:40 AM
I am a newbie, yet i successfully installed xine on fedora core 6 earlier and now on fedora 8. i also found kaffine player working well in fedora 8 after installing xine library. ive posted the details at my personal portal located at http://www.amitypages.com/fedora.html

brotherpug
30th April 2008, 09:27 PM
Dunno if you're still watching this for a solution but I'm having the same problem. Kaffeine works fine, Xine doesn't. I think the problem is simply that the path to the DVD drive in settings is incorrect. According to the entry "Device used for CD audio" Xine is looking for the path: /dev/dvd-rom, I'm pretty sure that this is wrong but (to my shame) I just cannot work out what the correct path should be. :(

Edit: I thought it might be helpful to add that the Xine log viewer shows a whole pile of plugins found but fails with the message "xine: input plugin cannot find input plugin for MRL [dvd:/]".

Jongi
30th April 2008, 09:37 PM
On F8, it could be /dev/sr0

brotherpug
30th April 2008, 09:50 PM
On F8, it could be /dev/sr0

Yep that worked for me! Thanks :)

For clarity, because I may have typed some confusing info above....

Right Click on the Xine screen, select settings>Setup. Choose the media tab and find the entry "device used for DVD playback" change the entry here.

(I still can't believe I couldn't work that out for myself, by the way)