PDA

View Full Version : File size limit exceeded (core dumped)



jlzink
16th April 2008, 05:01 PM
I have a Fedora 6 server running in a data center. Up until today everything ran fine, but now, when I try to run my php script at command line I get the following:
File size limit exceeded (core dumped)

this is very annoying as I need my scripts to run. Any ideas on how to fix this?

I run the script via: php myscript.php

Please help.

RupertPupkin
17th April 2008, 04:01 AM
Reduce the file size.

jlzink
17th April 2008, 06:09 AM
yes, this might work if the file size was large, but the filesize is only 10kb big. I get the same error even with a file containing
<?
echo "Test";
?>
so it's surely not the file size.

sidebrnz
17th April 2008, 06:12 AM
Does your script use a temp file? If so, it might be looping and the temp file's getting too big.

jlzink
17th April 2008, 06:14 AM
no. The script runs solely within itself and the uses the includes for housing commonly used functions. All logging is done via a mysql backend. As mentioned before though the error occurs even when I do a simple php file like:

<?
echo "Test";
?>

when it gives this error it then creates a file in the directory called core.#### where #### is a number.

cgrim
17th April 2008, 06:36 AM
I have a stupid question - do you have enough free space on the partition you are using for the new file?
Try df command for example to check it.

jlzink
17th April 2008, 06:46 AM
yes, but I figured out the problem and fixed it. there was an error_log in the directory that was large. So after modifying that it seems to work...thanks all for your help.