PDA

View Full Version : The problem of building aMule...



Cyberman
15th April 2008, 11:22 AM
I've try to install aMule. Since there hasn't a yum for it, I try to build it from source code.
First, I installed wxWidgets:
yum install wxGTK

Then, try to build aMule, but configure failed since wx-config script couldn't be find. I've tried to find where it is:
find / -name="wx*"

But it seemed nothing installed, any the only output seems have something to do with wxWidgets is its docs. Why?

Cyberman
15th April 2008, 11:28 AM
I forgot one thing: The system if Fedora 7.0.

Wayne
15th April 2008, 11:37 AM
Umm......

http://www.google.co.jp/search?q=amule+fc7+rpm&ie=utf-8&oe=utf-8&aq=t&rls=Swiftfox:en-US:unofficial&client=firefox-a

Wayne

jtang613
15th April 2008, 12:51 PM
aMule is in the Livna YUM repository.

su -
rpm -Uvh http://rpm.livna.org/livna-release-8.rpm
yum install amule
- JT

Cyberman
15th April 2008, 03:17 PM
Hi jtang613, can you explain what it means? I got that problem:


Retrieving http://rpm.livna.org/livna-release-8.rpm
warning: /var/tmp/rpm-xfer.Ci0osF: Header V3 DSA signature: NOKEY, key ID a109b1ec
error: Failed dependencies:
fedora-release >= 8 is needed by livna-release-8-1.noarch

I change livna-release-7.rpm, and it went fine.

I have one more question: How can I set up the Networks? In eMule it usually published with defaults.

sideways
15th April 2008, 03:40 PM
The default server list in amule isn't valid anymore. You can find a working url for the server list by googling.