PDA

View Full Version : Nautilus sound preview doesn't work for .ogg's, but does for mp3's



Thetargos
15th April 2008, 02:35 AM
Has anyone else noticed this?

Using Pavu Control I was able to determine that it isn't actually Nautilus who does the previewing, but rather gst-launcher. At any rate, I found this to be rather intriguing, as Sound Preview in nautilus works just fine for .wav and .mp3 files (provided you have the right plugin installed, either fluendo or gstreamer-plugins-ugly), however it does not work for Vorbis files encoded into .oggs or .flac files, despite of gstreamer being able to playback these formats in Totem in a default installation (or rather Totem using another backend?).

Since this doesn't seem to be a Nautilus problem, I filed a bug against Gstreamer here (https://bugzilla.redhat.com/show_bug.cgi?id=442481)

RJFUatHOME
15th April 2008, 05:19 AM
I don't have codecs for mp3 and such on my system, but ogg previews in Nautilus only work if ESD is enabled, when the system sounds are turned on. Have you disabled Gnome system sounds?

I'm checking on Fedora 7, but like I said oggs only preview on hover in icon view mode and if system sounds are enabled.

leadgolem
15th April 2008, 05:25 AM
I don't have any mp3's, but my ogg files only audio preview if I've opened them with one of the gstreamer based players, aka exaile etc.., prior to hovering.

Wayne
15th April 2008, 05:30 AM
I have System Sounds off, but ESD enabled and an OGG that I downloaded from their site previewed fine on F8.... Gnome....

Wayne

Thetargos
15th April 2008, 06:08 AM
Ok, the general consensus seems to be that it should work, so this may be indeed an architecture-specific issue... I'm using x86_64 Fedora 8... And I do have ESD turned on (otherwise PulseAudio doesn't work on GNOME), and like I said, only .mp3's and .wav's have previews, no .ogg or .flac files. I will have to amend the bug report to read x86_64 as the arch.

Seve
15th April 2008, 06:13 AM
Hello:
I am running 64bit with Gnome, so I can try and confirm your issue if you like.

Not a big audiophile here so can you please let me know exactly what is
"Nautilus sound preview" ?

Sorry if it's a silly question :)

Seve

Dies
15th April 2008, 06:25 AM
Hello:

Not a big audiophile here so can you please let me know exactly what is
"Nautilus sound preview" ?

Sorry if it's a silly question :)

Seve

It's not. ;)

Nautilus - Edit>Preferences>Preview>Sound Files

Make sure that's enabled then rest your cursor on a music file for a second or two and you should hear it play.

Wayne
15th April 2008, 06:25 AM
Hover your mouse over an audio file and you should get a sound preview of the tune. You have to have it enabled in the Nautilus File Manager Preferences (Preview tab)

Wayne

Seve
15th April 2008, 06:35 AM
Hello:

Thanks guys .... as always, Seve is still learning :)

I got hold of a mp3 and the hover seems to work with that [as you folks have described].
I downloaded an ogg file from the ogg web-site and tried the the same thing with that.
No go with the hover over the file as it would not auto-play [i.e. Preview]. ?

Using
2.6.24.4-64.fc8
64bit

Seve

Wayne
15th April 2008, 06:39 AM
I thought it might have something to do with me also having mpg321 installed but it seems that's just for MP3s, or so I believe.

Wayne

Dies
15th April 2008, 06:43 AM
< ...even Nautilus dislikes .ogg files... >

:D

Thetargos
15th April 2008, 06:54 AM
It has nothing to do with other MPEG plugins, as the program used as the backend by Nautilus to launch the previews is gst-launcher-0.10, so it only suffice to have mp3 support for GStreamer.

Thetargos
15th April 2008, 06:56 AM
< ...even Nautilus dislikes .ogg files... >

:D
I very much prefer them over the inferior quality of mp3s... But that's not the issue, the issue here is that 64-bit GStreamer (or at least gst-launcher) lacks support for .ogg files.

Wayne
15th April 2008, 07:00 AM
What I'd like to see is video previews like on the Mac, but I fear I'd need a better computer for that :)

Wayne

Dies
15th April 2008, 07:04 AM
And Nautilus would probably only preview .wmv's and .mov's properly. :p

leadgolem
15th April 2008, 07:07 AM
Ok, the general consensus seems to be that it should work, so this may be indeed an architecture-specific issue... I'm using x86_64 Fedora 8... So am I. OSS for my sound.

Thetargos
15th April 2008, 08:23 AM
So am I. OSS for my sound.
Do you mean that you also have the "issue"?

leadgolem
15th April 2008, 08:30 AM
No, I mean that I am using the same fedora version and arch. I can only get the audio preview after playing the .ogg file for a second in one of the gstreamer players. Though totem-xine seems to have the same effect of allowing me to do the audio preview, and it's not a gstreamer based player.

Thetargos
16th April 2008, 02:55 AM
Hence, indeed this seems to be a Gstreamer limitation probably linked to the architecture.

Seve
16th April 2008, 03:34 AM
Hello:
I just tried the preview function in F9 [64bit] and it seems to work for both mp3 and ogg. :)

Seve

Thetargos
16th April 2008, 07:19 AM
Those are good news, but leaves Fedora 8 users (which still has 6 more months to go as "supported") with the problem... Still this is low enough a priority and severity, that I guess it is OK :) (unlike some other (http://forums.fedoraforum.org/showthread.php?t=186311) issues)