PDA

View Full Version : No sound in RealPlayer 11.



popatopalous
13th April 2008, 09:47 PM
For people like me that have had problems using RealPlayer on sites like:

http://www.bbc.co.uk/radio/i/

and most especially:

http://www.rte.ie/radio/index.html

RealPlayer 11 for Linux is now available at:

http://www.real.com/linux

Currently in Fedora x86_64>Firefox with browser plugins enabled both of those links will open RealPlayer. Unfortunately there is no sound. I'll get to the sound issue in Fedora later. In Suse both sites open with sound so it should be fixable problem. :cool:

mbokil
13th April 2008, 11:35 PM
Does it play nicely now with Pulseaudio? It is amazing how Flash content has taken over streams and video. I used to use Realplayer all the time for listening to streaming radio and watching videocasts. It think around the time youtube really began to take over I lost interest in it. I downloaded and installed it. Seems pretty nice. The only thing it is missing is pulseaudio output plugin.

JohnVV
14th April 2008, 06:51 AM
well for the bbc at least mplayer-plugin for Mozilla seamonkey works fine for me and works nicely with pulse audio

popatopalous
14th April 2008, 10:21 PM
I am trying to get sound in RealPlayer 11 to work. Specifically embedded media in Firefox. Doesn't matter if I'm regular user or root if I try to listen here:

http://www.rte.ie/radio/index.html

RealPlayer opens and plays but there is no sound. It is different from RealPlayer 10 and the usual tricks used to get sound in 10 don't seem to work. I've been searching Fedora forum and Google I haven't found anything yet. For one it now uses alsa for default sound not oss. Any ideas on how to trouble shoot this? :confused:

leigh123linux
14th April 2008, 10:41 PM
Threads merged , Please don't double post !!

popatopalous
14th April 2008, 10:54 PM
Sorry didn't know I was...

popatopalous
14th April 2008, 10:58 PM
This is weird but may indicate where the problem lies. If I bo here:

http://www.bbc.co.uk/radio/i/

and select what I want to listen to realplayer will open and play with no sound. If I then select to "launch in stand alone player" it launches realplayer and does 'cache fill' [slowly] and eventually will play the stream WITH SOUND! :eek:

So obviously there is sound in RealPlayer. Problem must be how it is functioning as a plugin in Firefox.

Edit: Popatopalous you crazy old man the reason you had sound was because Realplayer wasn't playing it was MPlayer.

popatopalous
16th April 2008, 11:18 PM
Here's terminal output when I try to play something:


$ realplay

(realplay.bin:3525): Gtk-WARNING **: Unable to locate theme engine in module_path: "nodoka",
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
ALSA lib pcm.c:2106:(snd_pcm_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_pcm_pulse.so
...

So what do I need to fix it? :confused:

popatopalous
16th April 2008, 11:48 PM
I admit I'm baffled. In Fedora 8 AMD 64 using KDE I have sound except [as far as I know] in RealPlayer 11. In Firefox I have RealPlayer plugins enabled when I go to:

http://www.rte.ie/radio/index.html

http://www.bbc.co.uk/radio/i/

RealPlayer opens and plays but with no sound. I do have sound in Flash [You Tube] and mplayer [Apple Movie Trailers] as well as in kde.

Here's some info I gathered while searching forums:

If I select to play streaming audio at bbc.com and run:


# lsof | grep dsp
npviewer. 7485 ben mem REG 8,7 11124 2784367 /usr/lib/libartsdsp.so.0.0.0
npviewer. 7519 ben mem REG 8,7 11124 2784367 /usr/lib/libartsdsp.so.0.0.0
# lsof | grep pcm
artsd 6646 ben mem REG 8,7 24032 2905290 /usr/lib64/alsa-lib/libasound_module_pcm_pulse.so
realplay. 7539 ben mem REG 8,7 103076 3430991 /opt/real/RealPlayer/plugins/pcmrend.so

I don't know what this means though?

Some more:


system-config-soundcard

does not play guitar chords in KDE but does in Gnome. Test Sound in KCC>Sound System>General does play sound though. Not sure if this means anything?


# alsamixer

opens mixer with ONLY Master Volume control. It lists:

Card: PulseAudio
Chip: PulseAudio
View: [Playback] Capture All
Item: Master

Master is, of course, unmuted and set to 71.


# rpm -qa | grep alsa
alsa-plugins-oss-1.0.15-3.fc8.1
alsa-lib-1.0.15-1.fc8
alsa-oss-devel-1.0.14-3.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-lib-1.0.15-1.fc8
alsa-oss-libs-1.0.14-3.fc8
alsamixergui-0.9.0-0.3.rc1.fc8.2
bluez-utils-alsa-3.20-6.fc8
alsa-oss-1.0.14-3.fc8
alsa-utils-1.0.15-1.fc8
alsa-oss-devel-1.0.14-3.fc8
alsa-tools-1.0.12-4.fc7
alsa-oss-libs-1.0.14-3.fc8

# rpm -qa | grep pulseaudio
pulseaudio-module-x11-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
pulseaudio-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8
pulseaudio-core-libs-0.9.8-5.fc8
akode-pulseaudio-2.0.2-4.fc8
kde-settings-pulseaudio-3.5-38.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-esound-compat-0.9.8-5.fc8
pulseaudio-module-gconf-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8

# lsmod | grep snd
snd_hda_intel 391145 4
snd_seq_dummy 11589 0
snd_seq_oss 38721 0
snd_seq_midi_event 15041 1 snd_seq_oss
snd_seq 60769 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device 15445 3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss 52545 0
snd_mixer_oss 23233 2 snd_pcm_oss
snd_pcm 87241 2 snd_hda_intel,snd_pcm_oss
snd_timer 28873 2 snd_seq,snd_pcm
snd_page_alloc 16721 2 snd_hda_intel,snd_pcm
snd_hwdep 16457 1 snd_hda_intel
snd 65129 16 snd_hda_intel,snd_seq_dummy,snd_seq_oss,snd_seq,sn d_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd _timer,snd_hwdep
soundcore 15073 2 snd

# uname -a
Linux localhost.localdomain 2.6.24.4-64.fc8 #1 SMP Sat Mar 29 09:15:49 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux

# pulseaudio --dump-modules
module-alsa-sink n/a
module-alsa-source n/a
module-cli n/a
module-cli-protocol-tcp n/a
module-cli-protocol-unix n/a
module-combine n/a
module-default-device-restore n/a
module-detect n/a
module-esound-compat-spawnfd n/a
module-esound-compat-spawnpid n/a
module-esound-protocol-tcp n/a
module-esound-protocol-unix n/a
module-esound-sink n/a
module-gconf n/a
module-hal-detect n/a
module-http-protocol-tcp n/a
module-http-protocol-unix n/a
module-ladspa-sink n/a
module-match n/a
module-mmkbd-evdev n/a
module-native-protocol-fd n/a
module-native-protocol-tcp n/a
module-native-protocol-unix n/a
module-null-sink n/a
module-oss n/a
module-pipe-sink n/a
module-pipe-source n/a
module-remap-sink n/a
module-rescue-streams n/a
module-rtp-recv n/a
module-rtp-send n/a
module-simple-protocol-tcp n/a
module-simple-protocol-unix n/a
module-sine n/a
module-suspend-on-idle n/a
module-tunnel-sink n/a
module-tunnel-source n/a
module-volume-restore n/a
module-x11-bell n/a
module-x11-publish n/a
module-x11-xsmp n/a

How can I troubleshoot/fix this? I would like to first figure out if this is a Fedora, or alsa, or pulseaudio, or kde problem? Or is it a RealPlayer problem? FWIW I DO have RealPlayer working [with sound!] on my other 4 distros. Also, by all means, let me know of any other info or tests that would help solve this. :confused:

popatopalous
17th April 2008, 01:25 AM
And there's more. I downloaded some music videos with Azureus. If I try to open them with RealPlayer 11 they won't open because I don't have 'asx'. If I open them in Kaffeine it promptly crashes. If I open them in MPlayer they open and play with sound but there is an error message:

Error!
[AO_ALSA] Unable to find simple control 'PCM', 0.

:confused:

leigh123linux
17th April 2008, 01:31 AM
Have you tried installing


alsa-plugins-pulseaudio.i386


You will need to manually fetch it from the i386 repo ! as it isn't available through yum . ( I run 64 bit and had to do this to get zattoo sound to work )


For mplayer try changing the audio setting for driver to pulseaudio !

popatopalous
17th April 2008, 02:28 AM
Have you tried installing


alsa-plugins-pulseaudio.i386


You will need to manually fetch it from the i386 repo ! as it isn't available through yum . ( I run 64 bit and had to do this to get zattoo sound to work )


For mplayer try changing the audio setting for driver to pulseaudio !

Where do I get 'alsa-plugins-pulseaudio.i386'?

https://admin.fedoraproject.org/pkgdb/

Won't let me login with my Fedora uname and pw and offers no option to register. It keeps sending me in circles and can't find any real package.

popatopalous
17th April 2008, 03:44 AM
I guess I'm all confused. Even if you can find i386 packages which I couldn't through Google or Fedora Project. Hint:

http://download.fedora.redhat.com/pub/fedora/linux/releases/8/Fedora/i386/os/Packages/

Then when I go to install the package I get:


# rpm -ihv alsa-plugins-pulseaudio-1.0.14-5.fc8.i386.rpm
Preparing... ########################################### [100%]
package alsa-plugins-pulseaudio-1.0.15-3.fc8.1.x86_64 (which is newer than alsa-plugins-pulseaudio-1.0.14-5.fc8.i386) is already installed
file /etc/alsa/pulse-default.conf from install of alsa-plugins-pulseaudio-1.0.14-5.fc8.i386 conflicts with file from package alsa-plugins-pulseaudio-1.0.15-3.fc8.1.x86_64

This is getting to be irritating. :(

popatopalous
17th April 2008, 03:52 AM
Have you tried installing


alsa-plugins-pulseaudio.i386


You will need to manually fetch it from the i386 repo ! as it isn't available through yum . ( I run 64 bit and had to do this to get zattoo sound to work )


For mplayer try changing the audio setting for driver to pulseaudio !

Your hint on MPlayer did work thanks. To freakin bad I can't figure out how to install 'alsa-plugins-pulseaudio.i386'. This has become frustrating. :(

leigh123linux
17th April 2008, 08:06 AM
Your hint on MPlayer did work thanks. To freakin bad I can't figure out how to install 'alsa-plugins-pulseaudio.i386'. This has become frustrating. :(

Try the updated version




su -
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386.rpm

TheMatt
17th April 2008, 12:07 PM
As I've been following this, installation of the i386 alsa-plugins-pulseaudio leads to yet another crash/bug:


Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
/usr/bin/realplay: line 59: 6676 Aborted /usr/bin/aoss $HELIX_LIBS/realplay.bin "$@"
This happens with or without the usual aoss in the realplay script.

And, just so you know we aren't alone, I present Helix bug #7375 (https://bugs.helixcommunity.org/show_bug.cgi?id=7375). Apparently there is a perfect storm of Real v. Pulse going on here.

leigh123linux
17th April 2008, 12:53 PM
Well this is strange it has started working for me .



[root@localhost leigh]# rpm -qa |grep pulse
pulseaudio-esound-compat-0.9.10-1.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
pulseaudio-libs-0.9.10-1.fc9.i386
pulseaudio-libs-glib2-0.9.10-1.fc9.x86_64
pulseaudio-module-gconf-0.9.10-1.fc9.x86_64
gstreamer-plugins-pulse-0.9.5-0.5.svn20070924.fc9.x86_64
pulseaudio-0.9.10-1.fc9.x86_64
pulseaudio-libs-0.9.10-1.fc9.x86_64
pulseaudio-utils-0.9.10-1.fc9.x86_64
pulseaudio-module-x11-0.9.10-1.fc9.x86_64
pulseaudio-core-libs-0.9.10-1.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
[root@localhost leigh]# rpm -q RealPlayer
RealPlayer-11.0.0.4028-20080225.i586
[root@localhost leigh]# rpm -q firefox
firefox-3.0-0.54.beta5.fc9.x86_64
[root@localhost leigh]# uname -r
2.6.25-1.fc9.x86_64
[root@localhost leigh]#


It was crashing before .

popatopalous
17th April 2008, 02:54 PM
Try the updated version




su -
rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386.rpm

Thank you very much.


# yum whatprovides libasound_module_pcm_pulse.so
No Matches found
# rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386.rpm
# yum whatprovides libasound_module_pcm_pulse.so
alsa-plugins-pulseaudio.i386 : Alsa to PulseAudio backend

So now I have 'libasound_module_pcm_pulse.so' and when I try to play something in RealPlayer... It crashes:


$ realplay

(realplay.bin:3473): Gtk-WARNING **: Unable to locate theme engine in module_path: "nodoka",
Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.

Wonder how I can fix that? At least I'm learning more about Fedora and Yum. That's a good thing.

leigh123linux
17th April 2008, 03:43 PM
Thank you very much.


# yum whatprovides libasound_module_pcm_pulse.so
No Matches found
# rpm -ivh http://fedora.tu-chemnitz.de/pub/linux/fedora/linux/updates/8/i386/alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386.rpm
# yum whatprovides libasound_module_pcm_pulse.so
alsa-plugins-pulseaudio.i386 : Alsa to PulseAudio backend

So now I have 'libasound_module_pcm_pulse.so' and when I try to play something in RealPlayer... It crashes:


$ realplay

(realplay.bin:3473): Gtk-WARNING **: Unable to locate theme engine in module_path: "nodoka",
Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.

Wonder how I can fix that? At least I'm learning more about Fedora and Yum. That's a good thing.


sndrv_pcm_hw_params: Assertion `err >= 0' failed


This looks like a soundcard setup issue .

pwalden
17th April 2008, 10:56 PM
I notice the Redhat rpm package put the files into /opt/real instead of /usr/local.

Could that be an issue?

leigh123linux
17th April 2008, 11:19 PM
I notice the Redhat rpm package put the files into /opt/real instead of /usr/local.

Could that be an issue?



No it doesn't matter where the files are !

popatopalous
18th April 2008, 02:46 AM
Here's why I think RealPlayer is not working on my system.


$ realplay

(realplay.bin:8813): Gtk-WARNING **: Unable to locate theme engine in module_path: "nodoka",
Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
/usr/bin/realplay: line 54: 8813 Aborted $HELIX_LIBS/realplay.bin "$@"

It's calling for 'ALSA PCM device'. If you remember from earlier posts when I open alsamixer there is no 'ALSA PCM device'. There is only one volume control 'Master'. Also when I play music videos with MPlayer I get the error:

Error!
[AO_ALSA] Unable to find simple control 'PCM', 0.

The RealPlayer start up script is looking for the alsa PCM device and some of us don't have it.

As further evidence there are distros that use PulseAudio where RealPlayer does work [Mandriva and Kubuntu ]. In those distros alsa mixer brings up a full complement of volume controls including PCM.

I'm convinced that the 'alsa-pulseaudio-plugin.i386' is necessary. I'm also convinced that there needs to be an alsa PCM device for RealPlayer [and other things including mplayer] to work.

How to resolve this? Is there a package that would provide alsa with ALL volume controls? From past experience I know that alsa with only a Master volume control will lead to multiple sound issues.

This whole thing is making me want to rip apart phone books with my bare hands... :(

popatopalous
18th April 2008, 03:00 AM
I notice that if I open PulseAudio volume control under tabs 'Output Devices' and 'Input Devices' It references:

ALSA PCM on front: 0 (AD198x Analog) via DMA.

Edit: In view of results of 'alsamixer' it would appear that alsa doesn't realize this...

So maybe some where there IS an alsa PCM device. If so either it isn't communicating with some applications or they can't find it. What to do?

OT: Now what am I gonna do if I need to look up a phone number?

popatopalous
18th April 2008, 06:44 PM
As I've been following this, installation of the i386 alsa-plugins-pulseaudio leads to yet another crash/bug:


Opening ALSA PCM device default
realplay.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
/usr/bin/realplay: line 59: 6676 Aborted /usr/bin/aoss $HELIX_LIBS/realplay.bin "$@"
This happens with or without the usual aoss in the realplay script.

And, just so you know we aren't alone, I present Helix bug #7375 (https://bugs.helixcommunity.org/show_bug.cgi?id=7375). Apparently there is a perfect storm of Real v. Pulse going on here.

Yes this appears to be a bug. In my case Realplayer 11 isn't oly issue I get it in some instances in MPlayer. Also:


$ speaker-test

speaker-test 1.0.15

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 1 to 2097152
Period size range from 0 to 206158431
Using max buffer size 2097152
Periods = 4
was set period_size = 0
was set buffer_size = 2097152
speaker-test: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted

I read the bug report you cited:

https://bugs.helixcommunity.org/show_bug.cgi?id=7375

and 2 others mentioned in that one:

http://www.pulseaudio.org/ticket/23

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=2601

It appears to be a bug in alsa and there may be patches that work. IF so the patches haven't made it into Fedora 8... So I filed:

https://bugzilla.redhat.com/show_bug.cgi?id=443087

and I'm hoping it gets fixed.

popatopalous
18th April 2008, 06:56 PM
Well this is strange it has started working for me .
It was crashing before .

leigh123@linux is it possible that this issue has been fixed in newer packages in Fedora 9 but not in Fedora 8??? You are showing newer versions of some key packages than I have?

Here's what I've got:


# rpm -qa |grep pulse
pulseaudio-esound-compat-0.9.8-5.fc8
pulseaudio-module-x11-0.9.8-5.fc8
akode-pulseaudio-2.0.2-4.fc8
pulseaudio-utils-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-core-libs-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
kde-settings-pulseaudio-3.5-38.fc8
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-module-gconf-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8
pulseaudio-module-lirc-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1


# rpm -qa |grep alsa
alsa-lib-devel-1.0.15-1.fc8
python-alsa-1.0.15-1.fc8
alsa-oss-libs-1.0.14-3.fc8
alsa-lib-1.0.15-1.fc8
alsa-plugins-upmix-1.0.15-3.fc8.1
alsamixergui-0.9.0-0.3.rc1.fc8.2
alsa-plugins-jack-1.0.15-3.fc8.1
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
kadu-alsa_sound-0.6.0-2.fc8
alsa-lib-devel-1.0.15-1.fc8
alsa-oss-devel-1.0.14-3.fc8
alsa-oss-libs-1.0.14-3.fc8
alsa-lib-1.0.15-1.fc8
bluez-utils-alsa-3.20-6.fc8
alsa-plugins-vdownmix-1.0.15-3.fc8.1
python-alsaaudio-0.3-1.fc8
alsa-plugins-oss-1.0.15-3.fc8.1
alsa-utils-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-oss-devel-1.0.14-3.fc8
alsa-tools-1.0.12-4.fc7
alsa-oss-1.0.14-3.fc8
asterisk-alsa-1.4.18.1-1.fc8


# rpm -q RealPlayer
RealPlayer-11.0.0.4028-20080225


# rpm -q firefox
firefox-2.0.0.13-1.fc8
firefox-2.0.0.13-1.fc8


# uname -r
2.6.24.4-64.fc8

OT: Why isn't my system showing arch of packages??? My system is x86_64 but I do have 'alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386'.

leigh123linux
18th April 2008, 07:45 PM
It also works for me in F8 x86_64



[root@localhost leigh]# rpm -qa |grep pulse
pulseaudio-module-gconf-0.9.8-5.fc8
pulseaudio-core-libs-0.9.8-5.fc8
pulseaudio-module-zeroconf-0.9.8-5.fc8
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-0.9.8-5.fc8
pulseaudio-module-x11-0.9.8-5.fc8
pulseaudio-libs-zeroconf-0.9.8-5.fc8
pulseaudio-esound-compat-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
pulseaudio-libs-0.9.8-5.fc8
pulseaudio-utils-0.9.8-5.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8
audacious-plugins-pulseaudio-1.3.5-3.fc8
pulseaudio-libs-devel-0.9.8-5.fc8
pulseaudio-libs-glib2-0.9.8-5.fc8


[root@localhost leigh]# rpm -qa |grep alsa
alsa-lib-devel-1.0.15-1.fc8
bluez-utils-alsa-3.20-6.fc8
alsa-lib-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-lib-1.0.15-1.fc8
alsa-plugins-pulseaudio-1.0.15-3.fc8.1
alsa-plugins-jack-1.0.15-3.fc8.1
alsa-utils-1.0.15-1.fc8


[root@localhost leigh]# rpm -q RealPlayer
RealPlayer-11.0.0.4028-20080225



[root@localhost leigh]# rpm -q firefox
firefox-2.0.0.13-1.fc8
firefox-2.0.0.13-1.fc8



[root@localhost leigh]# uname -r
2.6.24.4-74.fc8


[root@localhost leigh]# rpm -qa |grep nspluginwrapper
nspluginwrapper-i386-0.9.91.5-1
nspluginwrapper-0.9.91.5-1



OT: Why isn't my system showing arch of packages??? My system is x86_64 but I do have 'alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386'.
Today 06:44 PM PDT

I don't know it maybe a F9 feature :cool:


Try


rpm -qa --queryformat "%{NAME}-%{VERSION}-%{RELEASE}.%{ARCH}\n" |grep pulse

TheMatt
18th April 2008, 07:46 PM
OT: Why isn't my system showing arch of packages??? My system is x86_64 but I do have 'alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386'. Ah, I can help with this, to get:

> rpm -qa | grep pulse
akode-pulseaudio-2.0.2-4.fc8.x86_64
alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386
pulseaudio-libs-0.9.8-5.fc8.i386
...you need to add a bit to your rpm macros. In my case, I created a file called /etc/rpm/macros.mjmwired (because I got the tip from the mjmwired guides long ago, FC6 or so):
> cat /etc/rpm/macros.mjmwired
%_query_all_fmt %%{name}-%%{version}-%%{release}.%%{arch}Usually you add this to /etc/rpm/macros. Note that there is probably a valid reason not to do this if you are a heavy developer or something, but it hasn't broken my setup yet.

ETA: You know, to keep it away from root, you should add that line to ~/.rpmmacros instead.

popatopalous
18th April 2008, 08:10 PM
It also works for me in F8 x86_64

Well I wish I knew why it works for you and not for me.... Something has to be different.

popatopalous
19th April 2008, 12:41 AM
Ok, to fix sound issue in MPlayer I just >Mplayer>Preferences>Audio>PuslseAudio.

In >RealPlayer>Tools>Preferences>PCM device it was set to 'default' which probably should work if everything is right in PulesAudio and Alsa. But in my case that doesn't work. I changed PCM device to 'hw:0' and I now have sound but it is badly garbled. What do other people have for PCM device? What device should it be?

popatopalous
19th April 2008, 02:41 AM
Ah Ha! Forget everything I've said in this thread previously. Here's what I did.


# rpm -e alsa-plugins-pulseaudio-1.0.15-3.fc8.1.i386


rpm -e RealPlayer

And I then followed fix provided by nikosapi here:

http://forums.fedoraforum.org/showthread.php?t=174298&page=3&pp=15

Which in my case was specifically:


yum install kernel-devel mercurial


# yum groupinstall 'Development Tools'
$ hg clone http://hg-mirror.alsa-project.org/alsa-driver alsa-driver
$ hg clone http://hg-mirror.alsa-project.org/alsa-kernel alsa-driver/alsa-kernel
$ cd alsa-driver
$ make ALSAKERNELDIR=alsa-kernel all-deps
$ aclocal; autoconf
$ /configure --with-cards=hda-intel
$ make || make
# make install


Then reboot to make sure you're using the newly compiled module.

Edit: I also had to uncomment the line "/etc/alsa/pulse-default.conf" in '/etc/alsa/alsa.conf':


#
# ALSA library configuration file
#

# pre-load the configuration files

@hooks [
{
func load
files [
# "/etc/alsa/pulse-default.conf"
"/etc/asound.conf"
"~/.asoundrc"
]
errors false
}
]

# load card-specific configuration files (on request)

cards.@hooks [
{
func load
Then simply:


rpm -ihv RealPlayer11GOLD.rpm

and it just works. Right out of the box. Default settings. Fixed some other sound issues I was having as well.


$ speaker-test

speaker-test 1.0.15

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 2048 to 16384
Period size range from 1024 to 1024
Using max buffer size 16384
Periods = 4
was set period_size = 1024
was set buffer_size = 16384
0 - Front Left
Time per period = 2.665054
0 - Front Left

Woo Hoo!

and kudos to nikosapi, you da man.

fwelland
21st April 2008, 04:19 PM
Although not the best way to do this -- kinda defeats the purpose of using RP 11's built-in alsa support --

but a quick and dirty way to work around this would be to launch realplayer with 'padsp' (i.e. run RP with command like: "padsp /opt/real/RealPlayer/realplay" ) and put RP 11 into OSS mode.

fwelland
23rd April 2008, 03:53 PM
follow on note:

/opt/real/RealPlayer/realplay is s script and when/if you make or use a gnome menu item to run this script -- updating the item via alacarte to be like padsp /opt/real/RealPlayer/realplay -- MAY NOT WORK as expected.

For me Real was starting and playing -- but then I lost all other sounds (i.e. exclusive block on /dev/snd probably)... Starting from cmdline works OK (no blocks) -- so the padsp stuff is probably getting lost to a subshell some where when being launched from gnome menu.....

I fix/hacked this by changing the line in the realplay script from

$HELIX_LIBS/realplay.bin "$@"

TO

padsp -n RealPlayer -m RealPlayerStream $HELIX_LIBS/realplay.bin "$@"


This line is towards bottom of the script....

QuantumKnot
30th April 2008, 01:45 AM
I managed to fix this problem on x86_64 F8 by copying the *.so files in /usr/lib/alsa-lib from a 32-bit F8. Then in the hardware preferences of RealPlayer 11, I changed the PCM device from "default" to "hw:0" or "plughw:0". That seemed to get it to work, but you have to close other programs that play sounds (eg rhythmbox)

leigh123linux
30th April 2008, 09:35 AM
I managed to fix this problem on x86_64 F8 by copying the *.so files in /usr/lib/alsa-lib from a 32-bit F8. Then in the hardware preferences of RealPlayer 11, I changed the PCM device from "default" to "hw:0" or "plughw:0". That seemed to get it to work, but you have to close other programs that play sounds (eg rhythmbox)


Why did you need to do this ? :confused:


[root@localhost leigh]# yum whatprovides /usr/lib/alsa-lib
Loaded plugins: changelog, refresh-packagekit
Excluding Packages in global exclude list
Finished
Importing additional filelist information
alsa-lib.i386 : The Advanced Linux Sound Architecture (ALSA) library
alsa-lib.i386 : The Advanced Linux Sound Architecture (ALSA) library
alsa-lib.i386 : The Advanced Linux Sound Architecture (ALSA) library



I run Fedora 64 bit and use the package alsa-lib.i386 instead ;)


su
yum install alsa-lib.i386



[root@localhost leigh]# rpm -qa |grep alsa
alsa-plugins-pulseaudio-1.0.16-4.fc9.i386
alsa-lib-devel-1.0.16-3.fc9.x86_64
bluez-utils-alsa-3.30-2.fc9.x86_64
alsa-lib-1.0.16-3.fc9.i386
alsa-utils-1.0.16-2.fc9.x86_64
alsa-lib-1.0.16-3.fc9.x86_64
alsa-plugins-pulseaudio-1.0.16-4.fc9.x86_64
[root@localhost leigh]#