PDA

View Full Version : My Fedora Core 6 Installation has gone bad.



AdamR
14th April 2008, 09:49 AM
Hello,

I have a corrupt Fedora Core 6 installation and would appreciate any help.

This system worked like a champ for months until this previous weekend.
Here are some details:

Fedora Core 6 2.6.22.9-61.fc6

At boot:

lots of messages that appear normal until:
...
unmounting old /dev
unmounting old /proc
unmounting old /sys
/bin/sh: ro: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

At this point I have to power off the machine.

I followed the instructions on the Fedora Rescue CD (I got the newest 8, anaconda 11.3.0.50)
and did the "linux rescue" command.

So then I do this:

sh-3.1# chroot /mnt/sysimage
chroot: cannot run command '/bin/sh': Exec format error

Any help is gladly appreciated!
Adam.

zeno0771
14th April 2008, 11:47 AM
First things first...I'm not a programmer, but as a rule I use the rescue disc for the version I'm running...I've run into problems with that in the past. Don't know what the difference is (Anaconda version?) but if I have to break out a rescue disc I'm already too irate to care.

Barring that, you could try a LiveCD and just mount your FC6 install while running that; I've actually had better luck doing that lately, I can find the problem and get online if need be to find the answer.

On doing that, get into the logs and find where it's burping...start with /var/log/dmesg and /var/log/messages.

forkbomb
14th April 2008, 12:36 PM
Have you tried running fsck on the filesystem(s)?

bob
14th April 2008, 12:45 PM
If you google the error, there's three exact responses, none of which look good. Somehow a key file's been corrupted or deleted. Worst case; mount Fedora 6 via knoppix or other suitable Live CD and burn off your data, then reinstall. Considering that Fedora 6 has passed 'end of life', perhaps it's a good time to upgrade to Fedora 8?