PDA

View Full Version : WMV and WMA with MPlayer (or Any player) on 64bit



digitaldude
14th April 2008, 01:57 AM
Facts:

Recent Linux User stated with Fedora 8 32 bit.
Installed Fedora 8 x86_64 on new 64 bit hardware. (Due old hardware failure )


Problem: Cant get any player, i.e,, VLC, Mplayer, Totem to play wma or wmv files. Need to be able to play both. My big question is it possible to get Mplayer to play wma and wmv on Fecdora 8 64 and if not is there any player on Fecdora 8 that one can use to play these file types.


OS:
[user@localhost ~]$ uname -a

Linux localhost.localdomain 2.6.24.4-64.fc8 #1 SMP Sat Mar 29 09:15:49 EDT 2008 x86_64 x86_64 x86_64 GNU/Linux




Using command line to display what is installed

[user@localhost ~]$ rpm -qa | grep mplayer

mplayer-doc-1.0-0.90.rc2.lvn8

mplayer-gui-1.0-0.90.rc2.lvn8

mplayer-1.0-0.90.rc2.lvn8

[user@localhost ~]$ rpm -qa | grep mencoder

mencoder-1.0-0.90.rc2.lvn8


[user@localhost ~]$ rpm -qa | grep ffmpeg

ffmpeg-libs-0.4.9-0.41.20071011.lvn8




I have read various post and went to


http://www.mplayerhq.hu/MPlayer/releases/codecs/

and downloaded

windows-all-20071007.zip 07-Oct-2007 21:44 12.7M

I then install just the codecs to:
/usr/lib/codecs
/usr/lib/win32

Mplayer still won't play either wma or wmv

Thanks in Advance for all your help,
DigitalDude

wintersm
14th April 2008, 03:50 AM
try copying the codecs you downloaded into /usr/lib64/codecs and download http://www3.mplayerhq.hu/MPlayer/releases/codecs/essential-amd64-20071007.tar.bz2 and extract the files into there too..

i got my codecs from http://www4.mplayerhq.hu/MPlayer/releases/codecs/essential-20071007.tar.bz2

the trick on fedora is using /usr/lib64/codecs

:)

archo
14th April 2008, 04:12 AM
These worked for me on x86_64:
http://www1.mplayerhq.hu/MPlayer/releases/codecs/essential-amd64-20071007.tar.bz2
Extract the contents to /usr/local/lib/codecs
I guess this location is different because of how mplayer is compiled in the Fedora RPM?

digitaldude
14th April 2008, 04:39 AM
Thanks wintersm and archo for your help.

I downloaded the exact codecs at the link given by wintersm. I extracted them into /usr/lib64/codecs. Then rebooted the system.
I got the same two error messages from Mplayer:
=============================================
Fatal error!
Error opening/initializing the selected video_out (-vo) device.

Error!
Cannot find codec for audio format 0xA.
=============================================
I really need this to work.

Thanks Again,
DigitalDude

digitaldude
14th April 2008, 04:49 AM
I decide to add this information into the mix in case in would help someone who knows a lot more than me to determine what "the problem" might be or in fact is the case.

Thanks in Advance,
DigitalDude

[user@localhost ~]$ rpm -qi mplayer
Name : mplayer Relocations: (not relocatable)
Version : 1.0 Vendor: rpm.livna.org
Release : 0.90.rc2.lvn8 Build Date: Fri 15 Feb 2008 04:12:57 AM CST
Install Date: Fri 11 Apr 2008 09:08:58 AM CDT Build Host: plague-builder.livna.org
Group : Applications/Multimedia Source RPM: mplayer-1.0-0.90.rc2.lvn8.src.rpm
Size : 8625970 License: GPLv2+
Signature : DSA/SHA1, Fri 15 Feb 2008 05:20:19 AM CST, Key ID 71295441a109b1ec
Packager : rpm.livna.org <http://bugzilla.livna.org>
URL : http://www.mplayerhq.hu/
Summary : Movie player playing most video formats and DVDs
Description :
MPlayer is a movie player that plays most MPEG, VOB, AVI, OGG/OGM,
VIVO, ASF/WMA/WMV, QT/MOV/MP4, FLI, RM, NuppelVideo, yuv4mpeg, FILM,
RoQ, and PVA files. You can also use it to watch VCDs, SVCDs, DVDs,
3ivx, RealMedia, and DivX movies.
It supports a wide range of output drivers including X11, XVideo, DGA,
OpenGL, SVGAlib, fbdev, AAlib, DirectFB etc. There are also nice
antialiased shaded subtitles and OSD.
Non-default rpmbuild options:
--with nemesi: Enable libnemesi support (mutually exclusive with LIVE555)
--with samba: Enable Samba (smb://) support
--with xmms: Enable XMMS input plugin support
--with amr: Enable AMR support
--with libmad: Enable libmad support
--with openal: Enable OpenAL support
--with jack: Enable JACK support
--with arts: Enable aRts support
--with esound: Enable EsounD support
--with directfb:Enable DirectFB support
--with svgalib: Enable SVGAlib support

digitaldude
14th April 2008, 06:00 PM
Since it appears that no one one had any suggestions for a solution. Even trying something on a different player that they know works for wma wmv for 64 bit. I thought I would try some experimentation and report back to the forum my results. I'm sure there are a few knowledgeable people out there who could tell me why this next approach would or wouldn't work but there is nothing like an old empirical test to confirm a hypothesis I guess.

So here is what I did.
I uninstall all the 64 bit base apps for mplayer, the mencoder and gui etc.

Then I added the i386 lvna repository and then selected for install the i386 version of Mplayer mencode etc. The Package manager automatically informed me of the additional i386 dependencies that were needed and I downloaded and installed the entire lot.

Keep in mind that I had previously download and installed

windows-all-20071007.zip 07-Oct-2007 21:44 12.7M

I then install just the codecs to both locations:
/usr/lib/codecs
/usr/lib/win32


Guess What?
That didn't work either. I got one of the identical error messages as before plus and 2nd error message that was different than the one using x86_64 version.
=============================================
Fatal error!
Error opening/initializing the selected video_out (-vo) device.

Error!
Could not open/initialize audio device -> no sound.
=============================================

I thought at the least this might help other in the community with some useful data so I thought I would report back my findings.

Is there anyone out there that has successfully gotten any player on x64 to play wma and wmv even if the mplayer is 32 bit? I would really appreciate them letting me know.

Secondly, I could just be whistling in the dark here and simply be to naive to be aware of the fact that what I am attempting to do is just not possible. If that is the case, Would some kind soul out there let me in on the bad news?

Thanks in Advance,
DigitalDude

digitaldude
14th April 2008, 08:36 PM
Oh and another thing for the community.

Since my last post. I installed the 32 bit version of Kplayer.
Guess What?

I can now play both wma and wmv on 64 bit system with a 32 bit Kplayer even though MPlayer continues not to work.

Go figure.

So for me the stupid solution that works for reasons I don't know are:

Uninstalled all 64 bit version of MPlayer et. al. as stated above in previous posts.
Installed i386 version as stated above. Included right right codecs as stated above in /usr/lib/win32 and /usr/lib/codecs (because don't know which one is correct so did both)
Remember MPlayer still doesn't work.
Then lastly, Installed 32bit Kplayer. Then suddenly Kplayer will play the audio and video of wma and wmv files even though MPlayer won't .

If anyone want to add a explanation for my observed success and even maybe which parts of the recipe are probably not necessary please go ahead and add to this post.

Thanks,
DigitalDude

wintersm
15th April 2008, 01:24 AM
you could try the rpm versions of the codec libs..

http://www.mplayerhq.hu/MPlayer/releases/codecs/mplayer-codecs-20061022-1.x86_64.rpm
http://www.mplayerhq.hu/MPlayer/releases/codecs/mplayer-codecs-extra-20061022-1.x86_64.rpm

i used to use them ok until i got some realplayer files, i had to get the dll's from somewhere else for those..

one thing to watch out for is that not every codec is supported, sometimes something strange is used, so it pays to test with some different files..