View Full Version : Help mounting Ntfs Partitions

24th February 2004, 02:31 PM
I have installed on my system Fedora core 1 as well as Windows Xp. I want to mount my ntfs partitions on Fedora but i can't find a way to do it. I have the default kernel on it. I don't want to write on it ( I must install the 2.6 ) but simple read from it.


24th February 2004, 03:14 PM

24th February 2004, 03:35 PM
There are two options you could take:

One is to follow the tutorial located here and build support into the kernel yourself:

The other is to follow the link frannack gave you to the RPM section. There you can download an RPM for FC1.
To set things up all you need to do is:

#rpm -ivh kernel-ntfs-version.rpm
#/sbin/modprobe ntfs
#mkdir /mnt/windows
#mount -t ntfs -r /dev/hdxx /mnt/windows

NOTES: After the modprobe you can check the ntfs module was loaded with:

#lsmod | grep ntfs

Exchange the /dev/hdxx in the mount command to whatever your XP partition is on.
Use this to find out:

#fdisk -l

Then you can simply cd into the /mnt/windows directory to access you XP contents read-only.

26th February 2004, 01:59 PM

Evrything is ok i can now mount easily my ntfs partitions. I used the ntfs rpms style.

Can i somehow mount the ntfs partitions when fedora starts. I used to have Suse 9.0 and when you clicked on the hard disks icons on the desktop it mounted automatically the partitions. Can I do something like that on my Fedora?

26th February 2004, 02:09 PM
See this page for instructions:

27th February 2004, 09:39 PM
When I am root i can mount and unmount my partitions through the hard drive icons based on my desktop. When I am simple user I can't!
I read at the faq that you must put at the fstab line after the ro the command uid=your uid number but still nothing works.
Someone told me to put umask=0000 and still doesn't work.

Any suggestions please

28th February 2004, 06:20 AM
Did you try all three? The bottom one should work for user:

/dev/hda1 /mnt/windows ntfs ro,umask=0222,uid=flatcap,gid=winuser 0 0

Change uid and gid to your username.

14th March 2004, 07:56 PM
[root@localhost peeter]# /sbin/modprobe ntfs
[root@localhost peeter]# dmesg | grep NTFS
NTFS driver v1.1.22 [Flags: R/O MODULE]
[root@localhost peeter]# cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
nodev ramfs
nodev devpts
nodev usbdevfs
nodev usbfs
nodev autofs
[root@localhost peeter]# /sbin/fdisk -l

Disk /dev/hda: 123.5 GB, 123522416640 bytes
255 heads, 63 sectors/track, 15017 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1305 10482381 7 HPFS/NTFS
/dev/hda2 2611 15017 99659227+ 7 HPFS/NTFS
/dev/hda3 1306 1318 104422+ 83 Linux
/dev/hda4 1319 2610 10377990 f Win95 Ext'd (LBA)
/dev/hda5 1319 2480 9333733+ 83 Linux
/dev/hda6 2481 2610 1044193+ 82 Linux swap

Partition table entries are not in disk order
[root@localhost peeter]# mount /dev/hda2 /mnt/windata -t ntfs -r -o umask=0222
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost peeter]#
/mnt/windata exists!

I have tried many things, but nothing helps. I am too noob. I have been seaching a solution to it for two hours (at least) already!
Please help!

15th March 2004, 09:02 AM
Try this:

#mount -t ntfs -r /dev/hda2 /mnt/windata
#mount -t ntfs -r -o umask=0222 /dev/hda2 /mnt/windata

You need to specify options before directories.
The too many mounted file systems might be an issue. Can you output `mount` thanks.

15th March 2004, 09:53 AM
[root@localhost peeter]# mount
/dev/hda5 on / type ext3 (rw)
none on /proc type proc (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
/dev/hda3 on /boot type ext3 (rw)
none on /dev/shm type tmpfs (rw)
[root@localhost peeter]#

[root@localhost peeter]# /sbin/modprobe ntfs
[root@localhost peeter]# mount -t ntfs -r /dev/hda2 /mnt/windata
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost peeter]# mount -t ntfs -r -o umask=0222 /dev/hda2 /mnt/windata
mount: wrong fs type, bad option, bad superblock on /dev/hda2,
or too many mounted file systems
[root@localhost peeter]#

As you can see that didn't help. By the way I have tried it already. I didn't find any answers by seaching in Google too. I tried many ways to format that line. Nothing helps. I have slept only three hours because of that (actually I had to wake up early too). I don't have very much hope left. Maybe I try Mandrake in the future and leave Fedora, but actually I don't want to do that :(

15th March 2004, 09:58 AM
I don't know about partitions very much. But maybe it is because hda2 is one part of the extended hda4...

15th March 2004, 08:46 PM
I added the following line to fstab:

/dev/hda2 /mnt/windata ntfs ro,umask=0222,uid=peeter,gid=peeter 0 0
and on startup I saw the same line (mount: wrong fs type, bad option, bad superblock on /dev/hda2, or too many mounted file systems) running by. But after that I saw a line that was about mounting too. It said something about cluster size and that ntfs partition is not totally supported or something like that.

Maybe that helps to help :p

16th March 2004, 04:14 AM
The problem is solved now. But today I cannot say how I did it. I am too tired to say something. It's 05:10 already. But I found a solution! It took so many hours to figure it out. Oh, man, I am so sleepy.


16th March 2004, 04:52 AM
Great! Good to see the problem finally resolved. WHen you've had some rest (you deserve it!), post what you believe you did to get it working so others can hopefully learn from your experience. Then we can mark it as RESOLVED. :)

16th March 2004, 10:01 PM
Actually I just upgraded kernel to 2.6.4. But by default the support of ntfs is disabled. It should be enabled in the config.

If to use kernel 2.4.xx, then ntfs drive's cluster size must be 4kb or less, otherwise it doesn't work. I read that here:
Kernel 2.4.xx users have to use that old ntfs driver and it has some limits as you can read in that page.

That was it, I think.

I don't have very much time to tell detailly what I did.

On the whole it wasn't so hard, but I just didn't know what to do and seaching for information took very much time. And I compiled and installed the kernel 2-3 times, because I did always something wrong.

OK. That's it for now.

20th March 2004, 07:18 PM
I was fed up with the problems with kernel 2.6.4. So I made fresh install to the Fedora (linux system was too messed up to just "uninstall" kernel 2.6.4).

Now I have kernel 2.4.22 and I want to enable ntfs support. The problems I had before (see above) was because I tried to use old ntfs drivers, but those don't support cluster size that is larger than 4kb.

So, to enable ntfs support I have to install the new version of ntfs drivers, but those are only for kernel 2.4.24 and 2.4.25 as you can see here:

What to do? May I install linux-2.4.25-ntfs-2.1.6a.patch.bz2 instead?

21st March 2004, 12:12 AM
I have got kernel 2.4.25 now, but I just figured out that those ntfs driver fails are in patch format and I cannot just install them (I just learnd that : p). I cannot patch that modul to the sourch also, because I installed the new kernel with rpm. Any ideas now? I suppose that I have to get the source code of kernel 2.4.25 or is there any rpm files available of those ntfs drivers (I didn't find)?

Sorry for the spam, but I thought that I should inform you how far I am.

21st March 2004, 11:35 PM
Basically all problems have been eliminated in my case now. So I want to make a conclusion what I have learnd.

1. Ntfs support for kernels below the version 2.4.24 works only if your ntfs partition's cluster size is 4kB or below that (old drivers, you cannot use new drivers).
you can get those drivers here:
2. For kernels 2.4.24 and 2.4.25 there is only patch for the source code (this driver supports cluster size from 512 bytes up to 64 kB). So you have to compile that kernel with this patch again.
you can get those patches here:
Also you can read about those drivers here (new drivers):
3. Sorry, but I don't know what is about kernel 2.5.xxx
4. Kernel 2.6.4 has ntfs support built in (if you compile your own kernel, then you have to select it yourselt, it is not applied by default). So I suggest you to upgrade to kernel 2.6.4 (if you have older one and want ntfs support), it has many other good sides too. This is also the way I fixed my problem.
you can find Kernel 2.6 in FC1 HOWTO here:

Good luck!

23rd March 2004, 11:50 PM
Marked as resolved.
Remember the thread starter can mark resolved.

24th March 2004, 12:10 AM
Originally posted by Jman
Remember the thread starter can mark resolved.
This thread wasn't started by me if you thought so.