PDA

View Full Version : Lucent modems



nixBoo
2nd July 2004, 12:22 AM
I have an N800w laptop with an internal Lucent modem (ltmodem).

Previously on FC1 it worked fine with the corresponding driver (RPM install) for the 2.4.22_1.2188 kernel (using ltmodem-kv_2.4.22_1.2188.nptl.............)
Of course upon upgrading to FC2, it doesn't work anymore - an expected outcome.

I know where the source is that will support a 2.6 kernel after compiling etc. but has anyone has done this already or maybe created an RPM (call me lazy) ?

ghenry
2nd July 2004, 12:52 AM
No you are quite correct in asking for an RPM. Unfortunately the ltmodem drivers are in development for the 2.6 kernel. So no go I'm afraid. You could try them anyway.

I have kept FC1 on my laptop for this reason.

kbradl1
2nd July 2004, 02:27 AM
It is doubtful you will find an RPM for it, as the code is being updated constantly. Also the linmodems site is very slow in creating RPMs because they have to be created for so many platforms. Sometimes you just have to "bite the bullet" and hack away. I compiled it from source, found at http://www.heby.de/ltmodem and am using my ltmodem in FC2. When I compiled it, several weeks ago, it was older code that didn't support the REGPARM of the kernel. I had to recompile the kernel without REGPARM support in order for it to work. The latest updates which just came out, I believe support REGPARM. Good luck.

nixBoo
2nd July 2004, 10:35 AM
Cheers for the replies :)

I'll go forward and compile from source.
If I have issues, I'll stop and wait for an RPM - I have cable internet at home, as well as access from the workplace, so dialup is just for when I'm rarely out and about.

Many Thanks,
Boo

Valent
2nd July 2004, 01:55 PM
It's not a FC2 reply, but still...

I run Suse 9.1 on my laptop (and FC2 on desktop) and I can say that Suse made really good ltmodem rpms. Whey worked wright out of the box with my modem and kernel on Suse 9.1 is 2.6.4.

So it can be done :) Keep your hopes high. ;)

ghenry
2nd July 2004, 10:22 PM
That doesn't surprise me. We (Suretec) are currently working with Suse Enterprise Server 8 for a client and SUSE doesn't even have Amanda RPMs available for it.

Talk about annoying.