PDA

View Full Version : VMWare Player Problems



piga
4th April 2008, 09:16 PM
[malcolm@localhost ~]$ su
Password:
[root@localhost malcolm]# /usr/bin/vmware-config.pl
Making sure services for VMware Player are stopped.

Stopping VMware services:
Virtual machine monitor [ OK ]

Configuring fallback GTK+ 2.4 libraries.

In which directory do you want to install the theme icons?
[/usr/share/icons]

What directory contains your desktop menu entry files? These files have a
.desktop file extension. [/usr/share/applications]

In which directory do you want to install the application's icon?
[/usr/share/pixmaps]

Trying to find a suitable vmmon module for your running kernel.

None of the pre-built vmmon modules for VMware Player is suitable for your
running kernel. Do you want this program to try to build the vmmon module for
your system (you need to have a C compiler installed on your system)? [yes]

Using compiler "/usr/bin/gcc". Use environment variable CC to override.

What is the location of the directory of C header files that match your running
kernel? [/lib/modules/2.6.24.4-64.fc8/build/include]

Extracting the sources of the vmmon module.

Building the vmmon module.

Using 2.6.x kernel build system.
make: Entering directory `/tmp/vmware-config18/vmmon-only'
make -C /lib/modules/2.6.24.4-64.fc8/build/include/.. SUBDIRS=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/kernels/2.6.24.4-64.fc8-i686'
CC [M] /tmp/vmware-config18/vmmon-only/linux/driver.o
CC [M] /tmp/vmware-config18/vmmon-only/linux/hostif.o
CC [M] /tmp/vmware-config18/vmmon-only/common/comport.o
CC [M] /tmp/vmware-config18/vmmon-only/common/cpuid.o
In file included from include/asm/bitops.h:2,
from /tmp/vmware-config18/vmmon-only/./include/vcpuset.h:74,
from /tmp/vmware-config18/vmmon-only/./include/modulecall.h:23,
from /tmp/vmware-config18/vmmon-only/common/vmx86.h:18,
from /tmp/vmware-config18/vmmon-only/common/hostif.h:18,
from /tmp/vmware-config18/vmmon-only/common/cpuid.c:14:
include/asm/bitops_32.h:9:2: error: #error only <linux/bitops.h> can be included directly
make[2]: *** [/tmp/vmware-config18/vmmon-only/common/cpuid.o] Error 1
make[1]: *** [_module_/tmp/vmware-config18/vmmon-only] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.24.4-64.fc8-i686'
make: *** [vmmon.ko] Error 2
make: Leaving directory `/tmp/vmware-config18/vmmon-only'
Unable to build the vmmon module.

For more information on how to troubleshoot module-related problems, please
visit our Web site at "http://www.vmware.com/download/modules/modules.html" and
"http://www.vmware.com/support/reference/linux/prebuilt_modules_linux.html".

Execution aborted.

[root@localhost malcolm]#

Seve
4th April 2008, 10:10 PM
Hello:
I assume this is your first time configuring VMWare ?

If so, make sure that you first have the following installed
yum groupinstall "Development Tools"

yum install xinetd kernel-devel

Then try vmware-config.pl again

If that fails then grab the latest (I think it's) vmware-any-any-update116 package from here http://vmkernelnewbies.googlegroups.com/web/vmware-any-any-update-116.tgz?gda=2v9KT04AAAAGlSSxO40Vbd18uKHVQhojT3QEq2 pfTMB9CU2H2__AFGG1qiJ7UbTIup-M2XPURDSGXdvV5n_wsDUmPsx7kjwlI6ntQuOhZp5frm-yOmhQvw
extract it and run
./runme.pl

Seve

adprice
5th April 2008, 05:59 AM
yup, I was having the same problem after updating my kernel. The any-any patch fixed it. Thanks!

piga
5th April 2008, 07:17 AM
I have tried both suggestions with no success, do you have any other suggestions?

piga
5th April 2008, 07:34 AM
Updated the kernal and the any-any patch works now, thanks for trying to help.

qiang.z.m
7th April 2008, 08:22 AM
change asm/bitops.h to linux/bitops.h, that works.

Like this:

1. tar -xf /usr/lib/vmware/modules/source/vmmon.tar
2. vim vmmon-only/include/vcpuset.h
3. change asm/bitops.h to linux/bitops.h at line 74
4. tar -cvf vmmon.tar vmmon-only
5. mv /usr/lib/vmware/modules/source/vmmon.tar /usr/lib/vmware/modules/source/vmmon.tar.bak
6. cp vmmon.tar /usr/lib/vmware/modules/source

You can get more details here:
http://zhiqiangma.info/post/%E5%AE%89%E8%A3%85vmware-server-105-80187i386.html