PDA

View Full Version : Fedora Core 8 and mono.repo



corelon
4th April 2008, 09:41 AM
Hello,

I copied the mono.repo file as suggested in the Project Mono web site and while trying to perform the regular updates to the OS I got an error that gecko-sharp demands 2.8 version of mono, and that it could not resolve the dependencies. I unchecked the specific update, but now it asks me everytime.
Is there something I could do?
I am more used to the repository system of Ubuntu where usually the dependencies are resolved without any problems.
The reason I wanted to put the mono.repo in my repositories was that I want to be able to use the latest mono framework. Monodevelop for example on my machine was in version 0.15 while version 1.0 has already been released.
Any suggestion would be really welcome.

Regards,

Nick

[EDIT] This is the exact message I get from the updater:

Missing Dependency: mono(gtk-sharp) = 2.8.0.0 is needed by package gecko-sharp2
Missing Dependency: mono(glib-sharp) = 2.8.0.0 is needed by package gecko-sharp2

weave
28th May 2008, 03:26 PM
Hi Nick,


I get a similar dependency error but different packages.....

Missing Dependency: libexif.so.9, mono(glib-sharp), mono(gtk-sharp) and mono(pango-sharp). I'm going to remove the mono with yum, download a complete rpm zip from Novell and attempt to install that without the repository setup.