PDA

View Full Version : VMware current amount free spacenot enough create specified disk file



gwiesenekker
23rd March 2008, 11:33 AM
I installed VMware workstation 6.03 on Fedora Core 8 running kernel 2.6.24.3-34.fc8 x86_64.
I changed the default location of VMs to another ext3 filesystem.
When I try to create a VM on that filesystem with a preallocated disk as a non-root user I get the error:
"The current amount of free space on the hard disk (size in GB) is not enough to create the specified disk file: the-name.vmdk. Please choose a different location or specify a smaller disk size."
The amount shown is the amount of free space on the /home filesystem, so it looks like VMware is looking in the wrong place.
After several tries I found that this error is not given if you run VMware as root, so the workaround is to create the VM as root in the desired directory and chown that directory to the non-root user after it has been setup.

Regards,
Gijsbert

gwiesenekker
23rd March 2008, 11:51 AM
I just tried to create another virtual machine as root, and now I got the same error as root..
I analyzed my command-history, and it showed that I ran the vmware command from a directory on the target filesystem!
So the real workaround is not to run vmware as root, but to cd to a directory on the target filesystem and then start vmware You can do this from a terminal, but I created a shell script in ~/bin:
#!/bin/bash
cd directory-on-target-filesystem
/usr/bin/vmware
And changed the VMware application launcher to use this shell-script instead of /usr/bin/vmware

Regards,
Gijsbert

okcomputer44
23rd March 2008, 12:02 PM
Hi mate!

When you create the new disk just tick off "allocate all disk space now" and everything will work fine.
You maybe need to tick on "split disk into 2Gb files" but this one usually ticked already on.

There is no need to allocate all disk space at all.
I'm using VmWare server on Linux/Windows for clustering and I had never a problem with disks allocating.

I hope it helped.

Laz