View Full Version : Problem installing Dell Wireless 1395 on Inspiron 1420

21st March 2008, 07:07 PM

i just bought a DELL inspiron 1420 and installed FC8. Everything is OK except the WIFI.

The card is a DELL 1395 wireless. It is NOT recognized by the system (only the wlan0)
is available.

lspci sees it as a broadcom 4310 card. Googling around tells me they are the same (are they?)

I've tried using ndiswrapper to install XP driver (bcmwl5.inf) and the vista one on Dell's site.

Not luck yet. Dell offers preinstalled linux so it shoudlnt be difficult...right????

Any other ideas on things to try?


21st March 2008, 07:29 PM
Hello udutronik

It is possible to use ndiswrapper to control a broadcom card but Fedora has a native driver in place called b43 which usually does the job.

If the native driver is not blacklisted it will interfere with the operation of ndiswrapper.

Usual advice would be to try b43 first.

To confirm what it is best to use would you like to post back the results of:


where it relates to your wireless card. It may provide us with more information on what broadcom chipset it is using.

21st March 2008, 09:41 PM
Hello and thanks for helping!

Here is the LSPCI output relevant to wireless:

0c:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)

Hope it helps...

For your information, using ndiswrapper results by having ndiswrapper -l saying driver is installed but nothing about device being present...

21st March 2008, 10:03 PM
If you look carefully in your messages file you will see a message telling you where to go for the firmware for the card.

The b43 developers can't distribute broadcoms firmware with the driver, so you have to get the supported version of the windows driver from the site listed in your messages file (or perhaps it was in the output from dmesg?), and use a utility called fwcutter to extract the firmware and put it in the right directory. I have another laptop with one of those cards, and the procedure was quite easy. fwcutter was already installed along with the driver.

After completing this, the driver works nicely for me. At least once I got rid of that horribly buggy kernel...

21st March 2008, 10:25 PM
Hello udutronik

I'll not make any promises about a broadcom 4310. The place I get my information from is the b43 homepage here:

http://linuxwireless.org/en/users/Drivers/b43?action=show&redirect=en%2Fusers%2FDrivers%2Fbcm43xx#devicefirm ware

and they don't list the 4310.

If you choose to go the b43 route your options will be governed by the Fedora kernel you are running. Sometime in the life of Fedora 8 one of its changes introduced an update to b43 that requires different firmware to support the maximum variety of broadcom chipsets.

If you issue this command in a terminal:

rpm -q b43-fwcutter

it will return something like b43-fwcutter-011-3.fc8

If you wish to use b43 then post back that output and we'll talk further about blacklisting ndiswrapper and what you need to do and what firmware to download.

However, if you decide to continue to use ndiswrapper in view of the uncertainty surrounding your card and b43 then you will need to blacklist b43 as that will interfere with ndiswrapper.

The balcklist command in that case would be added to the file:


There will be other entries there to guide you but the command you add is:

blacklist b43

Then if you have installed ndiswrapper from Livna and run the usual "ndiswrapper -i" against your XP driver - I gather Vista drivers don't work - "ndiswrapper -l" should list your card and the rest of the ndiswrapper install is as normal. NetworkManager should then be available to control your card.

Think about the above and post back if you want to talk some more. Particularly if you decide to use ndiswrapper, how you installed it and how far you have got in its setup.

22nd March 2008, 12:30 AM
Birger : What are the messages you are talking about? I dont know about dmesg either...

bbfuller : ok, i'll try one last time with ndiswrapper since b43 doesnt officially support my card

So, here is what i did:

1) Blacklisted b43 as suggested

2) The win XP driver i found () is called bcmwl5.inf, so :

ndiswrapper -i bcmwl5.inf

3) Checking... ndiswrapper -l
output : bcmwl5 : driver installed

But nothing about the device... (from what i understand, i should read : device (address) present

Maybe its the wrong driver

By the way, output from rpm -q b43-fwcutter is :



Thanks again for future help on this!

22nd March 2008, 12:50 AM
Hello udutronik

Yes, the output from ndiswrapper -l does look deficient. I only have one card using ndiswrapper at present and that's on Sabayon. However, its output from 'ndiswrapper -l' is:

sabayonx86 ~ # ndiswrapper -l
net111v2 : driver installed
device (0846:6A00) present (alternate driver: rtl8187)

I wouldn't expect the Fedora output to look a lot different if it was working. In the days when I used ndsiwrapper - Fedora - broadcom I remember it looked pretty much like that.

One thing that is apparent though is that not all bcmwl5.inf/sys combinations are equal in ndiswrappers eyes.

I've got several variants here all of different sizes. I've attached the one I believe I used to use and you may wish to try that.

All you need to do is delete the previous one in /etc/ndiswrapper before using ndiswrapper -i on the new package.

I'd thoroughly exhaust the possibilities of ndiswrapper before you try anything with b43. It seems to be difficult to get the second one to work once you've tried the other without a re-install. I know it shouldn't be but that's just my opinion from watching what has happened to others.

With the 008 fwcutter you should use this package:


and the package to cut is the wl_apsta.o file in the kmod directory.

22nd March 2008, 01:32 AM
bbfuller, sorry for repeating myself but THANKS...

Unfortunately, it didnt work with your drivers, i still have only the "driver installed" with no reference to the device in ndiswrapper -l

So i guess we are now heading towards solution 2, fwcutter?

By the way, i dont mind reinstall, its all fresh, all my time devoted to the wifi problem...

What are the steps you suggest from here?

22nd March 2008, 08:45 AM
Hi udutronik

Welcome to the Forum.

I would suggest having a read of this Fedora specific web site, http://fedoramobile.org/wireless it should give you some information on Getting Started, Troubleshooting and info on Ndiswapper and the b43 driver.


22nd March 2008, 10:56 AM
Hello udutronik

Shame about ndiswrapper. I've been looking on their site here at the list of cards people have reported working:


and your Dell 1395 doesn't appear there. The nearest is the Dell 1390. That reckons to have a 4311 in it and work with some, but not all, bcmwl5 files in the Dell drivers. Some of those might be worth trying before you abandon ndiswrapper because I don't have a good feeling about b43.

I've just done a quick search on the internet and found someone here:


on the Gentoo forum who reckons to have got it to work.

Now ignoring all the Gentoo specific stuff like installing ndiswrapper and how they control their card it reckons to work with the files form this driver:


on the Dell website.

The author at Gentoo also seems to have got it going with b43 but in that case you would need to get a wired connection to the laptop and get your fedora up to date.

It seems to need the 011 version of the b43-fwcutter which matches to an updated version of the b43 driver in the later Fedora kernels which also requires different firmware to that we've talked about so far.

Sorry if that's a bit jumbled, I've been researching as I write and that's never good for clarity. Post back if I've not been clear.

22nd March 2008, 05:48 PM
OK for your information, i've tried ndiswrapping with the above driver - same results

Broadcom 4310 or Dell 1395 never seem to be on compatible lists...

I will manage to get access to wired connection and update my system. Then proceed with fwcutter

I'll keep you posted. Thanks

22nd March 2008, 08:44 PM
Hello udutronik

I wish you every luck.

If you are updating then:

rpm -q b43-fwcutter

should reveal the number 011 in the return.

If that is so then you will need different firmware to cut from what I specified above.

With 011 you should use this package:


and cut the wl_apsta_mimo.o file within the kmod directory.

23rd March 2008, 08:31 PM
this issue is SOLVED! Special thanks to bbfuller for all his support

For the record, here is the procedure (key is having the right driver)

Installing a Dell Wireless 1395/Broadcom 4310 with Ndiswrapper

Use this driver from here : http://ftp.us.dell.com/network/R174291.exe
and use the bcmwl5.inf from DRIVER_US dir.

For complete tutorial, refer to this page from Dell Wiki : http://linux.dell.com/wiki/index.php/Tech/Wireless/Truemobile_ndiswrapper

happy surfin' !

23rd March 2008, 09:58 PM
Hello udutronik

That's good news.

Not everyone has the patience to try lots of Windows drivers against ndiswrapper but it can be worth it.

I have a Netgear card that I can only get to work with the Windows 98 drivers from a set that are about 3 sets earlier than the current release.

Enjoy the wireless.

17th April 2008, 04:34 AM
Hey all,

I'm having the same problem with this whole ndiswrapper thing. I have the drivers working and when i ""ndiswrapper -l" it tells me the drivers are intsalled and present. I tried following the instructions on dell (http://linux.dell.com/wiki/index.php/Tech/Wireless/Truemobile_ndiswrapper) , and everything works, but at the bottom they mention turning of roaming mode. Any idea how to do that?

I'm probably missing something key...


17th April 2008, 09:12 AM
Hello ApacheRoseXB

Welcome to the Forum.

Probably best not to follow the Dell instructions for your card. Those are specifically aimed at the Ubuntu distribution that Dell support.

For Fedora the instructions are similar but different at least in part due to the fact that Fedora doesn't use 'sudo' unless you set it up.

Before you go on with ndiswrapper though, you might run:


and post back the parts that relate to 'network' and 'ethernet' cards. Fedora, being cutting edge, usually has the latest kernel drivers for wireless cards and it's just possible that yours is supported in Fedora without ndiswrapper.

Here is a generic instruction set for installing your windows driver with ndiswrapper on Fedora if you need to go ahead with that. I suggest you work through it, see what parts are different to the Dell instructions and do those:

Acquire full root rights with:

su -

That's a space and a minus sign after the su. It gives full root rights over the machine, not just over your own environment which is what you get with plain su.

ndiswrapper -i <path to your windows driver file>.inf

should install the driver,

ndiswrapper -l

if it is going to work should return "hardware present"

modprobe ndiswrapper

should load the driver into the kernel, but probably only until you reboot.

If you are lucky now and NetworkManager is running then after a short while it 'may' begin reporting wireless networks. NetworkManager is the preferred method of connecting to wireless networks with Fedora and should be located on the top Gnome Panel to the right in the notification area.

If it's not there, "Gnome System Menu - Administration - Services" will give you the opportunity to start it, set it to start at boot time and save the changes.

If it works, or indeed if it doesn't you will also need to run:

ndiswrapper -ma

and then edit the file:


as root and add the line:

alias wlan0 ndiswrapper

to it.

With that all in place, reboot the computer to get the alias recognised and open "Gnome System Menu - Administration - Network", highlight your wlan0 entry, click "Edit" and make sure now that it is set NOT to "Activate device when computer starts" but that if it is there, "Controlled by NetworkManager" is ticked. That last item will only be in place if your machine is currently fairly up to date.

Reboot and try connecting again.

If you have problems during that process I'll be looking for questions.

17th April 2008, 03:37 PM
hi again.

here is the output from /sbin/lspci:

09:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5906M Fast Ethernet PCI Express (rev 02)
0c:00.0 Network controller: Boadcom Corporation BCM4310 USB controller (rev 01)

And after following your instructions, I've got the computer to recognize that the drivers are installed and present, and in the network manager the niswrapper shows up, however whenever I try to activate it, it says "ndiswrapper device wlan0 does not seem to be present, delaying initialization."

Thanks again for the help!

17th April 2008, 04:09 PM
oh! and one more thing...

I was reading a site (http://www.linuxweblog.com/ndiswrapper) and it says that once the driver is installed and you "modprobe ndiswrapper" that my wireless light should turn on, but mine doesn't. I thought that may help in trouble shooting.

thanks again

17th April 2008, 07:47 PM
Hello ApacheRoseXB

I wouldn't worry too much about the wireless light. Whether it works or not seems to depend on the method the manufacturer chooses to control it.

I think for now, you are confusing 'Network Configuration' and 'NetworkManager'. They are two totally different ways of controlling a wireless card, and if they are both used in any way then they will conflict with each other and stop your card working.

If you have done the last part of my post #16 then you will have been in 'Network Configuration' and will have set the card not to activate at boot time etc. That should be the last time you use that particular configuration dialogue.

NetworkManager should appear in the notification area of the top Gnome panel. If all is installed correctly then left clicking on it should present you with a list of access points. Left clicking on one of those should present you with a dialogue asking for your encryption key - if you have one.

If NM is not in place, post back and we'll consider how to start it.

If that is necessary, also post back the results of the following commands issued after 'su -' as described in post #16:


iwlist wlan0 scan

19th April 2008, 12:09 AM
I'm not quite sure what the gnome notification panel is, but i did everything in post #16.

as for iwconfig, here is the output:

lo no wireless extensions.

eth0 no wireless extensions.

and for iwlist wlan0 scan:

wlan0 Interface doesn't support scanning.

19th April 2008, 09:53 AM
Hello ApacheRoseXB

The Gnome notification panel (if you are using the Gnome desktop - tell me if you are using something else) is at the top of the screen on a normal installation. It will have the Applications, Places and System menus to the left of it and to the right there will be the clock and the name you gave when installing your user. Just to the left of that is the notification area where you should see the NetworkManager notification if you have a network detected.

As you have no output though from your iwconfig command it may well not be there yet.

What output did you/do you get from:

ndiswrapper -l

23rd April 2008, 04:38 PM
People, I'm stuck too :-(

Here's my output:

[root@localhost ~]# lspci | grep Broadcom
0b:00.0 Network controller: Broadcom Corporation BCM4310 USB Controller (rev 01)

[root@localhost ~]# ndiswrapper -l
bcmwl6 : driver installed
device (14E4:4315) present

[root@localhost ~]# lsmod | grep ndis
ndiswrapper 168476 0

And now the trouble:

[root@localhost ~]# dmesg | grep ndis
ndiswrapper version 1.52 loaded (smp=yes, preempt=no)
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMIndicateStatusEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeNetBufferList'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateMdl'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeMdl'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterScatterGatherDma'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSynchronizeWithInterruptEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterMiniportDriver'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSetMiniportAttributes'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMGetBusData'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMRegisterScatterGatherDma'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferListPool'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMOidRequestComplete'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateIoWorkItem'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSetBusData'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateNetBufferAndNetBufferList'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMDeregisterMiniportDriver'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeNetBufferListPool'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisOpenConfigurationEx'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisFreeIoWorkItem'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMSendNetBufferListsComplete'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisMIndicateReceiveNetBufferLists'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisAllocateMemoryWithTagPriority'
ndiswrapper (import:242): unknown symbol: NDIS.SYS:'NdisQueueIoWorkItem'
ndiswrapper (load_sys_files:210): couldn't prepare driver 'bcmwl6'
ndiswrapper (load_wrap_driver:112): couldn't load driver bcmwl6; check system log for messages from 'loadndisdriver'
usbcore: registered new interface driver ndiswrapper

Any ideas? This is my first encounter with ndiswrapper (before Intel's chips were too good on Linux :( ), so i need hint/tip. Tnx.

23rd April 2008, 04:54 PM
Hello 4ndY

Most people who installed ndiswrapper would never notice the output from dmesg because it isn't in the usual instructions you see.

Have you actually completed the rest of the installation and found it fails or could that be a spurious message?

If it is actually causing problems then I would look around for other windows drivers for your 4310. I've actually seen other people get this one going.

A search on 4310 on the forum may give you some leads to drivers used.

23rd April 2008, 05:20 PM
Ok, I fixed it. I've been using wrong driver (Vista one probably), this one from previus page (90Mb file) is working - no errors!

This is probably the last problem:

ADDRCONF(NETDEV_UP): wlan0: link is not ready
ndiswrapper (iw_set_bitrate:442): setting bit rate failed (C00000BB)

23rd April 2008, 05:30 PM
Hello 4ndY

You are probably looking too deeply if it is working well.

21st January 2009, 04:20 PM
There is a new wireless package called broadcom-wl. I am using a Dell Inspiron 1525 with a 1395 card and it works great!

21st January 2009, 05:04 PM
There is a new wireless package called broadcom-wl. I am using a Dell Inspiron 1525 with a 1395 card and it works great!Hello krazynewfie,

The Broadcom 802.11 Linux STA driver (broadcom-wl) has been well received around here. However, it is apparently not intended to be universally applied to every Broadcom based wireless card. The Broadcom web site (http://www.broadcom.com/support/802.11/linux_sta.php) states that it is intended for use with only a few Broadcom chipsets (BCM4311, BMC4312, BCM4321, and BCM4322). In spite of that, it is known around here to have worked with a couple of additional "unadvertised" chipsets (BCM4328 (http://forums.fedoraforum.org/showthread.php?t=209124) and BCM43XG (http://forums.fedoraforum.org/showthread.php?t=208874)).

So here is my question for you. What is the chipset for which you successfully used the broadcom-wl driver? I ask because the only chipset that has been discussed in this thread is the BCM4310 USB, and until now I have not known it to be supported by the broadcom-wl driver. It is also not listed as supported by b43 at Linux Wireless (http://linuxwireless.org/en/users/Drivers/b43#unsupported) (the home of b43). That is why people always use ndiswrapper and a Windows driver with it. So it's potentially important for the record if your chipset is the BCM4310 USB or even some other one not included in those I mentioned above that are already known to work with it.
/sbin/lspci -n
/sbin/lsusbP.S.: The BCM4310 USB uses the PCI bus in spite of its name and how /sbin/lspci identifies it. I guess that's why it shows up in the /sbin/lspci report.