View Full Version : Newbie networking to XP

27th June 2004, 02:24 AM
I have some machines on my network, one of which is running fedora core 2 - the rest are on XP.

I am interested in being able to set up file sharing on the fedora machine so that my windows box can see and write to it. I have read posts around other forums and this one about how to do this, but I am completely stuck...

What I have done so far:

*Tried* to configure samba
Started the smb service
Set the domain to the same as my XP box
Set the hostname to 'andy' in network settings
*Tried* to create a share read/write

I have also tried typing in the IP of the fedora machine in IE, \\\ but it asks for a password.

Can anyone help a COMPLETE newbie to this set up file sharing?


If you need any more info, just say.

[Edit] see updated info.

27th June 2004, 02:47 AM
More info:

I have tried booting another machine with Knoppix linux live. I go into konqueror and type lan:// and it asks me fore a password. I enter the username and password for the main account on the fedora box and it shows me the name of the shared folder, "andy". When I click on the shared folder it asks me fore user and pass again, but this time using the ones I did before doesn't work.

27th June 2004, 04:45 AM
An update:

Some progress has been made. I did as suggested in yet another thread and set up samba to use encrypted passwords and created a user account with the same name and password as on my windows machine. Now, when I go in network places on windows, I can see the samba server. I go to it and see the folder I shared, but when I click on the folder I get this error:

\\\andy is not accessible. You may not have permission to use this network rescource. Network access is denied.

27th June 2004, 06:20 AM
Samba isn't always that simple. there is a good samba howto on the samba org site that should help you along the way...make sure to follow all of the steps...

a couple of things...

If you are using user level security, you need to "samabbuer [name]"
If you are using share level, you need to make sure your shares are browable and r/w
don't use domain security unless you have a domain and really know what you are doing.

27th June 2004, 06:59 AM
Typo alert...
"samabbuer [name]"
smbuser (as root) :D

27th June 2004, 08:26 AM
Let us know how you get on and don't forget to visit the poll...

27th June 2004, 09:01 AM
Thanks for the suggestions, will try then and keep you posted :D

27th June 2004, 11:23 PM
I have edited the smb.conf so that browseable = yes under home and my share, but that didn't help. I am not sure what you mean by smbuser [name]?


28th June 2004, 06:11 AM
If you're validating based on user logins (which is the default), you need to specifically add users to the Samba system. This is done by invoking the smbuser program and entering in the user's Windows information (name, password).

I would recommend installing the swat package - this provides a web-interface to setting up Samba, along with some extremely helpful help pages and information. One caution: don't let the number of configurable options scare you off - most of the ones that are blank can be left that way. You may need to tweak some of them, though, and that's where the "help" links come in handy.

29th June 2004, 08:10 AM
As a follow-up. I'm doing basically the same thing...In the past on RH7 and RH8 everything wored great, but there have been some changes in the lastest release...I tried confiuring from the GUI, share level etc...and get a nasty Guest prompt asking for password...none work...

I haven't had time to look at the configs, but my plan is to go back through the old Samba Howto and follow the steps...I'll let you know what I find.

Also, I noticed the the old smbadduser tool is gone...not sure why...I hate it when they replace perfectly good CLI tools with GUI stuff...at the very least they could have left the old tool in there...


29th June 2004, 10:05 AM
I haven't been able to use the smbuser command, where should I operate it from? I tried typing 'smbuser angelfly' in a terminal as root but nothing happened, said it couldn't be found or wasnt valid or something.

29th June 2004, 10:34 AM
It's a GUI config tool. Should be in one of the Gnome menues called samba. If it's not there, then you need to load them...or just load swat

5th July 2004, 06:23 AM
Well, I've completed the basics with Samba...

my FC2 box is now showing in network neighborhood for XP, I can access and browse all shares, and I can even mount shares from the XP box to the FC2 server.

if you still need help Anglefly, let us know...samba seems to be working fine...


add a user through the Samba tools in the GUI
use user level authentication
make sure that you are mounting drives with the correct username and password (not server/username)
I would turn on the WINS from the Linux side...that's in smb.conf.