PDA

View Full Version : Desktop icons | new windows



Elena147
10th March 2008, 12:04 PM
question 1.
hej hej, i hate it when my desktop is fulled with icons, now, when i install fedora there are allready some icons, is it possible to del those, or will it hurt my computer??

question 2.
When i would open a document, and i go in my map, my "browser" always open a new window when i go in a map, is it possible to let it open the map in the same window?

best regards

LordMorgul
10th March 2008, 01:39 PM
You can turn off Nautilus drawing your desktop entirely if you wish, but no icons at all will show up and you will have no context menu for the desktop either.

First install gtweakui: yum install gtweakui

Then open gTweakUI - Nautilus from the System->Preferences menu, then uncheck use nautilus to draw the desktop.

For the second question, post what site you're visiting for the map. You can control some of the browser behavior as to which window or tab a new window is supposed to open in, but its different depending on how the site is doing it. You may want to install an addon called 'Tab Mix Plus' from addons.mozilla.org which allows you to really control what is going to happen for a link that has a target (creates a new window).

Hlingler
10th March 2008, 01:42 PM
Hello Elena:

Yes, you can do this, and it should not "hurt" anything, but how you do it depends on what desktop you are using. So, what desktop are you using: KDE or GNOME?

If KDE, you can remove some of the desktop icons by right-clicking on the desktop itself, then select "Configure Desktop"; from the pop-up window, select "Behavior=>File Icons" and Behavior=>Device Icons" and uncheck the ones that you do not want. If you have created custom desktop icons of your own, simply delete them.

The file browser behavior is also controlled differently in KDE (Konqueror file manager) versus GNOME (Nautilus file manager). For Konqueror, the setting you want is Konqueror=>Settings=>Configure Konqueror=>Behavior=> uncheck "Open in separate windoes".

V

Wayne
10th March 2008, 01:46 PM
There was a bug in F8 on release that showed mounted partitions on your Gnome desktop. If that's your problem then see post #14 here:

http://forums.fedoraforum.org/forum/showthread.php?postid=896610#poststop

Wayne

JN4OldSchool
10th March 2008, 01:49 PM
hej hej, I was gonna ask what DE you are using but question 2 answered that!

1. Yes, you can delete the desktop icons. You will also find "computer" and "home" and "trash" in the browser pane on the left or in the places menu.

2. Go to preferences - personal - file management in your menu and open the second tab and check "always open in browser window."

To answer your question here:

http://forums.fedoraforum.org/showthread.php?t=183220

You can autostart programs by going to preferences - personal - sessions and adding the program you want to start here.

LordMorgul
10th March 2008, 01:52 PM
Ah, I misunderstood question 2, hlinger is probably on the right track.

For Gnome, to do the same thing (make file browsing windows open in the same window), you want to go and open gTweakUI - Nautilus, and check the 'always use browser mode' button.

Or type: gconftool-2 --type bool --set /apps/nautilus/preferences/always_use_browser true

sidebrnz
10th March 2008, 09:19 PM
Is it possible to tell Nautilus that I don't want anything for a background but do want icons? That way I could use xplanet properly.