PDA

View Full Version : Pidgin will not automatically connect



SpectrumDT
7th March 2008, 04:39 PM
Hello.

I am using the Pidgin messenger program and having trouble with it: It refuses to automatically connect on startup. When it starts, I get "Waiting for network connection" forever, and it never connects. I have to manually set my status to "Offline" and then back to "Available" before it connects to anything.

I am using MSN, AIM, ICQ and Jabber/Google Talk protocols through Pidgin. The problem pertains to all four of them.

I had the exact same problem with Kopete back when I used that.

Can anyone help? How do I make it automatically connect?

Thanks in advance.

PS: Sorry if this is in the wrong section. It might belong under "Networking", I don't know.

bsquare
7th March 2008, 08:51 PM
"It refuses to automatically" -> how did you try ?

SpectrumDT
8th March 2008, 01:28 AM
"It refuses to automatically" -> how did you try ?
Thanks for the reply.

Hm, good question.

I thought there was a "connect automatically at startup" checkbox that I had checked somewhere, but now that I look through the Preferences, I can't seem to find any such option.

Now I'm confused. Is Pidgin even supposed to have such a feature?

tw2113
8th March 2008, 03:44 AM
click on accounts >> manage, and see if you have "enabled" checked.

SpectrumDT
8th March 2008, 02:33 PM
click on accounts >> manage, and see if you have "enabled" checked.
Yep, all four accounts are "enabled".

As it turns out, the symptoms I described above are not entirely accurate. At times it actually does connect on its own after a while. At least on some of the accounts. Google Talk and AIM seem more willing to connect, whereas ICQ and MSN hardly ever do without manual assistance.

bsquare
8th March 2008, 05:22 PM
What do you do manually to make it works ?

SpectrumDT
9th March 2008, 04:17 PM
What do you do manually to make it works ?
I right-click the tray icon and set my status to "offline", then change status again to "available".

Hlingler
9th March 2008, 08:05 PM
Is your firewall setup to allow incoming connections to port 5190 (AOL/AIM)? And port forwarding, if you're inside a LAN?

V

SpectrumDT
9th March 2008, 08:27 PM
Is your firewall setup to allow incoming connections to port 5190 (AOL/AIM)? And port forwarding, if you're inside a LAN?

V
I just now set the firewall to let port 5190 pass through. Doesn't seem to make any difference.

Should the port forwarding matter? Remember, I CAN connect fine enough. It just won't do it automatically on startup.

Hlingler
9th March 2008, 08:36 PM
Actually, it should not have been necessary to set incoming to allow port 5190, since responses to outgoing login requests should be allowed. But I thought it was worth a try.... Port forwarding inside a LAN, however, would be mandatory, if the pidgin machine was inside the LAN.

V

SpectrumDT
9th March 2008, 11:19 PM
Actually, it should not have been necessary to set incoming to allow port 5190, since responses to outgoing login requests should be allowed. But I thought it was worth a try.... Port forwarding inside a LAN, however, would be mandatory, if the pidgin machine was inside the LAN.

V
All right, thanks. I will look into the port forwarding, then.

Hlingler
10th March 2008, 01:38 AM
Here's my firewall setup. Machine at 192.168.0.1/192.168.1.1 (out-side/in-side) is the router/firewall. Machine at 192.168.2.2 is running Pidgin, two hops away. Note that the machine running Pidgin has no firewall running (not necessary inside LAN if main firewall is setup correctly).

V