View Full Version : Broadcom wireless card on HP dv6000

Xx r3negade
29th February 2008, 07:45 AM
I'm attempting to get a broadcom wireless card working on my HP.
I tried to install a driver using ndiswrapper. I looked at the driver's status and got this:

bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)

So...that's some progress, right? But it still doesn't work.

SIOCSIFFLAGS: Cannot assign requested address
SIOCSIFFLAGS: No such file or directory
is what I get when I try to activate the device
So I check the documentation, which suggests to use the alternate driver (ssb in this case)

[root@localhost ~]# rmmod ssb
ERROR: Module ssb is in use by b43

So how do I stop b43?

Xx r3negade
29th February 2008, 09:16 PM
Any help, please, all I need to know is how to stop b43 (my other networking device) from using ssb, so it can be used by ndiswrapper

1st March 2008, 02:13 AM
Hello Xx r3negade

The general advice if you are using a broadcom card that is other than the most recent, is to try the b43 driver.

If it doesn't work with that and you need to use ndiswrapper then as you have found, you may need to blacklist the various parts that go with the b43.

The route to that is to edit the file:


There are probably entries already there to guide you but the lines you need to add are:

blacklist b43
blacklist ssb

You should be looking for NetworkManager to control the software and that usually appears on the top Gnone Panel to the right in the notification area.

To give it a clear shot at controlling the card though you should open the:

System Menu - Administration - Network

application, highlight you card and click "Edit" and select for it not to be activated at startup. If your system is up to date then there may also be an option to tick "Controlled by NetworkManager" and that should be done.

If for some reason you are going to use some other method of controlling the card then NetworkManager should be stopped in:

System Menu - Administration - Services

otherwise you will have two things trying to control the card with unpredictable effects.

Hope that helps.

Xx r3negade
1st March 2008, 10:20 PM
Ok, first off, I don't think it was the right broadcom driver. So here's what I did:
>I uninstalled the incorrect driver:

ndiswrapper -r bcmwl5
>I downloaded the installer of the correct driver and ran it with Wine
>I installed the correct driver:

ndiswrapper -i bcmwl5.inf
>I checked the status:

ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4311) present (alternate driver: ssb)

>I unloaded the alternate driver:

[root@localhost ~]# rmmod ssb
ERROR: Module ssb is in use by b43

>Didn't work, so I edited /etc/modprobe.d/blacklist:

blacklist b43
blacklist ssb

>I rebooted, and got this message during boot:

WARNING: /etc/modprobe.d/.blacklist.swp line 1: ignoring bad line starting with 'b0VIM'

I get this whenever I try and interact with the network. So editing the blacklist with Vim f---ed it up??? Oh well, no matter.
rmmod ssb now works
>So now I go to the network manager, look for my ndiswrapper driver in the "Hardware Tab", and....
>So, I decide to try plain old b43 again(I take it off the blacklist) and get this error:

ndiswrapper device wlan0:0 does not seem to be present, delaying initialization.

b43 is in NO WAY supposed to be associated with ndiswrapper!
>So now I'm completely screwed. My ndiswrapper device magically vanished, and b43 is having a f---ing identity crisis. Is now the time that I should just format and re-install Windows?

1st March 2008, 10:55 PM
Hello Xx r3negade

I think your problem is probably to do with trying too many ways of controlling this card without fully implementing one or stopping the other.

Using vim might be the hard way of editing /etc/modprobe.d/ blacklist if you are getting those results.

I don't have a file called .blacklist.swp myself, my suggestion is that you open each in turn in a visual text editor like gedit and copy and paste back here what you have in there.

If you need to edit such files you could always call gedit from a root terminal and get root editing rights that way.

If you go back to trying to use b43 while you are still loading ndiswrapper I suspect you will get error messages, which is what we appear to be seeing in your last quote.

There should be a line about "alias wlan0 ndiswrapper" in /etc/modprobe.conf for ndiswrapper to work and that should be removed or commented out if you are going to try and use b43 again.

My advice is settle on one way of controlling the card, disable the other method and go from there. Post back with which you are going to use and we'll try from there.

Edit: By the way, I have two broadcom based cards here using b43 and neither turn up in the 'Gnome system menu - Administration - Network'. I don't know why but it is so. The NetworkManager software of the top Gnome panel controls them perfectly though.

Xx r3negade
1st March 2008, 11:50 PM
These were the contents of my /etc/modprobe.conf file:

alias eth1 forcedeth
alias wlan0 b43
options snd cards_limit=8
alias snd-card-7 snd-usb-audio
options snd-usb-audio index=7

I have absolutely no idea why Fedora is still associating wlan0 with ndiswrapper. I have even uninstalled ndiswrapper from my system.

2nd March 2008, 12:21 AM
Hello Xx r3negade

We haven't even discussed yet just which of the broadcom chipsets you are using. That will have some bearing on which method of controlling your card you should use. Can you tell us what it is?

Leaving aside the error message you are seeing, that may not stop the b43 working.

Have you got your system completely up to date, if you are using an up to date system you will have a different version of the b43-fwcutter in place and will have to use a completely different version of the b43 firmware to cut. Where did you get that firmware?

What happens if you use the command:


Do you see a wireless interface listed?

If you do, do you get any response from:

/sbin/iwlist wlan0 scan

Of course, if the first command identifies an interface other than wlan0 then substitute that in the second command.

Do you see any wireless interfaces in the NetworkManager software that I mentioned in post #5?

Xx r3negade
2nd March 2008, 03:25 AM
I got the driver for my card here (http://h10025.www1.hp.com/ewfrf/wc/softwareList?os=228&lc=en&cc=us&dlc=en&product=1842155) , to be honest I don't know the exact model of card. My system is completely up to date with b43-fwcutter - 011-3.fc8.x86_64 installed

iwconfig lists this output:

lo no wireless extensions.

eth1 no wireless extensions.

so no, wlan0 doesn't show up

Do you see any wireless interfaces in the NetworkManager software that I mentioned in post #5?
Like I said, the interface I installed with ndiswrapper *used* to show up, along with b43. Now just b43 shows up.

2nd March 2008, 06:38 AM
yeah im having the same problem. i used ndiswrapper before and it worked like a snap. now its saying invalid driver. im using the same one as i did before. is it because of newer kernel?

2nd March 2008, 11:54 AM
Hello Xx r3negade

You can usually determine more about what particular card you are using by the command:


You can usually identify the output that relates to a wireless card, try copying and pasting that back.

I not sure if b43-fwcutter works with the hewlett packard drivers.

What you are best getting is this file:


saving it to disc and then using the command:

b43-fwcutter -w /lib/firmware wl_apsta_mimo.o

Where it says 'wl_apsta_mimo.o' in the above command, you will either have to have cd'd into the directory you stored the file in for it to work or you will have to preface the file name with the complete path to the file.

That will give you the best chance of getting working firmware for your card BUT it depends on the particular model of broadcom you are using. b43 doesn't work with every broadcom chipset.


To anyone who reads this at a later date. The information to get the broadcom-wl- file is correct today. If and when the b43 fwcutter gets updated it may no longer work with that file and you will have to research another.

Xx r3negade
2nd March 2008, 08:47 PM
Okay, but it still gives me the error that "ndiswrapper device wlan0 does not seem to be present". I've edited the "alias wlan0 ndiswrapper" out of my modprobe file, as you suggested, and changed it to "alias wlan0 b43", but the computer is still detecting ndiswrapper

2nd March 2008, 08:58 PM

su -
rmmod ndiswrapper
modprobe b43
And post the output of


2nd March 2008, 09:07 PM
I also believe that if you ran 'ndiswrapper -ma' which is part of the usual instructions it adds a line to /etc/modprobe.d/ndiswrapper.

It might be worth removing that as well.

Xx r3negade
3rd March 2008, 02:24 AM

su -
rmmod ndiswrapper
modprobe b43
And post the output of


Cool, that worked. The only problem is, I have to do this every time I start up the computer. How do I load b43 automatically at startup?

4th March 2008, 05:01 AM
[root@exactor ~]# ndiswrapper -l
bcmwl5 : driver installed
device (14E4:4328) present (alternate driver: ssb)
bcmwl564.sys : invalid driver!
bcmwl5.inf : invalid driver!
[root@exactor ~]#

so thats what i get. im using the same driver i used before to get this to work. but for some reason after my last install i cant get it to work.

4th March 2008, 05:16 AM
Venumus, I'd imagine you have to remove the other drivers (bcmwl564 and bcmwl5.inf). I'm not sure of the command off the top of my head but ndiswrapper -r maybe? Just check the man page. The ssb driver is used by b43/b44 in the kernel. Dunno if that will have an affect or not. Any particular reason you're using ndiswrapper and not the native driver? If there is no reason it may be worth switching.

Renegade, add "alias wlan0 (or whatever name of your card is) b43" to /etc/modprobe.conf. Just for the sake of knowledge you can check out the manpage on modprobe.conf (also tells you about modprobe.d). That should work.

4th March 2008, 05:40 AM
because the native driver doesnt work. ive gotten it to work before but since the upgrade to the new kernel it hasnt worked. i dled and extracted the drivers like before but for some reason its not workin

4th March 2008, 06:04 AM
The new kernel means wl_apasto.o doesnt work. You have to use wl_apasto_mimo.o

4th March 2008, 06:29 AM
how do i do that

4th March 2008, 06:32 AM
I'd say "clean" up the ndiswrapper install:

su -
rmmod ndiswrapper
nano /etc/modprobe.conf
remove any "alias wlan0 ndiswrapper" entries.

Then run Dangermouse's script: http://forums.fedoraforum.org/forum/showthread.php?t=171660

4th March 2008, 06:46 AM
i did that. but i dont think my broadcom driver isnt supported...and there wasnt a wlan0 alias...is that bad

4th March 2008, 07:05 AM
Not bad, no ... kinda surprising though, I thought ndiswrapper makes one as part of the setup procedure. What card do you have? Post the output of

su -
lspci | grep Network

4th March 2008, 07:06 AM
Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

4th March 2008, 07:15 AM
Yes, you're correct it's not supported. Open a new thread (include the lspci output) and ask for help getting it set up.

4th March 2008, 10:32 AM
Hello Xx r3negade

If you are still watching this thread, there may be a solution to run that command automatically. I haven't had the need to try it myself, but I understand that you can add that command to the file:


to have it automatically executed at start time.