PDA

View Full Version : FC2: Big problem playing DVDs and video clips



Motor
21st June 2004, 12:53 AM
System specs:
Matrox G550 (32mb ram)
AMD Athlon XP2000+
512MB RAM

This computer was upgraded from Fedora Core 1 to Fedora Core 2. I deleted the old XF86Config file and let FC2 set its own xorg.conf.

Everything seems to work except for playing video clips and DVDs when the output is done via the XVideo extension. Some low resolution video clips will play, but anything larger causes problems. It fails with errors in the XVideo code when trying to play DVDs with both mplayer, and ogle.

This all worked fine in FC1, but I do remember a similar problem with an earlier RH (and XFree86) release. I can also reliably cause lower resolution clips to fail in the same way (which would otherwise work) by running XMMS first.

Can anyone help?

Example:

>mplayer -v dvd://2

[snip]

Starting playback...
VDec: vo config request - 720 x 576 (preferred csp: Planar YV12) Trying
filter chain: vo
VDec: using Planar YV12 as output csp (no 0) Movie-Aspect is 1.33:1 -
prescaling to correct movie aspect. VO Config
(720x576->768x576,flags=0,'MPlayer',0x32315659) VO: [xv] 720x576 =>
768x576 Planar YV12 VO: Description: X11/Xv
VO: Author: Gerd Knorr <kraxel@goldbach.in-berlin.de> and others Xvideo
image format: 0x32595559 (YUY2) packed Xvideo image format: 0x32315659
(YV12) planar Xvideo image format: 0x30323449 (I420) planar Xvideo image
format: 0x59565955 (UYVY) packed using Xvideo port 69 for hw scaling
[xv] dx: 0 dy: 0 dw: 768 dh: 576
*** [vo] Allocating mp_image_t, 720x576x12bpp YUV planar, 622080 bytes
[xv] dx: 0 dy: 0 dw: 768 dh: 576
*** [vo] Allocating mp_image_t, 720x576x12bpp YUV planar, 622080 bytes%
X11 error: BadAlloc (insufficient resources for operation) Type: 0,
display: 8c336c8, resourceid: 1e00001, serial: 58 Error code: b, request
code: 8d, minor code: 13


MPlayer interrupted by signal 6 in module: flip_page - MPlayer crashed.
This shouldn't happen.
It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
gcc version. If you think it's MPlayer's fault, please read
DOCS/HTML/en/bugreports.html and follow the instructions there. We
can't
and won't help unless you provide this information when reporting a
possible bug.
Uninit audio filters...
[libaf] Removing filter dummy
uninit audio: liba52
uninit video: libmpeg2
DEMUXER: freeing demuxer at 0x8c03670 DEMUXER: freeing sh_video at
0x8c06070 DEMUXER: freeing sh_audio at 0x8c1d6a8 Successfully enabled
DPMS
Xlib: unexpected async reply (sequence 0x5e)! vo: uninit ...

*******************

Ogle:

X Error of failed request: BadAlloc (insufficient resources for
operation)
Major opcode of failed request: 141 (XVideo) Minor opcode of failed
request: 19 () Serial number of failed request: 82
Current serial number in output stream: 82

foolish
22nd June 2004, 01:04 AM
Try using a different video output. It might work.

Motor
22nd June 2004, 01:22 AM
Try using a different video output. It might work.

It works with different video output (I tried it before), but this is a fault in FC2 (possibly xorg-x11). I posted a bug in RH's buzilla a few days ago only to have it dismissed as a problem with mplayer despite the fact that xine, ogle and mplayer all fail.

I'm been discussing it on the fedora-list mailing list too, and have narrowed it down a bit.

http://www.redhat.com/archives/fedora-list/2004-June/msg05228.html

Motor
26th June 2004, 10:53 PM
I posted a bug in RH's buzilla

Sorry for following up my own message, but here's some more info and a workaround for anyone who suffers from this problem has tried searching this site, and ended up on this thread:

The bug is now being tracked in freedesktop.org's bugilla:

http://freedesktop.org/bugzilla/show_bug.cgi?id=474

And relates to pixmaps being cached, but not cleared out when the memory is needed for the XVideo extension. There is a workaround suggested in the bugzilla page, adding:

Option "XaaNoOffscreenPixmaps"

to xorg.conf, giving something like this:

Section "Device"
Identifier "Videocard0"
Driver "mga"
VendorName "Videocard vendor"
BoardName "Matrox Millennium G550"
Option "XaaNoOffscreenPixmaps"
EndSection

This seems to work for me... though obviously it is just a workaround and not a solution.