View Full Version : kde applications compile error

19th June 2004, 04:23 AM
/bin/sh ../libtool --silent --mode=link --tag=CXX g++ -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -pedantic -W -Wpointer-arith -Wwrite-strings -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align -Wconversion -O2 -fno-exceptions -fno-check-new -o ksmoothdock -L/usr/X11R6/lib -L/usr/lib/qt-3.3/lib -L/usr/lib -R /usr/lib -R /usr/lib/qt-3.3/lib -R /usr/X11R6/lib welcomedialog.o tooltip.o showdesktop.o item.o confmenudialog.o confkickerdialog.o confdialog.o aboutdialog.o ksmoothdock.o main.o confkickerdialog.moc.o tooltip.moc.o welcomedialog.moc.o confdialog.moc.o ksmoothdock.moc.o aboutdialog.moc.o -lkio -lkdeui -lkdecore -lqt-mt -lpng -lz -lm -lXext -lX11 -lSM -lICE -lpthread
/usr/bin/ld: cannot find -lselinux
collect2: ld returned 1 exit status
make[2]: *** [ksmoothdock] 错误 1
make[2]: Leaving directory `/home/neo/My Downloads/ksmoothdock-3.5.1/ksmoothdock'
make[1]: *** [all-recursive] 错误 1
make[1]: Leaving directory `/home/neo/My Downloads/ksmoothdock-3.5.1'
make: *** [all] 错误 2

in FC2, when compiling ksmoothdock and some other kde apps, the same problem.

19th June 2004, 05:17 AM
did you install selinux?

19th June 2004, 01:41 PM
I've no idea, i choose 'workstation' when install FC2.
there is a directory called 'selinux' under the root, but it is empty.

27th June 2004, 05:38 PM
you are missing the library "libselinux.rpm" :D

24th July 2004, 05:35 AM
Kinda dumb Qn..i install ksmoothdock via RPM....err how am i supposed to use it?

24th July 2004, 03:12 PM
press ALT+F2 - enter "kmsoothdock" (without the quotes) and click on "Run." Once it's up (make sure your kicker panel is either hidden or on the top or sides of your screen), you can right-click on the visible dock to configure it. It's okay-ish, but not quite what I was looking for.

24th July 2004, 09:24 PM
Thanx crackers..hehe i totally forgot abt the RUN command..works now!! :D

24th July 2004, 09:30 PM
Great...now it didnt work..it crashed :(

25th July 2004, 05:46 AM
Well, that happens sometimes... run it from a terminal window, note the crash error(s), check their bug-list for a solution and/or file a bug-report. That's how stuff gets fixed and improved! ;)

26th July 2004, 03:46 PM
Well..i decided to dump ksmoothdock and get kxdocker instead...works fine for me :)

26th July 2004, 04:31 PM
Oh, the multi-megabyte download? Take a look at the files you downloaded - that clock is an image for every hour/minute combination. That's why the sucker's so big - they couldn't figure out how to animate the freakin' clock!

I was not impressed.

27th July 2004, 09:44 AM
well yeah de files r big...so wad then wld u recommend? u got anything cool dock thing u using?

27th July 2004, 06:23 PM
Yeah - it's called "kicker" ;) I gave up on a lot of eye-candy a long time ago. But then again, I am an old phart (Wyse 50 Amber, anyone?).

Der Hanseat
1st September 2004, 02:35 PM
Hi Darkmage,

you are missing the library "libselinux.rpm" :D

you forgot to mention that you also need libselinux-devel-<version>.rpm. I had libselinux-1.11.4-1.rpm installed on my laptop computer (running Fedora Core 2.A from German Red Hat Magazin with some updates) and encounter this error whenever I tried to compile KDE software such as kdeadmin from the sources.

It took me nearly a week to remember that devel packages are required for compilation.

After manually fixing checkinstall-1.6.0beta3 (where did I find the patch?) I finally have an RPM package of kdeadmin-3.2.2 running on Fedora Core providing me with kpackage. (Let's see if it works properly....)

Cheers, der Hanseat