PDA

View Full Version : FGLRX.ko not found found for kernal 2.6.23.14-115.fc8



k13pt0
8th February 2008, 02:09 AM
after a few questions couple weeks ago on the forums My system was running great. Just today there was an update for the kernel. I did the update Now my Gnome desktop just turns white seems no end to it. I restart into KDE desktop and it works. Upon start startup i get "FGLRX.KO for kernel 2.6.23.14.-115.fc8 not found" then beneath it "FGLRX DRI Will Not be enabled until one is found" . Im still learning Linux planning on buying a book next week to better understand. upon trying to rerun ati driver I get permission denied even as super user. hopefully im not the first and someone can guide me though this without having to reinstall again.

fhubers
8th February 2008, 02:19 AM
the kernel module for ati cards wasn't up on the repos yet last time I looked - you will need to log in with the older kernel (I hope you keep two versions) and run yum update and see if the new kmod-fglrx is posted yet. Never install a new kernel until you see a matching kmod-fglrx version for it.

just took a look at http://rpm.livna.org/fedora and it is not there yet. Keep checking. :rolleyes:

k13pt0
8th February 2008, 02:26 AM
honestly I dont know what i did. Said Update So i did, For future reference how do i save older version. And How do i boot into the older Kernel? Forgive my ignorance please.

Thank you for the insight ill make sure to keep checking for an update :)

fhubers
8th February 2008, 03:56 AM
if you installed grub it normally gives you the previous kernel as a boot choice - just hit the down arrow as soon as grub comes up. that should get you into a regular session - just use yumex and see if an update for kmod-fglrx is there.

if that doesn't work:

if you can't get your x session running hit ctrl+alt+f3 to get a command prompt. Log in and do the falling commands:

su
yum update kmod-fglrx

if it succedes reboot and it should now work. Not sure when the new kernel module will hit livna.

koallalays
10th February 2008, 09:47 PM
I have nearly the same problems ..... the only difference is, that, I didn't get it working at all.

I tried
1) xununtu 7.10
2) Fedora 8 without Livna's ATI drivers
3) and Fedora 8 with Livna's ATI drivers during the installation process
In all three cases I cant even get to a logon-screen coz after the init-process the display turns black and goes into standby.

1) and 2) passed the init-process without any errors, but then ... everything black
3) had the same problem as the member k13pt0 describes 'FGLRX.KO not found' and display black too


As an absolute newbie I don't even know how to get to a command line -prompt ... allready tried ctrl+alt+f3 ... only effect is that I get into grub submenues, where I don't know anything what to do.

I have orignal Fedora 8 x86_64 DVD downloaded in December with kernel 2.6.23.1-42 and have choosen the only possible (AMD) ATI-Driver which was displayed at the installation process (of course I've choosen http://rpm.livna.org/fedora/8/x86_64) ...

but ... its not working at all :(((


Can anyone help me with it? .... I was never working with Linux and this are my first trys to get it working .... so you have to guide me throug every click ;)

Thank you very much :)))




My Hardware:
Asus P5LD2 Deluxe Mainbord (Intel 945P Chipset)
Intel Pentium D830 3,0GHz Dualcore
Saphire Radeon X800GTO
Corsair DDR2 2x512MB, Dualchannel, doublesided
2x SATA II HDDs

fhubers
11th February 2008, 01:56 AM
I would recommend you start with this thread: http://www.fedoraforum.org/forum/showthread.php?t=155503 it is a very good "how to" guide on getting the ATI.

If that doesn't get you there start with posting to that forum - Leigh123 is very, very good with the ATI drivers!

koallalays
11th February 2008, 02:56 PM
Thank you :))

And finally I found the only line in the www, describing where I can type those commands :rolleyes:

http://www.fedorafaq.org/basics/

A: Text-only mode is runlevel 3. If you want to start in text-only mode, see the instructions in the runlevel question above, and change your runlevel to runlevel 3.


You should open a newbie corner here describing just those 'simple problems' ;)

fhubers
11th February 2008, 08:01 PM
Sorry - I was in a hurry when I posted and forgot to answer the other part of your question - I was only thinking about the ATI issue when I posted. I am glad you found that - I haven't used some of those techniques in a while myself, so it is helpful to be reminded when I mess up my own Kernel (which I have done on more than one occasion).

nybigjet
13th February 2008, 08:49 AM
Forget the NuBee stuff. Fedora is the forever Beta distro. Works today, broken tomorrow. Don't believe half the stuff you read here.

Mine says "needs kernel-x86_64 =2.6.23.14-107.fc8, this is not available."
No X for more then a week, I'm booting into run level 3. Here's how:
1- when the grub screen comes up, HIT e.
2- cursor down to the kernel line and hit e again
3- press return, space, and s (for single), return
4- press b (for boot) the system will boot into runlevel 1.
5- no login needed yet. Type "telinit 3" enter. (NO QUOTES)
6- you are now in runlevel 3, login as root. Type "yum update"

Good luck
--nybigjet