PDA

View Full Version : KDE and Xmms



mip
5th February 2004, 01:17 PM
How the hell do I get these to play nicely together?

The only way I can get Xmms to play is by killing artsd. What output plugin should I be using for Xmms?

Cheers.

Ug
5th February 2004, 03:39 PM
For XMMS mp3 support you should:

Download this: http://www.osnews.com/files/xmms-mp3-fc1.tar.gz
then perform this in the folder in which you downloaded the plugin:[code:1]tar -zxvf xmms-mp3-fc1.tar.gz[/code:1]
Copy the two lib files (as root) to /usr/lib/xmms/Input
Restart xmms

Then you should get mp3 support, and I think that might solve your Arts problems.

Tell us how you get on.

mip
5th February 2004, 03:44 PM
I've have already got the MP3 plugin installed and the artsd problem persists.

This seems to be a description of the smae problem <http://tinyurl.com/3a5t5>. No real solution though. I've tried using different output plugins with xmms but i either get no sound or the behaviour I have described.

BTW I'm using KDE 3.2 but I had the same problems with the version of KDE which came with FC1.

Lindy
20th February 2004, 03:36 AM
If your using xmms 1.2.8 you may have better luck with v1.2.9 . I never could get the version of xmms that shipped with core1 to work properly, it kept seg. faulting. What I did was to uninstall it and build 1.2.9 from source, and install it with checkinstall.I haven't had any problems with it since. You can find v1.2.9 at http://www.xmms.org

bakwas_internet
20th February 2004, 06:56 AM
i think problem is your output plugin....the xmms arts output plugin dont work with kde 3.2 .....more details are on xmms website.....


For anyone who has not noticed yet, it will not work with KDE 3.2


This is because in KDE 3.2 libarts (the arts client, which this plugin uses) uses gthread 2, from glib 2. As mentioned in the FAQ, xmms is currently a GTK 1 app, using glib 1. glib 1 and glib 2 cannot be used together, xmms (or any other app) will complain along the lines of "gthread system can only be initialized once" and then die. If anyone has a way around this, *please* tell me. Currently debian is alright since it looks like the next version (sarge) will release with KDE 3.1, not 3.2. After that, however, there will be problems. In short, xmms and arts *cannot* be used together as of KDE 3.2 (not even with artsdsp, that has the same problem). The only workaround I know is to wrap esd into arts ("artsdsp esd") and use the ESD output plugin.

Chris Boyle (cmb at debian.org)

source (http://xmms.org/plugins.php?details=22)

so i think u should use some other output plugin like oss or esound.....hope it helps....

bsoderror
21st February 2004, 10:34 PM
Just tried the link Lindy mentioned and got a "We're Sorry, page not on server" message for the ftp or http d/l. Bummer

Lindy
22nd February 2004, 01:28 AM
I just tested the link. It works. Might be that their server is a bit testy.

bsoderror
22nd February 2004, 03:32 AM
the link you posted works but the d/l link isn't at least for me:

We're sorry

But the page you tried to load: http://www.xmms.org/files/1.2.x/rpm/fc1/xmms-1.2.9-2.i386.rpm was not found on the server.

Please contact the webmaster (thomas at xmms.org)

bsoderror
22nd February 2004, 04:33 AM
Originally posted by Lindy
I just tested the link. It works. Might be that their server is a bit testy.

UPDATE, I was using mozilla to try and get the file, tried Opera and got it, there are still some links giving the 404 error though gonna write to thomas at xmms.org and let him know. Thanx Lindy