PDA

View Full Version : Can't get rhgb to display on boot



mrmailer
30th January 2008, 02:54 AM
Intel e1505 laptop
f8

kernel /boot/vmlinuz-2.6.23.14-107.fc8 ro root=LABEL=/ rhgb quiet

is the current boot parameter.

What am I doing wrong? It just does console detailed boot every time, despite rhgb being installed.

The screen goes blank when rhgb would normally show up, then a few moments later, console boot.

kevmif
30th January 2008, 03:06 AM
I would say that the system for whatever reason has trouble starting rhgb on your video card. Has it ever worked or did an update break it? Is your system 100% up to date?

Does anyone know if there is a log somewhere where any debug messages might show up?

stevea
30th January 2008, 03:25 AM
There may be a log message in /var/log/messages
The /etc/rc.d/rc.sysinit script is where the rhgb argument is processed.

Try login'ing in to another virtual console [<ctrl+alt+f1>, then login as root]
then type the command "/usr/bin/rhgb"

You *should* see the screen change to a blue border and the swirly in the upper right corner. If so the rhgb works. You can change back to your login session with <ctrl+alt+f7 >or see the blue-swirly again with <ctrl+alt+f8>.

Anyway that should tell you if rhgb works.

mrmailer
30th January 2008, 03:23 PM
Steve, i run it from that console and it displays fine, so this is confusing...

it does, like on boot, blank screen then show the graphical. However, on boot it blanks then goes back to console boot.

Attached is sysinit
Now, I do have selinux disabled, not sure if that matters...

mrmailer
31st January 2008, 06:46 AM
https://bugzilla.redhat.com/show_bug.cgi?id=378251