PDA

View Full Version : Aptana Studio Problem



rivalslayer
28th January 2008, 11:31 AM
I try to run Aptana on my Fedora 8, but it fails saying,

"An error has occurred. See the log file
/Drive_F/Documents/My Completed Downloads/Aptana_Studio_Setup_Linux/aptana/configuration/1201516123511.log."

I installed the latest JDK 6 U 4, but no avail....

The log file contains


!SESSION 2008-01-28 13:59:18.778 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Framework arguments: Studio
Command-line arguments: -os linux -ws gtk -arch x86 Studio

!ENTRY org.eclipse.equinox.common 4 0 2008-01-28 13:59:19.800
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:294)
at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1046)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)

!ENTRY org.eclipse.update.configurator 4 0 2008-01-28 13:59:19.802
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: J2SE-1.4,CDC-1.0/Foundation-1.0,J2SE-1.3
at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:294)
at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1046)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)

!ENTRY org.eclipse.core.runtime 4 0 2008-01-28 13:59:19.803
!MESSAGE FrameworkEvent.ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
at org.eclipse.osgi.framework.internal.core.BundleHos t.startWorker(BundleHost.java:294)
at org.eclipse.osgi.framework.internal.core.AbstractB undle.resume(AbstractBundle.java:329)
at org.eclipse.osgi.framework.internal.core.Framework .resumeBundle(Framework.java:1046)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.resumeBundles(StartLevelManager.java:573)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.incFWSL(StartLevelManager.java:495)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.doSetStartLevel(StartLevelManager.java:27 5)
at org.eclipse.osgi.framework.internal.core.StartLeve lManager.dispatchEvent(StartLevelManager.java:455)
at org.eclipse.osgi.framework.eventmgr.EventManager.d ispatchEvent(EventManager.java:189)
at org.eclipse.osgi.framework.eventmgr.EventManager$E ventThread.run(EventManager.java:291)

!ENTRY org.eclipse.osgi 4 0 2008-01-28 13:59:19.809
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2008-01-28 13:59:19.809
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v200701 11.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2008-01-28 13:59:19.809
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.

!ENTRY org.eclipse.osgi 4 0 2008-01-28 13:59:19.827
!MESSAGE Application error
!STACK 1
java.lang.IllegalStateException: Unable to acquire application service. Ensure that the org.eclipse.core.runtime bundle is resolved and started (see config.ini).
at org.eclipse.core.runtime.internal.adaptor.EclipseA ppLauncher.start(EclipseAppLauncher.java:65)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.ru n(EclipseStarter.java:177)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Nativ e Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Native MethodAccessorImpl.java:57)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(De legatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:623)
at org.eclipse.core.launcher.Main.invokeFramework(Mai n.java:336)
at org.eclipse.core.launcher.Main.basicRun(Main.java: 280)
at org.eclipse.core.launcher.Main.run(Main.java:977)
at org.eclipse.core.launcher.Main.main(Main.java:952)

!ENTRY org.eclipse.osgi 2 0 2008-01-28 13:59:19.844
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-01-28 13:59:19.844
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v200701 11.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing imported package javax.xml.parsers_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing imported package org.xml.sax_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing imported package org.w3c.dom_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-01-28 13:59:19.844
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.844
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.845
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.845
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).

!ENTRY org.eclipse.osgi 2 0 2008-01-28 13:59:19.847
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-01-28 13:59:19.847
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.common_3.2.0.v20060603.jar/ [1] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.common 2 0 2008-01-28 13:59:19.847
!MESSAGE Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.0/Foundation-1.0,J2SE-1.3
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-01-28 13:59:19.847
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.2.2.R32x_v200701 11.jar/ [2] was not resolved.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.847
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.848
!MESSAGE Missing imported package javax.xml.parsers_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.848
!MESSAGE Missing imported package org.w3c.dom_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.848
!MESSAGE Missing imported package org.xml.sax_0.0.0.
!SUBENTRY 2 org.eclipse.update.configurator 2 0 2008-01-28 13:59:19.848
!MESSAGE Missing imported package org.xml.sax.helpers_0.0.0.
!SUBENTRY 1 org.eclipse.osgi 2 0 2008-01-28 13:59:19.848
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.2.0.v20060603.jar/ [3] was not resolved.
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.848
!MESSAGE Missing required bundle org.eclipse.equinox.common_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.849
!MESSAGE Missing required bundle org.eclipse.core.jobs_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.849
!MESSAGE Missing required bundle org.eclipse.equinox.registry_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.849
!MESSAGE Missing required bundle org.eclipse.equinox.preferences_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.849
!MESSAGE Missing required bundle org.eclipse.core.contenttype_[3.2.0,4.0.0).
!SUBENTRY 2 org.eclipse.core.runtime 2 0 2008-01-28 13:59:19.849
!MESSAGE Missing optionally required bundle org.eclipse.core.runtime.compatibility.auth_[3.2.0,4.0.0).

What can be problem? Please help!!!!

majdi
22nd August 2008, 02:43 PM
Im looking for web development apps that run in gnome for developing data base driven websites, it should have html, css, php, javascript Ajax functionality.

I found this Aptana app, has anyone installed this successfully on gnome? if so what do you think of it and would you recommend any other apps for this?

demuytree
24th August 2008, 06:25 PM
I have this problem

JVM terminated. Exit code=127
/usr/bin/java
-Xmx384M
-Xms128M
-Djava.awt.headless=true
-jar /home/billyduc/aptana/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /home/billyduc/aptana/AptanaStudio
-name Aptana
-showsplash 600
-exitdata 16b000d Studio
-vm /usr/bin/java
-vmargs
-Xmx384M
-Xms128M
-Djava.awt.headless=true
-jar /home/billyduc/aptana/startup.jar
I have already installed JRE and aptana worked a little bit and then crashed ??

derekmjg
13th September 2008, 02:18 AM
I have the same problem as demuytree with the latest Aptana Studio on Fedora 9. The application starts up, but if I click on certain things it crashes with the Exit code=127 and essentially the same contents as you have. I have been successful in running Aptana Studio on Ubuntu 8.04, but it requires Sun Java 1.5 or greater (the app itself says so), and other internet sources say that it requires Firefox 2. I installed both of those on Ubuntu and so far everything is fine. The following bug submission appears to be this same issue and has not yet been resolved by Aptana http://support.aptana.com/asap/browse/STU-2024

One of the users who experienced the problem has resorted to installing Eclipse and the Aptana Studio plugin instead. I am considering going that route.

Good luck to you guys...

Derek
Weston, FL
USA

CodeTwister
12th March 2009, 12:29 PM
I use the standalone Aptana version on Fedora 9. There is a problem with firefox 3.X - so just get an older firefox version from mozilla and store it somewhere on your disk. Then set the MOZILLA_FIVE_HOME environment variable to that directory before starting Aptana (best done with a start-script)



#!/bin/sh
MOZILLA_FIVE_HOME=/path/to/oldfirefox/root/directory
export MOZILLA_FIVE_HOME
./AptanaStudio