PDA

View Full Version : LeadTek WinTV 2000XP + ATI X1600 + TVtime



CraigWatson
27th January 2008, 04:22 PM
This is the very last piece of hardware that's playing up on my PC - after I've had to make do without Compiz-Fusion because the ATI drivers aren't up to it - and it seems like ATI are to blame yet again for this problem :mad:.

I have a LeadTek WinTV 2000XP Expert PCI TV tuner and TVtime installed, but when I run TVTtime from the command line, I get this:


[craig@galileo ~]$ tvtime
Running tvtime 1.0.1.
Reading configuration from /etc/tvtime/tvtime.xml
Reading configuration from /home/craig/.tvtime/tvtime.xml
xvoutput: No XVIDEO port found which supports YUY2 images.

*** tvtime requires hardware YUY2 overlay support from your video card
*** driver. If you are using an older NVIDIA card (TNT2), then
*** this capability is only available with their binary drivers.
*** For some ATI cards, this feature may be found in the experimental
*** GATOS drivers: http://gatos.souceforge.net/
*** If unsure, please check with your distribution to see if your
*** X driver supports hardware overlay surfaces.

After a lot of Google searches, it looks like the ATI drivers don't support YUY2, so am I comepletely screwed for TV or is there a fix?

My Xorg.conf file:


[craig@galileo ~]$ cat /etc/X11/xorg.conf

# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "aticonfig-Screen[0]" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[1]"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]"
Driver "fglrx"
Option "DesktopSetup" "horizontal"
Option "OverlayOnCRTC2" "1"
BusID "PCI:1:0:0"
Option "XAANoOffscreenPixmaps" "true"
Option "VideoOverlay" "on"
EndSection

Section "Device"
Identifier "aticonfig-Device[1]"
Driver "fglrx"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device "aticonfig-Device[0]"
Monitor "aticonfig-Monitor[0]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[1]"
Device "aticonfig-Device[1]"
Monitor "aticonfig-Monitor[1]"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "Extensions"
Option "XVideo" "Enable"
Option "Composite" "Enable"
EndSection

Hopefully there's a fix for this, otherwise I'll have to keep rebooting into Windows to watch TV. My next GPU will definitely be nVidia after this :mad:.

Cheers,
Craig

Evil_Bert
27th January 2008, 04:31 PM
I know it's no consolation, but I went with nVidia and FusionHDTV because of Linux support. ;)