PDA

View Full Version : incorrect LCD refresh rate causing isses



silentdragon48
27th January 2008, 02:00 AM
Short synopsis of my problem:
I have a Kogi L7EH LCD monitor. I prefer to run it at 1024x768 @ 60 Hz refresh.

However, every time I put my Toshiba in the dock & connect up the monitor, then booting up F8 I have a resolution problem with gdm and X11.

The problem is that the refresh rate is being incorrectly detected by udev (maybe? I'm not sure what process during the startup services sets the resolution but as soon as the frame buffer tries to hide all the startup diagnostics my screen goes off saying "Recommand Mode" (yes it is indeed spelled wrong)) and Xserver gets setup as 1280x1024 @ 56Hz, my monitor shuts off.

What I'm looking for is ( I plumb forgot how I fixed this problem on my previous computer running FC4 and the hard disk with my fix notes smoked itself) how do I manually tell the frame buffer, Xserver, and gdm for that matter to ALWAYS be at 1024x768 @ 60Hz regardless of if my Toshiba is on the external or internal monitor?

Its been a while since I messed with modelines, but I remember that being part of the solution.

BlueC
27th January 2008, 10:57 AM
to refresh your memory: modelines go in /etc/X11/xorg.conf

it is the X server that detects your monitor modes, so have a look in /var/log/Xorg.0.log to see what modes it detected last time it started and see if there are any that are suitable (i.e. 60hz) - if there are then add them as modelines in xorg.conf and set as a PreferredMode. Setting HorizSync and VertRefresh to the correct values would also be a benefit and may prevent the need for the new modeline. See also "man xorg.conf"

silentdragon48
27th January 2008, 10:00 PM
Found the issue:
There are a combination of problems that were/are occuring:
(1) Kogi monitors suck
(2) resolution was being scanned at 56Hz. Looked at this in Xorg.0.log .. kept looking for Xorg.log and not finding it before, thanks for the correction. For some reason the monitor reports that 56Hz is the supported scan rate, contrary to the manual & my experience with it. Fixed the resolution problem by setting the monitor up in the xorg.conf file.
(3) The DPI is screwy. The only real issue was that fonts were INSANELY small. The monitor is 90 DPI .. yet the fonts were being set to 56 DPI.

Now I just need to figure out where the font DPI is set (never looked). Any hints?

JEO
28th January 2008, 07:20 AM
Had the same font issue appear on a plug and play monitor. In Gnome, go to system, preferences, look and feel, appearance, fonts tab, details button on lower right. Then you can type over the auto detected dpi (I used 96 dpi and that seemed to fix the small font size problems).