PDA

View Full Version : Xorg "no screens" on Trident



Kimball
26th January 2008, 07:28 AM
Just installed FC8 on my box running a Trident CyberBlade/i1, A ComeMon 1024x768 LCD display, and an AMD 1.2 Thunderbird processor.

When I try to startx it fails and prints out:

(WW) TRIDENT: No matching Device section for instance (BusID PCI:1:0:0) found
(EE) No devices detected.

Fatal server error:
no screens found


I have tried the vesa video driver instead of trident, gets a really messed up display with it all fuzzy and split down the center of the screen.

I also tried system-config-display it booted eventually after trying the --reconfig flag but then my monitor said it had no signal.

My xorg.conf:

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "trident"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


Any help appreciated.

ppesci
26th January 2008, 08:05 AM
in a console, type the command:

/sbin/lspci

to see what video card you have (one of the lines will tell you).

Then use that information to search in this forum or in internet to see what is the proper driver and change it in xorg.conf.

HTH

jdeslip
27th January 2008, 08:19 AM
I think Trident CyberBlade/i1 is his video card. I have no idea how to solve this problem, though. It seems like trident should be the right driver. I also assume people post here hoping someone knows the answer and not for someone to tell them how to use google ;)

As a complete shot in the dark perhaps the depth of 24 is not compatible with your card. Seeing as this is old hardware, I would think it would be configured correctly automatically though....

notageek
27th January 2008, 08:32 AM
I see that modes are missing from your xorg.conf, this could be a reason why your monitor gives you " No Signal"

try adding modes e.g 1078x768 etc



Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection



Example



Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Kimball
28th January 2008, 06:44 AM
I believe I tried it with the modes at 1024x768 but I will give that a try again.

As for the Depth an xorg error wiki suggested setting it at 8, I did this and it locked up my computer (couldn't even kill X).

I've pretty much resigned to running through command line now (didn't need X just wanted to setup VNC), but I'll give this stuff a try later on. Thanks for the suggestions.