PDA

View Full Version : dual boot problem



DamagePlan
25th January 2008, 10:16 PM
I have just installed fedora and when I boot up it boots up into fedora not to the dual boot screen. How could I change this. I still have my vista hardrive.


Thanks
DamagePlan

amanadas
25th January 2008, 10:48 PM
Hi,

Post the results from these commands:

- fdisk -l /dev/sda
- cat /etc/grub.conf

This post may help

http://forums.fedoraforum.org/forum/showthread.php?t=178579

LordMorgul
25th January 2008, 10:48 PM
To explain further, do you not see a grub list of available kernels at all? Not even for a few seconds?

To fix this, we'll need some info. Please post the output (while running fedora with all your harddrives connected) of these commands:

cat /boot/grub/grub.conf
cat /etc/fstab
fdisk -l /dev/sda
fdisk -l /dev/sdb
fdisk -l /dev/sdc

(if you have more than 3 drives... follow the pattern) Do you have vista installed on the first or second drive?

edit: jinx!

DamagePlan
25th January 2008, 10:54 PM
[Dyson@localhost ~]$ cat /boot/grub/grub.conf
cat: /boot/grub/grub.conf: Permission denied
[Dyson@localhost ~]$ cat /etc/fstab
LABEL=/1 / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/sda5 swap swap defaults 0 0
/dev/sda7 swap swap defaults 0 0
[Dyson@localhost ~]$ fdisk -l /dev/sda
bash: fdisk: command not found
[Dyson@localhost ~]$ fdisk -l /dev/sdb
bash: fdisk: command not found
[Dyson@localhost ~]$ fdisk -l /dev/sdc
[Dyson@localhost ~]$

glennzo
25th January 2008, 11:05 PM
Log in as root and run the commands.

DamagePlan
25th January 2008, 11:19 PM
SOrry my fault, im not that good with linux..



# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/sda3
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.23.14-107.fc8)
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.14-107.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.14-107.fc8.img
title Fedora (2.6.23.1-42.fc8)
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.1-42.fc8.img
title Other
rootnoverify (hd0,0)
chainloader +1
[root@localhost ~]# cat /etc/fstab
LABEL=/1 / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/sda5 swap swap defaults 0 0
/dev/sda7 swap swap defaults 0 0
[root@localhost ~]# fdisk -l /dev/sda

Disk /dev/sda: 400.0 GB, 400088457216 bytes
255 heads, 63 sectors/track, 48641 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x08d8b994

Device Boot Start End Blocks Id System
/dev/sda1 * 1 15465 124216362 7 HPFS/NTFS
/dev/sda2 47979 48642 5321728 7 HPFS/NTFS
/dev/sda3 26708 32573 47118645 83 Linux
/dev/sda4 32574 47978 123740662+ 5 Extended
/dev/sda5 47223 47978 6072538+ 82 Linux swap / Solaris
/dev/sda6 * 32574 46621 112840497 83 Linux
/dev/sda7 46622 47222 4827501 82 Linux swap / Solaris

Partition table entries are not in disk order
[root@localhost ~]# fdisk -l /dev/sdb

Disk /dev/sdb: 300.0 GB, 300069052416 bytes
255 heads, 63 sectors/track, 36481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xc8f109fa

Device Boot Start End Blocks Id System
/dev/sdb1 * 2 36481 293025600 f W95 Ext'd (LBA)
/dev/sdb5 2 36481 293025568+ 7 HPFS/NTFS

glennzo
25th January 2008, 11:27 PM
Not a big deal. This is how we learn. Now you know.

LordMorgul
26th January 2008, 12:52 AM
Thanks for the output. So when you start the computer, can you confirm that you do NOT see a grub boot loader screen for 5 seconds (blue background, saying it will 'booting Fedora (2.6.23.14-107.fc8) in 5s'? That would suggest you chose not to install the bootloader when you installed, and would need to now install grub to your master boot record.

Your grub.conf looks like it contains an error for your setup of windows,
but it should work and let you see the two linux kernel options if its installed to the MBR.

Given your fdisk output, I assume now that Vista is installed on the partition /dev/sdb5 on disk 2 (300Gb size). Correct me if that is wrong (you have more than 1 NTFS partition).

Since vista is on your second drive, the grub.conf line:

title Other
rootnoverify (hd0,0)
chainloader +1
Should be:


title Vista
rootnoverify (hd1,0)
chainloader +1

Note the change in title is only for asthetics (it does not effect anything, just nicer in the list than Other).

Open /boot/grub/grub.conf with a text editor (as root) and make that change, then try booting your machine. If you still do not see grub appear, you need to go through a grub install process. Let us know.

The alternative if you do not see grub would be immediately seeing black screen with the text 'RedHat nash starting' very soon after. (much faster than 5s delay)

If you are seeing grub, but it does not give you any choices, make sure you press a key while it counts down, and see if it now shows a list where you see two Fedora entries, and one 'Other' entry.

DamagePlan
26th January 2008, 11:37 AM
Sorry, I do get that boot loader. I just want to have list the os's
Ill try and follow your post now.


Thanks

LordMorgul
26th January 2008, 11:41 AM
Damage,
If you want to make the list of OSs always show, then change the lines:


default=0
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu


To read:


default=0
timeout=0
splashimage=(hd0,2)/boot/grub/splash.xpm.gz


And it will never choose an OS by timeout (you must pick before it will boot), and you will always see the list right away.

DamagePlan
26th January 2008, 12:10 PM
Thanks for you help, but

It now gets rid of the splash screen and goes straight into fedora

grub.conf:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/sda3
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
title Fedora (2.6.23.14-107.fc8)
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.14-107.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.14-107.fc8.img
title Fedora (2.6.23.1-42.fc8)
root (hd0,2)
kernel /boot/vmlinuz-2.6.23.1-42.fc8 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.23.1-42.fc8.img
title Other
rootnoverify (hd0,0)
chainloader +1


Sorry about this.

Thanks,

glennzo
26th January 2008, 12:21 PM
Change timeout=0 to something like 30 (the number reflects seconds) so 30 is 30 seconds. It's set to 0 seconds as it is.

DamagePlan
26th January 2008, 12:34 PM
It works.
I get 3 os's to choose from

fedora and another fedora(dont why that it is)
and vista

Problem is when I select Vista It says that its not a driver and to press enter to go back to the menu.

Do you have an idea why this is happening

THanks,

DamagePlan
26th January 2008, 12:44 PM
Im not an expert in this field but Vista might not be hd1. Im probally wrong

glennzo
26th January 2008, 12:46 PM
Try (hd0,1) for Vista

DamagePlan
26th January 2008, 01:07 PM
Yeah, thats the right hardrive. ONly problem is when I boot with VIsta it goes to the system recovery.

Thanks for help anyway.

LordMorgul
26th January 2008, 01:22 PM
DamagePlan, did you have vista installed on the same harddrive as Fedora? (both only the 400Gb drive)

Is your 300Gb drive then used for just storage?

You do have a bootable NTFS partition on both drives, which could be some confusion.

You should try as the vista partition in grub:
(hd0,1)
(hd1,0)
(hd0,0)

It could be any one of those. Is that system recovery mode a windows command prompt (recovery console)?

LordMorgul
26th January 2008, 01:26 PM
And btw, you could set default=2 right now if you wanted your machine to boot vista by default (as soon as it works that is) :-)

Glennzo, do you recall how to remove the timeout completely? I thought 0 did that, perhaps removing the timeout= assignment from the conf works?

DamagePlan
26th January 2008, 01:39 PM
DamagePlan, did you have vista installed on the same harddrive as Fedora? (both only the 400Gb drive)

Is your 300Gb drive then used for just storage?

You do have a bootable NTFS partition on both drives, which could be some confusion.

You should try as the vista partition in grub:
(hd0,1)
(hd1,0)
(hd0,0)

It could be any one of those. Is that system recovery mode a windows command prompt (recovery console)?

Yeah fedora and vista are on the same hardrive. THe system recovery is weird. I have the option of doing a full recovery restore applications command prompt and some others.

ILl try what you just said.

DamagePlan
26th January 2008, 01:39 PM
Yeah fedora and vista are on the same hardrive. THe system recovery is weird. I have the option of doing a full recovery restore applications command prompt and some others.

ILl try what you just said.


edit : my 300 is used for storage like you said.

DamagePlan
26th January 2008, 01:47 PM
Yay!! Thankyou it works, and everyone else who helped. It needed to be changed to (0,0)
Please could you just tell me why in the grub boot loader I have two fedora os's to choose from.


now to go and sort my resolution out :)

Thankyou very much

LordMorgul
26th January 2008, 01:54 PM
You currently have two kernels installed, that gives you two bootloader options. Its always best to keep two or more kernels installed and available... if one breaks for some reason, you might be able to boot your system with the other.

When you get a new kernel it should almost always be 'installed' by Fedora, not upgraded (which would remove the current one and put in the new). By default Fedora should keep at least 2 kernels, so you always have one that you were using and worked (this is configurable).

glennzo
26th January 2008, 01:57 PM
Please could you just tell me why in the grub boot loader I have two fedora os's to choose from.Thankyou very muchBecause when you update your system and there is a kernel update also both kernels are kept and a second entry is added to the boot menu. Now that there's 2 kernels, if there's another kernel update the oldest will be removed and the newest added. You will still have 2. Kind of a safety feature. If there's trouble with the new kernel you can choose the older one that was working and still be able to use your system.

glennzo
26th January 2008, 02:01 PM
Glennzo, do you recall how to remove the timeout completely? I thought 0 did that, perhaps removing the timeout= assignment from the conf works?Looking at the GRUB pages I don't think you can. It looks as if it's 0 for immediate boot or a higher number for a short delay before booting. I'd bet if you remove the timeout line GRUB would act as if it's set to 0.