PDA

View Full Version : Problem with partition



lesliek
25th January 2008, 05:17 AM
I have on my computer Windows XP, Fedora 3 and Fedora 7.

I use a Windows program, Bootpart, to choose among the 3, with Fedora 7 being the default.

I just booted up and expected Fedora 7 to run by default. Instead, I got a grub prompt. I rebooted and chose Fedora 3. Again, I got a grub prompt.

I found some information about the grub prompt commands and it seemed I should use the command: kernel /vmlinuz root=/dev/xxxx.

I've got 2 internal hard drives, each with 2 partitions on it. I was pretty sure I should be putting into the grub command either hdb1 or hdb2, but I tried both and got grub error 17, cannot mount selected partition.

I then booted up with a live cd of DSL. I tried, as root, to mount all 4 hard drive partitions. Three of them mounted, but not hdb2. For it, I got the following: "mount: relocation error mount: undefined symbol: blkid_known_fstype".

I don't know what to try next.

I'd be very grateful for any suggestions.

Thanks,

Leslie

glennzo
25th January 2008, 11:57 AM
Boot with DSL again and get the output of the commands /sbin/fdisk -l and see if you can get a listing of your boot menu.

lesliek
25th January 2008, 05:10 PM
Thanks for your reply glennzo.

I rebooted with DSL. I ran fdisk. The partition I can't mount in DSL shows up as hdb2, not flagged bootable and with filesystem Win 95 FAT32 (LBA).

I'm sorry, but I don't know what you mean when you suggest I try to get a listing of my boot menu. Could you please explain that?

Thanks again,

Leslie

glennzo
25th January 2008, 06:34 PM
Try listing out the file /boot/grub/menu.lst on the partition that is used to boot Linux. Also, /sbin/fdisk -l, can you tell me all the partitions on both disks, i.e., dev/sda1, dev/sda2, dev/sdb1, dev/sdb2 and what types they are, ext3, ntfs, vfat fat32 etc.

lesliek
25th January 2008, 07:05 PM
Glenn,

1. Here's the entire menu.lst file that I found in hdb1:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdb2
# initrd /initrd-version.img
#boot=/dev/hdb1
default=0
timeout=0
splashimage=(hd1,0)/grub/splash.xpm.gz
#hiddenmenu
#title Bootchart logging
# root (hd1,0)
# kernel /vmlinuz-2.6.11-1.1378_FC3 ro root=LABEL=/ rhgb quiet #acpi=off init=/sbin/bootchartd
# initrd /initrd-2.6.11-1.1378_FC3.img
title Fedora Core (2.6.12-1.1378_FC3)
root (hd1,0)
kernel /vmlinuz-2.6.12-1.1378_FC3 ro root=LABEL=/ acpi=off init=/sbin/bootchartd
initrd /initrd-2.6.12-1.1378_FC3.img

2. fdisk -l shows two internal hard drives each with 2 partitions on it.
hda1 and hdb1 are both marked bootable, with filesystem HPFS/NTFS.
hda2 and hdb2 both show the filesystem as Win95 FAT32 (LBA).

Thanks again,

Leslie

glennzo
25th January 2008, 07:22 PM
I'm really confused here. You got the menu.lst file from /dev/hdb1 yet /dev/hdb1 is shown as an NTFS file system? I don't see any Linux partitions on the 2 drives which would explain why Fedora won't boot. menu.lst is pointing to /dev/hdb1 as the boot partition for Linux yet it's an NTFS partition? If you have no EXT3 partitions how in the world can you even find menu.lst ?? Are the 4 partitions all you ever had or do you think 1 or 2 partitions disappeared? What do they say in Australia? Crikey? The crikey it is! Something is very strange with your system. Any recent installs or major changes?

lesliek
25th January 2008, 08:14 PM
Crikey's too mild!

It's true that using fdisk in DSL gave me the information that hdb1 had an NTFS filesystem, though using the DSL filemanager I was able to mount hdb1 and find and read menu.lst (at least the menu.lst for Fedora 3; the one for Fedora 7 must be on hdb2).

I'm sure I didn't have hdb1 as NTFS.

So it seems that both partitions on hdb have gone mad and I can't mount hdb2.

That makes me wonder--does there exist any tool I can use to change filesystem types without destroying the data on the partitions?

Alternatively, is there some way for me to recover the files on hdb2 even though I can't mount it?

I'll try to look for answers to these questions myself, but if you know the answers already, I'd be very grateful if you'd mention them to me.

Thanks again,

Leslie

EDIT: Sorry, I didn't answer your question about any major changes lately. The answer's no.

L.

lesliek
27th January 2008, 03:03 AM
I want to record, in case it helps someone else, that I was able to solve my problem by using TestDisk. I used a version that came on a SystemRescueCD. TestDisk found my "real" partitions (of which there were 6!) and put everything back to normal.