PDA

View Full Version : Firefox 3



spdaniel91
22nd January 2008, 03:11 PM
Um, you know guys, i'm very new to fedora and linux :P

I want to install FF3 beta 2. I downloaded the tarball file, and extracted it to ~/firefox, so it ended in ~/firefox/firefox.

Now, when I run in the terminal "/firefox/firefox/firefox" (the last firefox is the executable file), it just opens Firefox 2.

If I have to uninstall firefox 2, no problem, I installed FF3 on XP and it's damn awesome.

mbratch
22nd January 2008, 03:16 PM
Check the executable. Is it a text script that points to a binary?

Wayne
22nd January 2008, 03:36 PM
Uninstalling Firefox2 might take some dependencies with so I'd leave it be for now.

New to Linux and already messing about with beta tarballs, eh? :)

I personally would have put firefox3 under /opt

/opt/firefox

The reason Firefox2 runs is because there's a link to it in the directory /usr/bin

Either remove that link (as root) or make a link from your firefox3 install to /usr/bin

It might be a good idea to call it something different so not to mess things up, something like:

ln -s /opt/firefox/firefox /usr/bin/firefox3

then you can run in a Terminal:

firefox3

Or make a launcher for it.

http://www.fedoraforum.org/forum/showthread.php?t=175912&highlight=firefox3

Wayne

spdaniel91
22nd January 2008, 03:55 PM
Ok. I installed it in
/opt/firefox

Now. In the terminal I put:
[spdaniel91@localhost ~]$ ln -s /opt/firefox/firefox /usr/bin/firefox3
ln: creating symbolic link `/usr/bin/firefox3': File exists

And when I run firefox3, it still opens FF2. I'll try to remove the link.

spdaniel91
22nd January 2008, 04:01 PM
Ok.

I removed the link, and it works. Thanks guys!

And about the tarball things, I luv danger :P