PDA

View Full Version : Compiz-fusion is trouble



chousho
22nd January 2008, 11:22 AM
Not in that it steals my cookies, but compiz-fusion has been giving me issues since I installed it.

My initial notice was that the fonts seem to have gotten smaller since installing.

Secondly, every now and then the mouse will have about a 50x50 pixel area below it that has horizontal white bars. In addition, I'll sometimes get a small (100 x 50 or so) area on the bottom right of my screen with horizontal bars that are either white or black depending on the window open.


Does anybody have any clue on how to fix these issues?

Demz
22nd January 2008, 11:50 AM
what kind of issues has compiz-fusion been giving you? an what compiz-fusion are you using? the fedora one or liegh's one?

Dies
22nd January 2008, 07:58 PM
Does anybody have any clue on how to fix these issues?

It would help if you at a minimum mentioned what graphics card and driver ( including version ) you're using.
And it would be even better if you gave us stuff like amount of RAM, processor speed to go along with those.

chousho
22nd January 2008, 09:31 PM
Sorry about that.

I'm running:

IBM Thinkpad T43
CPU: Intel Pentium M 1.73GHz
RAM: 512MB DDR II SDRAM PC 4200 533MHz
GPU: ATI Technologies Inc M22 (Mobility Radeon X300)


I'm running the Fedora compiz-fusion (done through yum). Version is 0.6.2

The issue I'm getting is that I'll get horizontal bars displayed across a small square area on my display (in the lower right corner). As this is being directly displayed, a screenshot doesn't show this. If I were to describe the bars, they go in groups of two and display a general negative color of what they lay on.

leigh123linux
22nd January 2008, 09:52 PM
Sorry about that.

I'm running:

IBM Thinkpad T43
CPU: Intel Pentium M 1.73GHz
RAM: 512MB DDR II SDRAM PC 4200 533MHz
GPU: ATI Technologies Inc M22 (Mobility Radeon X300)


I'm running the Fedora compiz-fusion (done through yum). Version is 0.6.2

The issue I'm getting is that I'll get horizontal bars displayed across a small square area on my display (in the lower right corner). As this is being directly displayed, a screenshot doesn't show this. If I were to describe the bars, they go in groups of two and display a general negative color of what they lay on.


This is a known bug in the ATI driver , The latest release has fixed this problem


from release notes 8.1:
....
Resolved Issues

The following section provide a brief description of resolved issues with the latest version of the ATI Catalyst™ Linux software suite. These include:

* Corruption will no longer be noticed in the lower right corner of the display or on the mouse pointer after the system is running for a long period of time
* Connecting a display device that supports 1680x1050 to a system running Linux will no longer result in a maximum display resolution of 1280x1024 only being available
* Custom mode lines in xorg.conf will no longer be ignored by the fglrx driver
* Suspending to RAM or DISK on kernel version 2.6.23 or later no longer fails

......

chousho
23rd January 2008, 03:43 AM
This is a known bug in the ATI driver , The latest release has fixed this problem

Thanks, I just updated and hopefully won't experience that anymore.

I'm still looking at why my fonts suddenly got smaller. I guess I can just alt + in firefox, and I went from 10 to 12 in the font control, but the minimize, close, etc. buttons are still a bit smaller than before. I guess i can put up with that, though.

Demz
23rd January 2008, 04:53 AM
Thanks, I just updated and hopefully won't experience that anymore.

I'm still looking at why my fonts suddenly got smaller. I guess I can just alt + in firefox, and I went from 10 to 12 in the font control, but the minimize, close, etc. buttons are still a bit smaller than before. I guess i can put up with that, though.
do you by any chance use a Emerald-Theme?

chousho
23rd January 2008, 06:56 AM
do you by any chance use a Emerald-Theme?

Not that I know of. I just installed compiz-fusion the other night and have been trying to get everything working. I haven't really gotten any of the effects to work, and avant window navigator throws a "Error: Screen isn't composited. Please run compiz (-fusion) or another compositing manager." so something is up.

Demz
23rd January 2008, 07:15 AM
from what liegh told me Avant-Window-Manager depends on Compiz being enabled ( correct me if im wrong liegh ) ,can you by any chance take a Screenshot of your whole Desktop for us so we can see the Buttons, depending on the Emerald theme you maybe using, the buttons can be smaller or larger

chousho
23rd January 2008, 08:18 AM
Here's my desktop
http://img153.imageshack.us/img153/9195/desktoptr8.th.png (http://img153.imageshack.us/img153/9195/desktoptr8.png)

Folder open (keep in mind I changed font from 10 to 12 to compensate)
http://img170.imageshack.us/img170/3351/screenshotnv6.th.png (http://img170.imageshack.us/img170/3351/screenshotnv6.png)

Text within firefox (which I set to a minimum of 12, as well)

http://img167.imageshack.us/img167/5765/textif7.th.png (http://img167.imageshack.us/img167/5765/textif7.png)

Demz
23rd January 2008, 08:23 AM
about the buttons, it looks like you are using Clearlooks2 theme?

chousho
23rd January 2008, 08:34 AM
Controls: Glossy
Window Border: MurrineRoundedIcon
Icons are based off Fedora with some custom thrown in.

Fonts are all size 12 and using Subpixel smoothing

I haven't really looked to see if the themes inherit from any others, though.

Demz
23rd January 2008, 08:55 AM
what if you change the Theme/Border back to a Fedora based Theme , does that make a difference , im thinking it maybe the theme your using that makes the buttons like that

NoSkill
23rd January 2008, 09:04 AM
Text within firefox (which I set to a minimum of 12, as well)

http://img167.imageshack.us/img167/5765/textif7.th.png (http://img167.imageshack.us/img167/5765/textif7.png)

I just matched that font size in that image against what I have (1280x1024). The only way I could get that size font was to have a low "Dots Per Inch" value (72 DPI) for the fonts.

Go to System->Preferences->Look And Feel->Font, which brings up the font preferences for you system.. Click on "Details..." (near bottom-right corner) and make sure the "Dots Per Inch" value is set to around 96 DPI and see if that makes a difference.

chousho
23rd January 2008, 09:49 AM
There we go! Thank you all so much!

Demz, leigh and NoSkill's advice helped get the appearance looking good again (without any more of those corruption lines, too).

Hopefully soon I'll be able to get the desktop effects to work as well. AWN still throws that "Error: Screen isn't composited. Please run compiz (-fusion) or another compositing manager." message. I'm pretty sure Compiz is enabled, anyway.

NoSkill
23rd January 2008, 10:39 AM
I'm pretty sure Compiz is enabled, anyway.
To be sure that compiz has actually started, do this at a console:

ps -A | grep compiz
The result should be something like this:

3773 ? 00:00:04 compiz
If the command just returns to the console without any output, then compiz hasn't started (for some reason). In this case it may be an idea to post your /etc/X11/xorg.conf file here so that we can be sure that it is set correctly.

By the way, how are you starting compiz?

chousho
23rd January 2008, 11:14 AM
Hmm, couldn't grep compiz so I guess it didn't start up. I thought it would start up with my session, but I guess not.

I tried to run compiz from terminal, but it only spat out "compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0"
which I may try.

My xorg.conf was setup by the ati driver, it's been PBed

http://pastebin.ca/869578

I guess I would setup compiz under the startups for session, then? I'm not sure if xorg.conf is correct for it, though.

leigh123linux
23rd January 2008, 11:30 AM
Add this section to xorg.conf



Section "DRI"
Mode 0666
EndSection

Then restartX

NoSkill
23rd January 2008, 11:38 AM
Hmm, couldn't grep compiz so I guess it didn't start up. I thought it would start up with my session, but I guess not.

I tried to run compiz from terminal, but it only spat out "compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.
compiz (core) - Fatal: No manageable screens found on display :0.0"
which I may try.

My xorg.conf was setup by the ati driver, it's been PBed

http://pastebin.ca/869578

I guess I would setup compiz under the startups for session, then? I'm not sure if xorg.conf is correct for it, though.
Your xorg.conf looks alright to me (but I'm an nVidia nut though ;) )...

Does compiz start if you run the following command from a console?

compiz --replace ccp &

leigh123linux
23rd January 2008, 11:49 AM
Your xorg.conf looks alright to me (but I'm an nVidia nut though ;) )...

Does compiz start if you run the following command from a console?

compiz --replace ccp &

Also try



compiz --replace ccp --indirect-rendering

chousho
23rd January 2008, 11:51 AM
Add this section to xorg.conf



Section "DRI"
Mode 0666
EndSection

Then restartX
OK, I added it, then (continued below)



Your xorg.conf looks alright to me (but I'm an nVidia nut though ;) )...

Does compiz start if you run the following command from a console?

compiz --replace ccp &
When i came back, I opened up terminal to get compiz working, but instead it turned my monitor a nice shade of white. My mouse would change when i moved it over (where i previously could see) text, but beyond the mouse everything else was white. Unless compiz is one of those "stare at it for 5 minutes and you'll see the picture" kind of things like when i was a kid, haha.

-- edit --
The same thing happens with compiz --replace ccp --indirect-rendering

After doing a bit of Googling, I found some people had similar problems and were told to turn off sideport+uma in bios. However, I get conflicting reports that it the issue was fixed in more recent ati drivers (of which i have the most up to date). AGH *pulls out hair*

NoSkill
23rd January 2008, 12:15 PM
OK, I added it, then (continued below)



When i came back, I opened up terminal to get compiz working, but instead it turned my monitor a nice shade of white. My mouse would change when i moved it over (where i previously could see) text, but beyond the mouse everything else was white. Unless compiz is one of those "stare at it for 5 minutes and you'll see the picture" kind of things like when i was a kid, haha.

-- edit --
The same thing happens with compiz --replace ccp --indirect-rendering
Can you restart your PC and then post the /var/log/Xorg.0.log file so that we can see if there is any problems with the driver loading, please?

chousho
23rd January 2008, 12:25 PM
Can you restart your PC and then post the /var/log/Xorg.0.log file so that we can see if there is any problems with the driver loading, please?

Fully rebooted just like you said
http://pastebin.ca/869612

Which part am I looking for?

NoSkill
23rd January 2008, 12:37 PM
Fully rebooted just like you said
http://pastebin.ca/869612
Thanks for that ;)

Looks like you have some issues with the ATI driver:

#549 (EE) fglrx(0): [pcie] Failed to gather memory of size 262144Kb for PCIe. Error (-1000)
#594 (EE) fglrx(0): atiddxDriScreenInit failed, GPS not been initialized.
#595 (WW) fglrx(0): ***********************************************
#596 (WW) fglrx(0): * DRI initialization failed! *
#597 (WW) fglrx(0): * (maybe driver kernel module missing or bad) *
#598 (WW) fglrx(0): * 2D acceleraton available (MMIO) *
#599 (WW) fglrx(0): * no 3D acceleration available *
#600 (WW) fglrx(0): ********************************************* *

I can't help you at this point because I am not familiar with getting ATI cards going with compiz (or Linux)... Sorry :(

Demz
23rd January 2008, 12:41 PM
im sure firewing has a Sticky on how to get ATI cards goung.. i'll try an find it before i logout for the night

chousho
23rd January 2008, 12:44 PM
I can't help you at this point because I am not familiar with getting ATI cards going with compiz (or Linux)... Sorry :(
Oh, don't worry about that, it's my problem anyway. Thank you so much for all of the help you've been able to give me!


im sure firewing has a Sticky on how to get ATI cards goung.. i'll try an find it before i logout for the night
:D
If I'm ever in the land of Aussies, I should be buying you guys a few rounds

Demz
23rd January 2008, 12:45 PM
this may help http://www.fedoraforum.org/forum/showthread.php?t=155503

leigh123linux
23rd January 2008, 01:49 PM
Fully rebooted just like you said
http://pastebin.ca/869612

Which part am I looking for?

Post


rpm -qa | grep fglrx

and


rpm -qa | grep kernel

and


rpm -qa | grep compiz

chousho
23rd January 2008, 11:12 PM
rpm -qa | grep fglrx
xorg-x11-drv-fglrx-8.443.1-1.7.12.lvn8
kmod-fglrx-2.6.23.9-85.fc8-8.443.1-1.7.12.lvn8
kmod-fglrx-8.443.1-1.7.12.lvn8


rpm -qa | grep kernel
kernel-2.6.23.1-42.fc8
kernel-headers-2.6.23.9-85.fc8
kernel-xen-2.6.21-2952.fc8
kernel-2.6.23.9-85.fc8


rpm -qa | grep compiz
compiz-fusion-extras-gnome-0.6.0-1.fc8
libcompizconfig-0.6.0-3.fc8
compizconfig-python-0.6.0.1-2.fc8
compiz-0.6.2-3.fc8
compiz-fusion-extras-0.6.0-1.fc8
compiz-fusion-0.6.0-12.fc8

leigh123linux
24th January 2008, 12:13 AM
rpm -qa | grep fglrx
xorg-x11-drv-fglrx-8.443.1-1.7.12.lvn8
kmod-fglrx-2.6.23.9-85.fc8-8.443.1-1.7.12.lvn8
kmod-fglrx-8.443.1-1.7.12.lvn8


rpm -qa | grep kernel
kernel-2.6.23.1-42.fc8
kernel-headers-2.6.23.9-85.fc8
kernel-xen-2.6.21-2952.fc8
kernel-2.6.23.9-85.fc8


rpm -qa | grep compiz
compiz-fusion-extras-gnome-0.6.0-1.fc8
libcompizconfig-0.6.0-3.fc8
compizconfig-python-0.6.0.1-2.fc8
compiz-0.6.2-3.fc8
compiz-fusion-extras-0.6.0-1.fc8
compiz-fusion-0.6.0-12.fc8


Can you post



uname -a

chousho
24th January 2008, 04:21 AM
uname -a
Linux localhost.localdomain 2.6.23.9-85.fc8 #1 SMP Fri Dec 7 15:49:59 EST 2007 i686 i686 i386 GNU/Linux

leigh123linux
4th February 2008, 10:13 AM
Try



su
wget http://www.linux-ati-drivers.homecall.co.uk/compiz-fusion/compiz-fusion.repo -O /etc/yum.repos.d/compiz-fusion.repo
yum install ccsm emerald-themes compizconfig-backend-kconfig compizconfig-backend-gconf fusion-icon* emerald compiz-fusion compiz-fusion-gnome libcompizconfig compiz-gnome compiz-bcop compiz compizconfig-python compiz-fusion-extras compiz-fusion-extras-gnome compiz-kde
wget http://koji.fedoraproject.org/packages/xorg-x11-server/1.3.0.0/9.fc7/i386/xorg-x11-server-Xorg-1.3.0.0-9.fc7.i386.rpm
rpm -Uvh --nodeps --oldpackage xorg-x11-server-Xorg-1.3.0.0-9.fc7.i386.rpm


you will need to ban xorg-x11-server-Xorg from updating



su
gedit /etc/yum.conf

and add this line

exclude=xorg-x11-server-Xorg


And to start it use fusion-icon

marcelkraan
4th February 2008, 12:05 PM
you got a very nice backgound image!

chousho
5th February 2008, 06:24 AM
you got a very nice backgound image!
Thanks! For some reason I can't view this page in Firefox on my laptop, but it works on my desktop. If you can view it, here's the DeviantArt it came from:
http://ker-.deviantart.com/art/SNES-World-24862520

Here's another site where you can choose the resolution below the preview image:
http://customize.org/wallpapers/42771

Here's the Mario image I'm using:
http://upload.wikimedia.org/wikipedia/en/thumb/d/de/Papermario.png/200px-Papermario.png

Demz
5th February 2008, 07:16 AM
http://ker-.deviantart.com/art/SNES-World-24862520 i cant get to that either on my desktop PC so its not just you