PDA

View Full Version : fedora on virtual PC



chekuri
22nd January 2008, 10:12 AM
Hi All

I am new to Linux and hence new to fedora. I have installed fedora in virtual PC in my laptop (HP Compaq NX 7400), after the installation the re-boot also went fine, but the GUI seems to be a bit messed up and can able to see any thing on the screen. all the images or texts are bro denned (larger may be due to the resolution).

could anyone help me on how to resolve this problem, since i am planning on removing windows and installing fedora in my laptop.

Thanks
Rahul Chekuri

Mathmo
22nd January 2008, 11:18 AM
I would expect it to be because of the virtual machine... are you using vmware or microsoft? and have you installed the virtual machine addons inside the guest fedora? if you are running microsoft virtual pc, then on one of the drop down menus there is an option to install the tools, although it probably wont work with fedora.
also, are you running it in fullscreen? because it may be thet your graphics card in your windows install is set to always fill the screen, regardless of resolution, and most virtualistaions without the addpns run in 800*600 or 640*480, so they would be horribly stretched by being made fullscreen.
try running the virtual machine in a window instead. and if it looks fine then the problem is just with the virtualisation.

saviles
23rd January 2008, 06:31 PM
Actually, I believe the reason that happens to the screen is because Virtual PC doesn't understand 24 bit color.
All you have to do is modify your /etc/X11/xorg.conf file and change the default from 24 to 16.
...
DefaultDepth 24
...

In order to get to this file and be able to modify it, you'll likely have to boot in single user mode.

DakotaC
5th February 2008, 06:16 PM
Can anyone help me on how to modify the file above "/etc/X11/xorg.conf" Where do i enter it and when?

saviles
5th February 2008, 11:00 PM
Go into single user mode.
When the system begins to boot and you see, the menu press "e" on the "Fedora 8... " option. Then use the arrow and highlight the line with "kernel /vmlinuz....." and press "e". In this screen type the number 1 at then of the line. Now press Enter and then press the letter "b". You will see the system begin to bootup. You will finally see the "sh-3.1#" prompt.

Modify the file
Here you use can use vim to modify the file #vim /etc/X11/xorg.conf.
Press "i" to begin editing the file. When you are doing press ESC and type ":wq" (without the quotes). You should end up at the prompt and here you type "reboot". That should be it.

DakotaC
6th February 2008, 01:45 AM
When i press i nothing happens why is this?