PDA

View Full Version : Fedora 8 on IBM T42 suspend/resume can not work!!



xhbdahai
22nd January 2008, 08:19 AM
Hello all:
I installed F8 on my notebook (IBM T42), it work properly.

It can suspend once close lid or (Fn + F4), but it can not resume from suspend properly when I open lid. HDD and Network can resume, but LCD can not. LCD will keep black same as there is no power for it.

My kernel is the last version released by Fedora project, all the driver and software have upgraded the last version.

My video card information:
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 [Mobility Radeon 9600 M10]

Can some body help me?

Thanks.

xhbdahai
26th January 2008, 03:57 PM
Is there nobody encounter this issue?

leigh123linux
26th January 2008, 04:11 PM
Try the latest driver


Resolved Issues

The following section provide a brief description of resolved issues with the latest version of the ATI Catalyst™ Linux software suite. These include:

* Corruption will no longer be noticed in the lower right corner of the display or on the mouse pointer after the system is running for a long period of time
* Connecting a display device that supports 1680x1050 to a system running Linux will no longer result in a maximum display resolution of 1280x1024 only being available
* Custom mode lines in xorg.conf will no longer be ignored by the fglrx driver
* Suspending to RAM or DISK on kernel version 2.6.23 or later no longer fails

For livna based rpm's

http://forums.fedoraforum.org/showpost.php?p=949356&postcount=1568

dmangal
26th November 2008, 01:13 AM
xhbdahai...did leigh's suggestion help your cause? I'm having the exact same problem and am still stumped. I am in fact using the latest driver from the ATI website though. My suspend works just fine once I close the lid (checked /var/log/messages) but the minute I open the lid back up, the display doesn't come up. Just to add all the lights on my laptop come on...only the display doesn't come up.

Below is the contents of my /etc/X11/xorg.conf:


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "vesa"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection