PDA

View Full Version : how to find programs that are installed on fedora?



ashjas
20th January 2008, 08:31 AM
Hi,

Fedora start menu doesnot list all the programs installed...

for example i have gnupg2 installed as shown here:

http://img402.imageshack.us/my.php?image=screenshotpackagemanagead2.png

but no link in the start menu to start using the program and make new keys??

why fedora has to be stupidly built that for every step a newbie has to post such stupid questions like that i am posting here?

why cant i search for a program and select it to start that program...what help the package manager is giving by just showing that the package is installed...with no info how to start...

kindly tell me how to start gnupg2.

Thanks for ur time.

lazlow
20th January 2008, 09:54 AM
Most programs can be started in Linux by opening a terminal, type the program name, and hit enter. Assuming that works you can just build a launcher for it. In Gnome you can create a launcher by right clicking on the desktop and using create launcher. It is really not that tough (usually).

Edit: In this case I THINK you would enter gpg2.

chousho
20th January 2008, 10:05 AM
You have a few options. If you have the bash autocomplete, you can start to type the name of the program, then tab or doubletab to either have it fill in the rest or view a list.

Also, right click on the "Applications" menu, select "Edit Menus" and see if you can find it there.

Hobashira
20th January 2008, 11:15 AM
Using

$whereis [program or file name]

is a good option, too.

Wayne
20th January 2008, 11:41 AM
If you were to read the documentation on the gnupg2 homepage you'll find out how to use it. As far as I know you have to set it up from a Terminal so obviously there's no entry in the menu. Terminal programs don't seem to have a GUI menu entry.

http://www.gnupg.org/documentation/faqs.en.html

Wayne

Evil_Bert
20th January 2008, 06:01 PM
but no link in the start menu to start using the program and make new keys??

kindly tell me how to start gnupg2..
This is in F8?

Try:
Accessories -> Passwords and Encryption Keys

And:
System -> Preferences -> Encryption Preferences

If you don't see those, you probably need to install gpgme and seahorse with:

yum install seahorse