PDA

View Full Version : Maple 11



xdzzz
20th January 2008, 12:27 AM
Hey, I wanted to install Maple 11 because I need it for school, and I installed it into my home directory (default location: /home/*myloginname*/maple11) and I just wanted to know if anyone that has used maple can help me get it running? (or haven't used it and can help me with a simple run command)

I read that you need to start it using the xmaple shell script but, when I double click and 3 options come up: Run in Terminal, Run, and Display.

I tried all 3 of them, the only one that shows any sign of working is "run in terminal".... the terminal will blink very fast and then thats about it.

I've tried to cd to /home/*myloginname*/maple11/bin/ (where xmaple is located) and that works, but idk how to start it... "sh xmaple" didnt work, said file didn't exist??? (clearly it does...)

OK and for future information... how do u run something such as a script or a program in the terminal? Lets say I wanted to run... lets say... openoffice, or the "chess" game through the terminal... HOW?!? I DONT GET IT plz help (mostly w/ the maple if ya can, but info would be nice too)

glennzo
20th January 2008, 12:43 AM
Open a terminal, change to the folder xmaple is in and try sh ./xmaple or just ./xmaple - Try it as regular user and as root. If it doesn't run at least you may get some error output.

xdzzz
20th January 2008, 01:29 AM
thanks but I already tried that... I got this "/home/covello/maple11/bin/maple: line 446: /home/covello/maple11/jre.X86_64_LINUX/bin/java: No such file or directory"

even tho thats not the directory i CD'd to... idk where the hell "jre.x86_64_LINUX/bin/java came from..., all i typed in was "./xmaple" in /home/username/maple11 ...soo... any other ideas? anyone else?

xdzzz
25th January 2008, 03:00 AM
Hey, I just wanted to update this by saying that I e-mailed Maple's support services and they said Fedora Core isn't officially supported but by running "./xmaple" in the after CDing to the bin directory it should have run. But it does not for some reason. I get the error that I copy pasted above.

"/home/covello/maple11/bin/maple: line 446: /home/covello/maple11/jre.X86_64_LINUX/bin/java: No such file or directory"

please, if someone has Maple 11 working on their Fedora (I have Fedora 8), please help me out.

glennzo
25th January 2008, 10:04 AM
Do you have java working? Looks like you're running the 64Bit version of Fedora and as I recall there are some issues with it and Java.

xdzzz
25th January 2008, 06:42 PM
actually yes I do, which is another reason why I don't understand why it's not working :(.

I used the script provided here to install: http://dnmouse.webs.com/autoinstall.htm

glennzo, do u have maple working on fedora? or are u just helping me out? is there any other things i should have downloaded or done in order to get it to work?

Thanks!

glennzo
25th January 2008, 06:49 PM
No maple here. Just trying to lend a hand.
This line, /home/covello/maple11/bin/maple: line 446: /home/covello/maple11/jre.X86_64_LINUX/bin/java: No such file or directory is the problem in my humble opinion. It's looking for java in the wrong place, or at least java isn't where the program thinks it should be. Can you tell me where /jre.X86_64_LINUX/bin/java is on your system? Maybe then you can make a link to it and get maple working.

xdzzz
26th January 2008, 12:44 AM
I did a search for "jre" on my filesystem, and my home directory. nothing with that name came up. other things did, including jre folders and iced tea folders (jfyi I also have iced tea installed... idk if that matters or not? idk what iced tea even is, something to do w/ java tho)

I think problem is not that its trying to execute the folder in the wrong directory but I think it's trying to access a folder that does not exist. Maybe b/c I installed in the home directory? I'm not totally sure. But yeah... that error keeps coming up when going through the terminal and jre.x86_64_LINUX does not exist.

Should I reroute w/e its trying to access to a certain java folder?

edit: I found out I have a "jre-1.7.0-icedtea.x86_64/bin/java" file somewhere on my filesystem... maybe i should somehow change it so it accesses that file and not what it's trying execute. Altho... i have no clue how I would do that at all... that is reconfigure the xmaple script...

glennzo
26th January 2008, 01:49 AM
OK, type in a terminal, as root, updatedb then when that's finished type locate libjava.so and post the full path of that file please.

xdzzz
26th January 2008, 04:00 AM
mmk... heres the big shabang..

[root@localhost covello]# updatedb
locate libjava.so
[root@localhost covello]# locate libjava.so
/home/covello/maple11/jre.IBM_INTEL_LINUX/lib/i386/libjava.so
/usr/java/jre1.6.0_03/lib/i386/libjava.so
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/lib/amd64/libjava.so

well?

hey, if i didnt say it already, thanks for the help! ur the only one helping lol. i appreciate it.

glennzo
26th January 2008, 10:58 AM
Try this. In a terminal as root, type,
ln -s /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/lib/amd64/libjava.so /home/covello/maple11/jre.X86_64_LINUX/bin/java
You should be able to copy and paste this line. Then try running the program again.

xdzzz
27th January 2008, 02:56 AM
mwuahah! yes. finally. Thanks man, you were definitely on the trail. you were partly right. it turns out the whole jre.x86_64_linux folder and bin.x86_64_linux folder were incorrectly named and were just called "jre.intel_linux" instead of what it was suppose to be. so i just changed the name of the folder and it booted up. ONE slight problem tho.

It said "mserver" was not in bin.x86_64_linux folder... so i just renamed that intel one, and now maple and java boot up perfectly fine... but when the server trys to boot i get a blank maple 11 applet w/ "untitled [1] - server[1]" at the title bar and it just stays blank... i still cant use maple.

edit: I got the activation services and everything working. I executed the "TestMaple" script and it says stuff in the terminal... doesnt look like any errors tho. Even the "tips to use" comes up ... I just cant see any of the appelets or open files or anything.

nucleo
27th January 2008, 05:07 AM
I have a problem with Maple 11 Classic Worksheet Motif interface (with last update 11.02) in Fedora 7 and 8 i386.
Maple crashes after appearance of context menu on the result of calculations without any error message in console.
Maple 11 works fine in Fedora 5.
What can be done to fix this problem?

xdzzz
27th January 2008, 07:26 AM
hey, yeah man i'm with you. basically for me the GUI isn't working right. I can't see like "File, Edit, View" toolbar but if i click at the invisible thing... the drop down menu shows up... but no worksheet shows up and I cant even get my homework done. I'd have to boot into windows. So if anyone can help us out... I think we have similar problems. 11.02 I have the same version too, I though it would change it by updating to newer version but it didn't.

xdzzz
27th January 2008, 09:44 AM
update: Okay, this is REALLY weird now... it worked... everything worked fine. For like... a little bit. A reboot fixed it... then a reboot crashed it. idk what the hell is going on...


update2: Okay, i figured out why it worked and why it didn't with a reboot.

the GUI (for me) does not worth with compiz enabled... with "desktop effects" disabled... Maple 11 works completely fine.

All I had to do was rename the "jre.IBM_INTEL_LINUX" and "bin.IBM_INTEL_LINUX" folders to "jre.x86_64_LINUX" and "bin.x86_64_LINUX" respectively. Then boot from xmaple.

Thanks for the help, if it wasn't for you, glennzo, leading me in the right direction, then I would have never figured this out. Amazingness! First time this forum has proved to help me, all the other times I had to google it or do it by myself!

nucleo
27th January 2008, 02:59 PM
I have installed xorg-x11-fonts-75dpi-7.2-3.fc8.rpm and xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8.rpm.
They are needed for displaying of fonts in menus "File, Edit, View..." in Classic Worksheet interface.
Motif interface works fine until context menu on the result of calculations appears and disappears.

glennzo
27th January 2008, 03:00 PM
Great! I never thought about the fact that you could be using Desktop Effects. While the effects are cool I have found that there's a few apps that won't run properly with it enabled. Google Earth for one. So I change to Metacity and all is well. Good that you got it working. And I might add that it was quite a test for me since I don't use Maple 11, don't have it installed and still don't even know what it's purpose is.

Edit: Now it's your turn. See if you can help nucleo.

xdzzz
27th January 2008, 08:00 PM
to be honest, I can't help you much nucleo... I'm a complete linux noob. If you have desktop effects disabled, you added the fonts, and then i'm not sure about your problem.

What exactly isn't working? Can you get the worksheet mode to work? Or can you just not do calculations? I'm a little confused as to what the problem actually is. If you can, try executing "TestMaple" by CDing to the "maple11/bin" directory and typing this "./TestMaple". That helped me by telling me what files weren't in the right place or missing. Might tell you some information about you're problem as well.

nucleo
27th January 2008, 11:19 PM
TestMaple creates normal output file l00.out.
I can do calculations both in java interface (xmaple) and motif interface (cwmaple).
But only motif interface crashes after appearance of context menu on the result of calculations.
May be problem in system libraries because the same maple executable works in Fedora 5 without crash.

glennzo
28th January 2008, 01:37 AM
Have either of you spent time reading documentation or faqs for this program? I haven't, but I have no need for the program so I'm just wondering if there's any sort of help on the Maple 11 web sites.

xdzzz
28th January 2008, 08:11 AM
yeah, unfortunately they aren't much help. I also e-mailed them and they responded "sorry but fedora core isn't officially supported by our application" so... , the guy did try to help and asked about my java and other stuff. So if we cant help nucleo, just send over an e-mail they'll respond in a day usually. support@maplesoft.com

I haven't tried the maplecw to be honest, i'm more concerned about xmaple because we use it for homework for simple calculus problems. So... yeah, as long as it works is my motto. But yeah, if it crashes i'm sure something has to be wrong w/ the lib... maybe something is misnamed or missing.

glennzo
28th January 2008, 12:11 PM
is there a free download or a trial version of this program?

xdzzz
29th January 2008, 06:19 PM
no, I don't think so. you can check, go to www.maplesoft.com. i doubt it tho, they're kinda *****es. I had a working copy of Maple 11 windows but it was only a windows/mac CD... so i just illegally downloaded it but used my legal purchased code. So I guess it's not really illegal. They don't even allow you to download the program from their site so if i wanted a linux CD i would have had to repurchase or call and ask for them to send me one.

hopefully nucleo will fix it tho, I think e-mailing them will help.

eugeny12
9th April 2008, 01:44 PM
Short comment. With "desktop effect" disabled Maple 11 is working. That's right.
If I open Maple 11 with "desktop effects" enabled, I will get blank screen instance.
Then I make "desktop effect" disabled, then switch back to enabled.
This opened instance of Maple 11 is already working fine with "desktop effects" enabled.
What the problem?! Can somebody shows me the way that I don't need always switching!
P.S. It is not real big problem as no library or java problem... In this case Maple 11 for sure cannot
works at all with enabled "desktop effectcs". (Fedora 8 x64)