PDA

View Full Version : Dell SP2208WFP Monitor's Webcam?



thesun
19th January 2008, 04:22 PM
Trying to get the webcam working on my new Dell SP2208WFP monitor. Anyone know what needs to happen to make it work...or if it's yet supported? It doesn't seem to be as simple as plugging in the USB cable and saying "Cheese." :-)

Gentoo Bob
19th January 2008, 05:13 PM
i kind of had the same issue with an external webcam (Logitech) and did some research and found a program that provideds the drivers. Webcam support is limited in Linux, at least for newer web cams. You need to find out the make/model of the webcam in your notebook, then look for linux drivers. Google is your friend. I used the instant messenger KOPETE and it provided support and I can use my webcam with it. Good luck on your search.

thesun
19th January 2008, 06:45 PM
This is a webcam that's in the monitor -- I have a desktop, and the screen (Dell model SP2208WFP) has the webcam integrated into the top of it. Any idea how to identify the make/model? I guess I can try Kopete and see if it detects it...thanks... :-)

Gentoo Bob
21st January 2008, 03:58 AM
look in your dmesg and see what it picks up...it will probalby be towards the bottom...i dont know any abbreviations linux uses for webcams in the system profile. (example eth0 = network card).

you could try #dmesg | grep -i webcam or something like that or just 'web'

thesun
21st January 2008, 08:28 PM
Hmmm. If I'm parsing this info correctly it looks like it's seeing the monitor's integrated USB ports, identifying two usb devices (probably the audio and cam), and that's where the buck stops. No?

A driver, a driver! My kingdom for a driver!!! :-)




Jan 21 14:25:00 localhost kernel: usb 2-3: new high speed USB device using ehci_hcd and address 19
Jan 21 14:25:00 localhost kernel: usb 2-3: configuration #1 chosen from 1 choice
Jan 21 14:25:00 localhost kernel: hub 2-3:1.0: USB hub found
Jan 21 14:25:00 localhost kernel: hub 2-3:1.0: 2 ports detected
Jan 21 14:25:00 localhost kernel: usb 2-3.1: new high speed USB device using ehci_hcd and address 20
Jan 21 14:25:01 localhost kernel: usb 2-3.1: configuration #1 chosen from 1 choice
Jan 21 14:25:01 localhost kernel: usb 2-3.2: new high speed USB device using ehci_hcd and address 21
Jan 21 14:25:01 localhost kernel: usb 2-3.2: configuration #1 chosen from 1 choice
Jan 21 14:25:01 localhost kernel: hub 2-3.2:1.0: USB hub found
Jan 21 14:25:01 localhost kernel: hub 2-3.2:1.0: 4 ports detected
Jan 21 14:25:01 localhost pulseaudio[22456]: alsa-util.c: Error opening PCM device hw:1: No such device
Jan 21 14:25:01 localhost pulseaudio[22456]: module.c: Failed to load module "module-alsa-source" (argument: "device_id=1 source_name=alsa_input.usb_device_ffffffff_fffffff f_noserial_alsa_capture_0"): initialization failed.

thesun
22nd March 2008, 10:57 PM
Just tying up the loose end: I've now gotten it to work without (apparently) doing anything at all. I think a recent Yum update must have included whatever drivers I needed to have. I can use Cheese and Skype, although I haven't yet found a way to test the audio. Any suggestions for a good "Take a Video with Your Webcam" application that I could use?

scotta3234
22nd March 2008, 11:06 PM
You can use the skype test call feature to test and see if your audio is working.

thesun
23rd March 2008, 02:05 AM
I've been playing around now for hours trying to get various video-related programs to work. Why aren't there more Yum-enabled video applications? For example, Zoneminder, Camorama, which seem the most promising, don't seem to have repos and when I try compiling from source I end up in dependency hell. Or, alternatively, all kinds of libraries and files that I know I have aren't found.

What I'd like is an application that lets me record short (or, heck, long) videos in a commonly used format...with audio. Does Cheese do this? I'd prefer something at the command line. What programs to other people use for their simple webcam applications?

(I actually don't need it, yet anyway, to do anything on the actual web. I just want to record to avi or mpeg files.)

Thanks for any and all help. I'm not sure if this should be a separate thread but Forum admins have been beating me with a stick so I'll keep this one here and hope someone can find it rather than risk double posting.

thesun
12th September 2008, 06:08 AM
It's been a while...I'm still having no luck using this webcam. Whatever I did ages ago worked for a little while (I never figured out what I did) and then it stopped working again. Anyone out there know how to get this webcam running?

One possible clue: when I pull up Skype video, it only lists my TV tuner card as /dev/video0, and that's the only option for video.

Should I be manually loading some specific drivers? If so...which ones?

thesun
17th September 2008, 02:20 PM
Still haven't gotten anywhere with this. It's apparently supported in the luvcvideo module, which I've installed. I don't know why it worked for about 2 weeks and then stopped working...that's just odd. The little blue webcam light flashes initially when the computer boots, and that's all the love I get. If anyone out there has this same monitor and has gotten the webcam working I'd love to know what worked....thanks in advance!

thesun
24th November 2009, 07:33 PM
Back again. I'm now using Fedora 11 and feel like I'm 80 percent of the way here with this. When I do "dmesg" I get the following:


usb 1-6.1: new high speed USB device using ehci_hcd and address 10
usb 1-6.1: New USB device found, idVendor=05a9, idProduct=2643
usb 1-6.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-6.1: Product: Monitor Webcam (SP2208WFP)
usb 1-6.1: Manufacturer: Mic-OmniVision Technologies, Inc.538-2640-07.08.09.6
usb 1-6.1: configuration #1 chosen from 1 choice
uvcvideo: Found UVC 1.00 device Monitor Webcam (SP2208WFP) (05a9:2643)
uvcvideo: UVC non compliance - GET_DEF(PROBE) not supported. Enabling workaround.
uvcvideo: Failed to query (129) UVC probe control : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).

The little blue "it's on" light flashes for a few seconds when I'm first plugging it in. Then nothing. Apparently this monitor works fine in Ubuntu so it seems crazy to me that it won't work in Fedora. Anyone out there know what I need to tweak to get it working?

Thanks very much...

AdamW
24th November 2009, 09:12 PM
well, you say you're using 'Fedora 11' (which is six months old) and give no information on what if any kernel updates you've done, and you don't give any information on what Ubuntu you've tried, so it's kind of hard to know whether it's 'crazy'. If you're using Ubuntu 9.10, fr'instance, it would be perfectly logical, since that has a later kernel version and hence a later version of uvcvideo with more hardware support fixes.

Have you updated Fedora 11 to the latest kernel available for it? What Ubuntu are you running? What's the kernel version (uname -r output) in both?

thesun
25th November 2009, 07:09 PM
Sorry for the lack of info. Hopefully this will help:

Linux localhost 2.6.30.9-96.fc11.i686.PAE #1 SMP Tue Nov 3 23:41:33 EST 2009 i686 i686 i386 GNU/Linux

I haven't tried Ubuntu with this monitor myself, but reading posts in other forums has shown that it works (for some people anyway!) and it's supposedly recognized (green checkmark) by the uvcvideo drivers. By using modprobe to load and unload the uvcvideo module it eventually will recognize the monitor and Cheese will work. I would like to have it running with Skype, however.

As always, any thoughts, tips, or suggestions would be wonderful. If anyone has a F11 system and is actually running this same monitor I'd love to know if it's working for you!

proflogic
19th February 2010, 09:54 AM
This might be like the issue with the Logitech webcams where the timeout was simply too short. I managed to get my webcam (same sp2208wfp monitor) to load after removing and reloading the module a couple times.

It seems there was a patch for it, but for whatever reason, it never made it into the mainline kernel. Reference: http://patchwork.kernel.org/patch/52261/ (http://patchwork.kernel.org/patch/52261/)