PDA

View Full Version : SCIM Korean Romaja option?



thesun
19th January 2008, 03:33 PM
In FC5 I used to have a great SCIM option that let me type Korean letters using Roman equivalents. To get "ㅂ" for example, I could type "ba" instead of "q" (which is the Korean keyboard equivalent). I've tried a bunch of different yum searches and haven't found anything like that available. Anyone know how to set up Korean Romaja? I'm running FC8 now.

thesun
5th December 2008, 05:33 AM
Still trying to figure this out. Any Korean language users out there know how to do this?

scottro
5th December 2008, 06:16 AM
I would assume it's like Japanese scim-anthy. That usually pretty much works. You type the romaji, as it's called in Japanese (the Latin letters) and get the equivalent phonetic or ideographic version.)
I assume you install scim and language support for Korean. Isn't there an option when you open scim, to choose input. (I would guess there's something like scim-anthy for Korean, but I have no idea what it is, though doing a quick yum search scim on CentOS showed that there's a scim-hangul.

linuxpcmancn
5th December 2008, 06:20 AM
yum install *scim* to get whatever you want

thesun
7th December 2008, 06:52 PM
It's not as simple as that. Installing "scim" just provides (I've no idea why) the Korean keyboard layouts...which have little or no connection to the English keyboard I have. Hangul Romaja, which is in the "scim-tables-ko" package, doesn't seem to be included or isn't, for some reason, working when I just install scim.

I have Japanese, in both Anthy and SKK working just fine in Scim, and Korean input works via the Korean keyboard. But what has eluded me (up until just now) was getting the Hangul Romaja option which means that when I type "k" and "a" on the keyboard, I get a 카 in Korean.

The solution was to Google for an old "scim-tables-ko" rpm and force it with nodeps. After I did that and restarted Scim it worked just like I'd hoped...I have the 2bul and 3bul etc. options, but an additional one for "Hangul Romaja" and that's the only one that's really usable on an American/English keyboard.

So I am set for now. I just wish that this Hangul Romaja worked right from the start when I installed "scim-hangul" or other Korean packages. It seems to have been dropped from the list for some reason and I think it's by far the most vital option for anyone in my situation who wants to play around with Korean but who doesn't have a Korean keyboard.

scottro
7th December 2008, 07:33 PM
Glad you fixed it. You might consider filing a bug. If possible, maybe even a quick install in a virtual machine, such as KVM or VirtualBox, to make sure that you can duplicate the error.

Regardless, glad you fixed what was no doubt a frustrating issue.

yosato
22nd June 2009, 12:42 PM
I have the same problem now, which presumably means the bug has not been fixed yet. I know this affects a very small population, as it would be the intersection of fedora users / korean-speakers / non-korean (as the koreans use their keyboards), but for 'us', it is a big problem!

scottro
22nd June 2009, 02:04 PM
I think Fedora is now concentrating on ibus--which seems to be shaping up quite nicely.