PDA

View Full Version : SCIM unstable after backspace or Enter key?



thesun
19th January 2008, 03:29 PM
I've noticed that I'm getting odd things happening when I use SCIM typing Japanese. It's fine until I hit Enter or the Backspace key, then it seems to repeat characters. For example, if I type "ja" SCIM will think I'm typing "jja" and if I keep typing, it gets worse. The only solution I've found to work around it is to hit control-space twice (exiting and reentering SCIM), but having to do this every line is annoying and I'm sure either there's a Qt bug or SCIM bug or maybe a setting that I've got incorrectly selected. Anyone else have this issue, and anyone know how to fix it?

I'm on FC8 in a KDE environment.
Qt: 3.3.8
KDE: 3.5.8-7.fc8 Fedora
KMail: 1.9.6 (enterprise 0.20071204.744707)
Smart Common Input Method 1.4.7

Here's a sample of what I'm talking about:

これはテストです。 今大丈夫ですが、エンターを押すと:
ええnえんえんtえんたえんたをおすと、全部が悪くなった。
dどどうどうsどうshどうしどうしyどうしよどうしようどうしよう?

Actually, I cut and pasted that in from Kmail since the problem didn't seem to occur here in Firefox. All I typed in the 2nd line was "entaa wo osu to..." and in the 3rd line "doushiyou?" and it turned into that, when it should have looked like:

エンタアを押すと、全部が悪くなった。
どうしよう?

I'm guessing it's a Kmail/SCIM issue since it seems to work fine in Firefox.

Many thanks!!!

:-)

Wayne
19th January 2008, 03:37 PM
What about other 'K' apps, like its text editor, etc? I use SCIM in Gnome with no problems so can't check.

Waynw

thesun
19th January 2008, 06:43 PM
I've seen no problems in any other applications: KWord is fine, Firefox, etc., but it's _always_ occurring in KMail.

scottro
19th January 2008, 08:05 PM
I'll see if I can check on Monday--I don't have KDE on anything here. Oh, Monday's a holiday, I won't be able to check till Tuesday.

However, from what you describe, I'm suspecting it's a kmail issue.

thesun
20th January 2008, 04:28 AM
I've seen it in Konqueror too. But not in KWord. KMail's the big culprit though. I wonder if it's something funky I've done in the Settings. If anyone out there is using KMail and SCIM and _not_ having the problem let me know how you've got the Scim Front End set up and so on...maybe it's something related to that.