PDA

View Full Version : Linux noob having trouble with dual head in 64-bit FC8



jdhaugen2
19th January 2008, 12:02 AM
I have attempted to find info on this subject in doc's and FAQ's, but have failed so far...

Have done clean install Fedora core 8 64-bit, and all updates (230+). Video card NVIDIA GeForce 7600 GS, one DVI LCD (Envision EN9110, using generic LCD for this), and one analog LCD, NEC MultiSync LCD1700M+, listed as such in system-config-display setup. Both screens have native 1280 x 1024 resolution.

DVI screen displays correctly, but analog screen displays flashing garbage, even after choosing dual head in the "screens and displays" (I believe it's called) GUI.

Xorg.conf file, exactly as created by system-config-display, is below. Is there a simple editing change that will activate the analog display?

Thanks for any help for a newbie! :)


# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "Multihead layout"
Screen 0 "Screen0" LeftOf "Screen1"
Screen 1 "Screen1" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
Option "Xinerama" "off"
Option "Clone" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us+inet"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "NEC MultiSync LCD1700M+"
HorizSync 31.0 - 81.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor 1280x1024"
HorizSync 31.5 - 81.0
VertRefresh 50.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nv"
EndSection

Section "Device"
Identifier "Videocard1"
Driver "nv"
VendorName "Videocard Vendor"
BoardName "nVidia Corporation G73 [GeForce 7600 GS]"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Emphyrio
19th January 2008, 09:49 PM
First off, this probably is NOT a 64 bit issue.

Second, get you system running correctly with a single monitor first.

Third, log in as root and install the correct drivers (nVidia or ATI).

Reboot

Fourth, login in as normal and make sure everything is working as it should.

Fifth, shut down and plug in you second monitor.

Sixth, boot up and log in as root. Open up the "nVidia Display Settings" program and activate the setting you need...there are a lot of choices to make (Twinview, Xinerama, Separate X screens). Save the settings. If everything works, back up you xorg.conf.

Seventh, log out, log in as your regular account. enjoy ( I hope). Please note the "nVidia Display Settings" program does not seem to work correctly unless you are logged in as root.

If this works...or doesn't..please let me know. Since this is such a common problem I am writing a HOWTO about this.

jdhaugen2
20th January 2008, 06:49 PM
Thanks very much, Emphyrio. I'll try it as soon as I have some time to concentrate on what I'm doing....

For installing the nVidia driver, I will follow the instructions on the nVidia website, I guess. It's not available in the repo's, is it????

And lastly, I am wondering if I will have to repeat the procedure whenever there is an update to the kernel??? Is that to be expected?

John

Emphyrio
20th January 2008, 10:10 PM
Actually it is.

First enable the livna repo, by following the instructions here:

http://www.fedorafaq.org/#getsoftware

Then all you have to do is follow the instructions here:

http://www.fedorafaq.org/#nvidia

It's best if you log on as root while you are doing this.


OR

Log in as root, start your desktop session. Open the package manager. There should be a menu option to edit repositories. Just check livna. Then go to the search tab and type in kmod-nvidia. Chose the package that is appropriate AND the package that is described as the 'metapackage'. Install, then reboot.

jdhaugen2
21st January 2008, 01:16 PM
Without the instructions for other repo's, i.e. livna in this case, I would have been lost. Maybe "http://www.fedorafaq.org/#getsoftware" is "unofficial", but it was essential for me. For a noob, it's hard to tell which (stable) repo's are even available, if they're not enabled in the original installation.

I performed all changes as root. First install of nvidia driver via command line failed to enable, so I uninstalled, and went to package manager, which installed OK with additional repo's selected. After more than one reboot, and a little experimentation with options (Xinernama, Twinview, etc.), it seems to work OK, but I have not determined if it will reboot as I left it previously, as of yet (saving changes to Xorg.conf as root). Have not tried different resolutions on each monitor, either. Also have not read through current Xorg.conf to see if it looks conflicted after all the changes...

Anyway, I think I'll go "sip" a little java - Iced Tea about now. Thanks for all the help!

john