PDA

View Full Version : Default installation path



virendra maloo
18th January 2008, 08:23 AM
what is the default installation path of apache2 and php in fedora core 8.
Please help.

markkuk
18th January 2008, 01:21 PM
You can list the files installed by those packages by "rpm -ql httpd" and "rpm -ql php". Both packages store files in several directories, there's no single "installation path".

virendra maloo
18th January 2008, 01:49 PM
My problem is this:
I am installing a s/w and I hav to edit http.conf. This is what i got frm the install file of the pkg.

:=The PHP distribution on Linux platform does not have the required mysql, zlib modules compiled by default
(unlike the Windows distributions), neither does it build the Apache 2 PHP module by default. So you will have to
build these modules manually by following instructions in the INSTALL file included with your PHP distribution
package. For example:
# ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql --with-
zlib
# make
# make install
For users who have installed MySql 4.1.x or higher releases, the MySql Improved PHP extension (MYSQLI)
should be used instead of the regular MySql PHP extension (MYSQL). The option “--with-mysql” above
should be changed to “--with-mysqli” when configuring the above PHP build environments.
If the above ‘make install’ command runs successfully, the PHP module for Apache 2 (‘libphp4.so’ or
‘libphp5.so’) should have been installed automatically in /usr/local/apache2/modules/, and your
HTTPD.CONF file should have been modified automatically to include the PHP module


the Qn is 'What is the replacement for this command (/configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql --with-
zlib)as i dont find this directory in fc8'

virendra maloo
18th January 2008, 01:49 PM
sorry that was httpd.conf

markkuk
18th January 2008, 03:36 PM
the Qn is 'What is the replacement for this command (/configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql --with-
zlib)as i dont find this directory in fc8'

There is no replacement, because the command is completely unnecessary. Fedora distributes PHP and Apache httpd as pre-compiled binary packges. You don't need to rebuild them from sources and you should ignore any instructions telling you to do that.


rpm -ql httpd | grep 'httpd.conf"shows you the location of httpd.conf.

virendra maloo
19th January 2008, 05:48 AM
you didn't go through the lines carefully,please read it back.

If the above ‘make install’ command runs successfully, the PHP module for Apache 2 (‘libphp4.so’ or
‘libphp5.so’) should have been installed automatically in /usr/local/apache2/modules/, and your
HTTPD.CONF file should have been modified automatically to include the PHP module.
If not, you will need to
manually edit the HTTPD.CONF file as the following:
****************** BEGIN: "HTTPD.CONF" Linux Platform ************************
For Users who have installed PHP 5:
********************** BEGIN: Loadable Modules – PHP 5 Users Only *********************
#
# Loadable modules
#
LoadModule php5_module modules/libphp5.so
********************** END: Loadable Modules – PHP 5 Users Only *********************
For PacsOne Server specific configurations, you will need to make the following additional changes to the
HTTPD.CONF file as the following:
********************** BEGIN: TypesConfig Module *********************
#
# TypesConfig describes where the mime.types file (or equivalent) is
# to be found.
#
TypesConfig conf/mime.types
AddType application/x-httpd-php .php
********************** END: TypesConfig Modules *********************
********************** BEGIN: Aliases *********************
#
# Alias
#
Alias /pacsone "{PACSONE_INSTALL_DIR}/php"
<Directory "{PACSONE_INSTALL_DIR}/php">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>
********************** END: Aliases *********************
******************* END: "HTTPD.CONF" Linux Platform ************************

and my php.ini is not configured automatically even after doing all of these changes.



also I've to edit php.ini as follows:

PHP.INI – Linux or Mac OS X Users Only
The PHP configuration file PHP.INI needs to be modified as follows:
********************** BEGIN: "PHP.INI" ****************************
********************** BEGIN: Extension Directory ******************
; Directory in which the loadable extensions (modules) reside.
extension_dir={PHP_INSTALL_DIR}/ext
********************** END: Extension Directory ******************
********************** BEGIN: Loadable Modules ******************
;Loadable Modules
extension=imagick.so
********************** END: Loadable Modules ******************
*************** BEGIN: Session.Save_Path – Refer to Section 5.4.7 ***********
session.save_path=/tmp
******************** END: Session.Save_Path ******************
*********************** END: "PHP.INI" *****************************
Where:
♦ PHP_INSTALL_DIR is the directory where PHP is installed, e.g., /usr/local/lib/php/
My Qn to you is ,where is the php installation directory in fc8.


5.4.13 Copy ‘imagick.so’ – PHP 5.0.x Linux Users Only
Revision 5.1.2 Company Confidential Page 23
Copyright 2003-2007 Rainbowfish Software
‘php5/imagick.so’ is the PHP 5.0.x extension module for ImageMagick, you need to copy the shared library
from:
{PACSONE_INSTALL_DIR}/ImageMagick/php5/
to:
{PHP5_INSTALL_DIR}/ext
Where:
♦ PACSONE_INSTALL_DIR is the directory where PacsOne Server is installed.
♦ PHP5_INSTALL_DIR is the directory where PHP 5.0.x is installed.


After the shared-library is copied, you need to verify the shared library dependencies are valid:
# ldd /usr/local/lib/php/ext/imagick.so
linux-gate.so.1 => (0xffffe000)
libMagick-5.5.6-Q16.so.0 => /usr/local/lib/libMagick-5.5.6-Q16.so.0
(0x40010000)
libbz2.so.1 => /usr/lib/libbz2.so.1 (0x401a6000)
libm.so.6 => /lib/tls/libm.so.6 (0x401b6000)
libc.so.6 => /lib/tls/libc.so.6 (0x401d8000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x40300000)
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x402ed000)
libdl.so.2 => /lib/libdl.so.2 (0x402fe000)
libz.so.1 => /lib/libz.so.1 (0x40301000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)


I hope, this isn't that big for you guys, help me.