PDA

View Full Version : Xserver crash+literally nothing is working!



mediator
18th January 2008, 06:38 AM
Hi,
I got a new machine with 1440 900 19" LCD display. I installed fedora 8 on it and upgraded right away. Then I installed the multimedia stuff.

Now the problem is lterally nuthin is working. I thought it might be some config settings. so Icreated a new account and now it looks like this
http://img301.imageshack.us/img301/901/snapshot1br2.th.png (http://img301.imageshack.us/my.php?image=snapshot1br2.png)

Xmms, mplayer , office, xine, kde, gnome nuthing works properly! Here's a detail output



[temp@Quad ~]$ xmms

Gtk-WARNING **: Failed to load module "libgnomebreakpad.so": libgnomebreakpad.so: cannot open shared object file: No such file or directory

Segmentation fault

You've probably found a bug in XMMS, please visit
http://bugs.xmms.org and fill out a bug report.

[temp@Quad ~]$ mplayer
Segmentation fault
[temp@Quad ~]$ xin
bash: xin: command not found
[temp@Quad ~]$ xine
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2007 The xine Team.
Segmentation fault
[temp@Quad ~]$ vlc
VLC media player 0.8.6d Janus
Segmentation fault
[temp@Quad ~]$ open
open openoffice.org-1.9 openvt
openct-tool openoffice.org-2.0
openoffice.org openssl
[temp@Quad ~]$ open
open openoffice.org-1.9 openvt
openct-tool openoffice.org-2.0
openoffice.org openssl
[temp@Quad ~]$ openoffice.org
0dc7a334-40eb-b090-53224a5e-753b1dec is dumped
/usr/lib/openoffice.org/program/soffice: line 147: 3438 Segmentation fault "$sd_prog/$sd_binary" "$@"
[temp@Quad ~]$




Here's another error which I guess is causing much problem.

http://img292.imageshack.us/img292/7599/snapshot2fe6.th.png (http://img292.imageshack.us/my.php?image=snapshot2fe6.png)

And here's the crash report....
http://crash.gnome.org/report/index/58cc4c0c-c57f-11dc-8566-0007e9333148?date=2008-01-18-04


What the heck is wrong? I think there is some module that is not being loaded and causing all the chaos. But my knowledge of X is very limited. Please help! :(

Thanx!

leadgolem
18th January 2008, 06:44 AM
Unfortunately "segmentation fault" is an extremely uninformative error, so let's start with your first error. Try this to get libgnomebreakpad.so installed.
su
yum install bug-buddyEDIT: Also try this.
yum install metacity gtk2 gtk+

mediator
18th January 2008, 06:48 AM
I edited my earlier post. There 3 more problems

1. Yum install/update also gives segmentation fault many times. I tried "rpm --initdb/rebuildb", but it still persists randomly.

2. These apps dont start in kde also!

3. keyboard key doesn't persist! I mean after typing a long command like "yum install a b c d e f" when the keyboard blink is on say right, I have to press left button repeatedly to get to left. It doesn't work if I keep the left button pressed and vice versa!



BUT firefox works!! Thats how I am able to contact this forum right now and bug-buddy is already installed !! :(

Edit : metacity and gtk u told are already installed :(

mediator
21st January 2008, 03:25 PM
SOLVED!!

It was a bad install in the presence of a bad memory stick. I removed the stick and reinstalled. Everything is awesome again! :)

leadgolem
22nd January 2008, 02:41 AM
Yeah, bad ram would do that.