PDA

View Full Version : Gateway 7426GX Laptop, suspending doesn't work



cbeck20
17th January 2008, 09:43 PM
When I try to suspend my laptop, it seems to work at first, the light on my laptop begins to blink indicating that it was put into sleep mode. But when I try to resume the laptop I am presented with a blank black screen and the keyboard doesn't seem to reactivate it.

It seems the graphics card needs a jump start to get working again. I know Fedora 8 supports Hal Quirks (http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-index.html) but I am unsure how to use that website to get suspending to work.
But what is weird is that hibernation works just fine on the laptop.

So can someone please explain to me how to use the Hal Quirk website, or other methods to troubleshoot the issue.

Any help is appreciated. Thanks

jrummy27
17th January 2008, 09:49 PM
Is the keyboard responsive? I.e., do the caps/num lock keys turn on the led's? Are you using F7 or F8?

If not, this sometimes happens because the wireless driver or something else fails to unload/load properly. If you are using wireless, try unloading the module before suspending. Example: If you wireless driver is bcm43xx, then do
# rmmod bcm43xx Then suspend and resume. If it works, then you can try adding it to /etc/pm/config.d/unload_modules like so:
SUSPEND_MODULES="bmc43xx"

If the keyboard is responsive, are you using compiz-fusion? If so, disable "sync to vblank" in the options, that worked for me.

cbeck20
17th January 2008, 10:01 PM
Yeah the caps/num lock keys are unresponsive. I'm using F8 x64.

Will that command work for the broadcom driver if I'm using b43?

And to add to insult I am using compiz-fusion so I'll have to add that option into it as well. I'll post here when I am finished. Thanks for the help.

jrummy27
17th January 2008, 10:05 PM
If you're using b43 then run
# rmmod b43 If suspend works after removing it, then add this to /etc/pm/config.d/unload_modules
SUSPEND_MODULES="b43" then try suspending again and see if it works.

jrummy27
17th January 2008, 10:10 PM
To disabled sync to vblank in compiz if you have fusion-icon installed, right click it (or run it from Applications->System Tools then right click it) and go to

Settings Manager->General Settings->Display Settings->Sync to vblank = unchecked.

cbeck20
18th January 2008, 04:22 AM
Thank you so much for suggestions but sadly they didn't work. The b43 module was successfully turned off because when I ran the command, my wireless was gone. I also successfully turned off VSync for Compiz-Fusion as well. But suspending didn't work.

When I put the computer into suspend mode what I found interesting that typing on the keyboard didn't even try to bring the computer back from suspending. I had to close my laptop lid and reopen it to get it going but again the screen remained off and the keyboard didn't do anything. But I tried every key on the keyboard and somehow was able to get my Scroll Lock light on my laptop to start flashing. Maybe it was just typing on my keyboard too much I don't know.

Are there any logs kept when going into suspend mode that I can post here?

Right now if I go into the suspend mode, the only thing I can do is restart my laptop right now.

jrummy27
18th January 2008, 03:32 PM
When the keyboard locks up like that and you start typing you'll usually see the num lock light start flashing, so that is normal.

Unfortunately I don't have any other ideas. You can try the quirks like you said, you can see them with
# pm-suspend --help

cbeck20
18th January 2008, 05:11 PM
When the keyboard locks up like that and you start typing you'll usually see the num lock light start flashing, so that is normal.

Unfortunately I don't have any other ideas. You can try the quirks like you said, you can see them with
# pm-suspend --help

How do I use the quirks? I typed the command above and got these options.

Options can change how the supend or hibernate is done.

Possible actions are:

--quirk-dpms-on
--quirk-dpms-suspend
--quirk-radeon-off
--quirk-reset-brightness
--quirk-s3-bios
--quirk-s3-mode
--quirk-vbe-post
--quirk-vbemode-restore
--quirk-vbestate-restore
--quirk-vga-mode3

jrummy27
18th January 2008, 05:16 PM
You would just run pm-suspend with one of the quirks, like so
# pm-suspend --quirk-s3-bios the page you looked at before has a description of what they mean and when to try which one. I'd start there and just start going through the quirks that seem relevant.

cbeck20
18th January 2008, 05:43 PM
Thanks, I really appreciate the help.

So far I've tried:
--quirk-dpms-on
--quirk-s3-mode
-quirk-radeon-off

with no luck hopefully the other ones may help.

cbeck20
18th January 2008, 05:55 PM
pm-suspend --quirk-vbe-post really did something weird to my computer.

The monitor turned off but the power light on my computer remained lit (normally it flashes indicating that it is in suspend mode).

I'll be testing out more of those quirks later but I need to work on a few things before then.

cbeck20
19th January 2008, 07:48 AM
If I enable these quirks and they don't work, do they remain activated?

The reason I ask is because looking at my dmesg, I see a few entries for quirk in there maybe indicating that they remain active even if they didn't work.
How do I disable these quirks?