PDA

View Full Version : Sound/volume control problems after recent f-8 pulseaudio updates



BlueC
17th January 2008, 12:12 PM
After todays updates (see below) I could no longer use the volume control applet to control my audio devices. It errors with...

"No volume control GStreamer plugins and/or devices found."

I "fixed" it by "chmod -R 777 /dev/snd/" - but that is real dirty and not really a solution.

Anyone else got this problem? Know a proper solution?

Is it just me or are f8's updates even more buggy than they were with f7?

==========

Todays updates:

Jan 17 10:01:37 Updated: e2fsprogs-libs - 1.40.2-12.fc8.x86_64
Jan 17 10:01:38 Updated: hpijs - 1:2.7.7-7.fc8.x86_64
Jan 17 10:01:39 Updated: pulseaudio-libs - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:40 Updated: cairo - 1.4.14-1.fc8.x86_64
Jan 17 10:01:40 Updated: pulseaudio-core-libs - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:44 Updated: pulseaudio - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:44 Updated: pulseaudio-module-x11 - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:45 Updated: pulseaudio-libs-glib2 - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:45 Updated: pulseaudio-module-gconf - 0.9.8-4.fc8.1.x86_64
Jan 17 10:01:47 Updated: e2fsprogs - 1.40.2-12.fc8.x86_64
Jan 17 10:01:48 Updated: mpage - 2.5.6-1.fc8.x86_64
Jan 17 10:01:51 Updated: kudzu - 1.2.79.2-1.x86_64
Jan 17 10:01:56 Updated: selinux-policy - 3.0.8-74.fc8.noarch
Jan 17 10:02:25 Updated: selinux-policy-targeted - 3.0.8-74.fc8.noarch
Jan 17 10:02:42 Updated: selinux-policy-devel - 3.0.8-74.fc8.noarch
Jan 17 10:02:42 Updated: pulseaudio-esound-compat - 0.9.8-4.fc8.1.x86_64
Jan 17 10:02:43 Updated: cairo-devel - 1.4.14-1.fc8.x86_64
Jan 17 10:02:45 Updated: e2fsprogs-devel - 1.40.2-12.fc8.x86_64
Jan 17 10:02:46 Updated: kudzu-devel - 1.2.79.2-1.i386
Jan 17 10:02:47 Updated: kudzu-devel - 1.2.79.2-1.x86_64
Jan 17 10:02:48 Updated: pulseaudio-libs - 0.9.8-4.fc8.1.i386
Jan 17 10:02:48 Updated: hpijs - 1:2.7.7-7.fc8.i386
Jan 17 10:02:53 Updated: hplip - 2.7.7-7.fc8.x86_64
Jan 17 10:02:54 Updated: libsane-hpaio - 2.7.7-7.fc8.x86_64
Jan 17 10:02:54 Updated: e2fsprogs-libs - 1.40.2-12.fc8.i386
Jan 17 10:02:55 Updated: cairo - 1.4.14-1.fc8.i386
Jan 17 10:02:56 Updated: pulseaudio-utils - 0.9.8-4.fc8.1.x86_64

leigh123linux
17th January 2008, 12:46 PM
I updated pulseaudio yesterday and noticed it was broken so I just reverted to the previous version which worked great anyway . ( I am going to wait until they release a fixed version )



I "fixed" it by "chmod -R 777 /dev/snd/" - but that is real dirty and not really a solution.

Yes that is real dirty :eek:

BlueC
17th January 2008, 12:54 PM
Hehehe I know its bad, but hey, what can ya do!

Leigh, would you be so kind as to show me the output of the following commands on your system? :)


rpm -qa | grep udev
ls -la /dev/snd
cat /etc/udev/rules.d/40-alsa.rules


Just an update: I am now thinking this may have something to do with an updated "udev" package and not pulseaudio perhaps?

Jan 16 22:03:28 Updated: udev - 118-1.fc8.x86_64

I noticed a new "udev-post" service that is activated on boot. I checked one of the files that this service creates: /etc/udev/rules.d/40-alsa.rules


# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*", NAME="snd/%k"
KERNEL=="hwC[D0-9]*", NAME="snd/%k"
KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k"
KERNEL=="midiC[D0-9]*", NAME="snd/%k"
KERNEL=="timer", NAME="snd/%k"
KERNEL=="seq", NAME="snd/%k"
KERNEL=="mixer0", SYMLINK+="mixer"
KERNEL=="dsp0", SYMLINK+="dsp"
KERNEL=="audio0", SYMLINK+="audio"

From a google, I believe this file may be incorrect, and it should in fact read something like below, as that would give the correct permissions to all users:


# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="hwC[D0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k", MODE="0666"
KERNEL=="midiC[D0-9]*", NAME="snd/%k", MODE="0666"
KERNEL=="timer", NAME="snd/%k", MODE="0666"
KERNEL=="seq", NAME="snd/%k", MODE="0666"
KERNEL=="mixer0", SYMLINK+="mixer", MODE="0666"
KERNEL=="dsp0", SYMLINK+="dsp", MODE="0666"
KERNEL=="audio0", SYMLINK+="audio", MODE="0666"

Anyone got any thoughts on this?!

leigh123linux
17th January 2008, 01:08 PM
I don,t think udev is the problem as I didn't update udev till today



[root@localhost ~]# cat /var/log/yum.log
Jan 17 11:24:20 Updated: e2fsprogs-libs - 1.40.2-12.fc8.x86_64
Jan 17 11:24:21 Updated: cairo - 1.4.14-1.fc8.x86_64
Jan 17 11:24:21 Updated: hpijs - 1:2.7.7-7.fc8.x86_64
Jan 17 11:24:22 Updated: popt - 1.13-1.fc8.x86_64
Jan 17 11:24:23 Updated: libvolume_id - 118-1.fc8.x86_64
Jan 17 11:24:23 Updated: readline - 5.2-9.fc8.x86_64
Jan 17 11:24:23 Updated: cairo - 1.4.14-1.fc8.i386
Jan 17 11:24:24 Updated: hpijs - 1:2.7.7-7.fc8.i386
Jan 17 11:24:28 Updated: hplip - 2.7.7-7.fc8.x86_64
Jan 17 11:24:29 Updated: libsane-hpaio - 2.7.7-7.fc8.x86_64
Jan 17 11:24:29 Updated: e2fsprogs-libs - 1.40.2-12.fc8.i386
Jan 17 11:24:30 Updated: popt - 1.13-1.fc8.i386
Jan 17 11:24:30 Updated: readline - 5.2-9.fc8.i386
Jan 17 11:24:31 Updated: e2fsprogs - 1.40.2-12.fc8.x86_64
Jan 17 11:24:31 Updated: libdhcp4client - 12:3.0.6-12.fc8.x86_64
Jan 17 11:24:32 Updated: dhclient - 12:3.0.6-12.fc8.x86_64
Jan 17 11:24:33 Updated: kudzu - 1.2.79.2-1.x86_64
Jan 17 11:24:34 Updated: logrotate - 3.7.6-2.1.fc8.x86_64
Jan 17 11:24:36 Updated: nspluginwrapper - 0.9.91.5-16.fc8.i386
Jan 17 11:24:36 Updated: mpage - 2.5.6-1.fc8.x86_64
Jan 17 11:24:37 Updated: e2fsprogs-devel - 1.40.2-12.fc8.x86_64
Jan 17 11:24:39 Updated: udev - 118-1.fc8.x86_64
Jan 17 11:24:48 Updated: gstreamer-plugins-good - 0.10.6-7.fc8.x86_64
Jan 17 11:24:49 Updated: gdb - 6.6-40.fc8.x86_64
Jan 17 11:24:49 Updated: nspluginwrapper - 0.9.91.5-16.fc8.x86_64
[root@localhost ~]#

BlueC
17th January 2008, 01:10 PM
Have you rebooted since the udev update? I presume it only comes into effect after a reboot.

Could you post the output of the 3 commands I asked for please?

Congrats on your new promotion btw - much deserved!

leigh123linux
17th January 2008, 01:18 PM
Have you rebooted since the udev update? I presume it only comes into effect after a reboot.

Could you post the output of the 3 commands I asked for please?

Congrats on your new promotion btw - much deserved!


Just rebooted and pulseaudio still works




[leigh@localhost ~]$ rpm -qa | grep pulseaudio
alsa-plugins-pulseaudio-1.0.14-5.fc8
pulseaudio-0.9.7-0.17.svn20071017.fc8
pulseaudio-esound-compat-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8
pulseaudio-libs-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8
pulseaudio-utils-0.9.7-0.17.svn20071017.fc8
pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8
pulseaudio-core-libs-0.9.7-0.17.svn20071017.fc8
[leigh@localhost ~]$




[leigh@localhost ~]$ rpm -qa | grep udev
udev-118-1.fc8
[leigh@localhost ~]$ ls -la /dev/snd
total 0
drwxr-xr-x 2 root root 320 2008-01-17 12:13 .
drwxr-xr-x 14 root root 5600 2008-01-17 12:13 ..
crw-rw----+ 1 root root 116, 12 2008-01-17 12:13 controlC0
crw-rw----+ 1 root root 116, 4 2008-01-17 12:13 hwC0D0
crw-rw----+ 1 root root 116, 13 2008-01-17 12:13 hwC0D2
crw-rw----+ 1 root root 116, 5 2008-01-17 12:13 midiC0D0
crw-rw----+ 1 root root 116, 14 2008-01-17 12:13 midiC0D1
crw-rw----+ 1 root root 116, 15 2008-01-17 12:13 midiC0D2
crw-rw----+ 1 root root 116, 11 2008-01-17 12:13 pcmC0D0c
crw-rw----+ 1 root root 116, 10 2008-01-17 12:13 pcmC0D0p
crw-rw----+ 1 root root 116, 9 2008-01-17 12:13 pcmC0D1c
crw-rw----+ 1 root root 116, 8 2008-01-17 12:13 pcmC0D2c
crw-rw----+ 1 root root 116, 7 2008-01-17 12:13 pcmC0D2p
crw-rw----+ 1 root root 116, 6 2008-01-17 12:13 pcmC0D3p
crw-rw----+ 1 root root 116, 3 2008-01-17 12:13 seq
crw-rw----+ 1 root root 116, 2 2008-01-17 12:13 timer
[leigh@localhost ~]$ cat /etc/udev/rules.d/40-alsa.rules
# do not edit this file, it will be overwritten on update

KERNEL=="controlC[0-9]*", NAME="snd/%k"
KERNEL=="hwC[D0-9]*", NAME="snd/%k"
KERNEL=="pcmC[D0-9cp]*", NAME="snd/%k"
KERNEL=="midiC[D0-9]*", NAME="snd/%k"
KERNEL=="timer", NAME="snd/%k"
KERNEL=="seq", NAME="snd/%k"
KERNEL=="mixer0", SYMLINK+="mixer"
KERNEL=="dsp0", SYMLINK+="dsp"
KERNEL=="audio0", SYMLINK+="audio"
[leigh@localhost ~]$



Congrats on your new promotion btw - much deserved!


Thanks :)

BlueC
17th January 2008, 01:42 PM
Thanks Leigh. Interesting!

I now seem to have fixed it the "proper" way thanks to the F8 guide in your sig! For some reason ConsoleKit wasn't running and neither was avahi-daemon - I enabled these, set the permissions on /dev/snd/* back to how they were, rebooted, and voila - it now works! (even with the latest pulseaudio updates)

begel
17th January 2008, 06:55 PM
I also upgraded pulseaudio via yum update this morning and my sound still does not work (even after rebooting).

Michael Begel
begel@bnl.gov

begel
17th January 2008, 06:57 PM
...oh, and I can no longer see pdf files embedded in my firefox. I don't know if this is related to
this issue though.

Michael Begel
begel@bnl.gov

alarm9k
18th January 2008, 08:16 PM
I have a slightly different problem. After upgrading to the recent pulseaudio package pulseaudio daemon now uses front:0 device for output instead of hw:0. Now I cannot control the surround sound settings in Kmix (surround, front, center etc) because the Front slider is the only one that works.

Reverting back to the previous version of pulseaudio package makes everything work again.

Logs from working version:
[alarm@winbox0 ~]$ pulseaudio -vvvv
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_4
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_4
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device=hw:0 sink_name=alsa_output.pci_1102_4_alsa_playback_0'
I: module-alsa-sink.c: Successfully enabled mmap() mode.
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_1102_4_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_1102_4_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
I: module-alsa-sink.c: ALSA device lacks separate volumes controls for all 2 channels (2 available), falling back to software volume control.
D: module-alsa-sink.c: Thread starting up

Logs from the recent (bad):
[alarm@winbox0 ~]$ pulseaudio -vvvv
W: polkit.c: Failed to show grant dialog: Unable to lookup exe for caller
W: polkit.c: PolicyKit responded with 'auth_admin_keep_always'
I: main.c: PolicyKit refuses acquire-high-priority privilige.
N: main.c: Called SUID root and real-time/high-priority scheduling was requested in the configuration. However, we lack the necessary priviliges:
N: main.c: We are not in group 'pulse-rt' and PolicyKit refuse to grant us priviliges. Dropping SUID again.
N: main.c: For enabling real-time scheduling please acquire the appropriate PolicyKit priviliges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
I: main.c: High-priority scheduling enabled in configuration but now allowed by policy. Disabling forcibly.
W: main.c: setrlimit(RLIMIT_NICE, (31, 31)) failed: Operation not permitted
W: main.c: setrlimit(RLIMIT_RTPRIO, (9, 9)) failed: Operation not permitted
I: main.c: Page size is 4096 bytes
I: main.c: Fresh high-resolution timers available! Bon appetit!
D: cli-command.c: Checking for existance of '/usr/lib/pulse-0.9/modules//module-hal-detect.so': success
I: module-hal-detect.c: Trying capability alsa
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_timer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/computer_alsa_sequencer
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_4
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_4
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_3
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_playback_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_2
D: module-hal-detect.c: Not loaded device /org/freedesktop/Hal/devices/pci_1102_4_alsa_capture_1
D: module-hal-detect.c: Loading module-alsa-sink with arguments 'device_id=0 sink_name=alsa_output.pci_1102_4_alsa_playback_0'
D: alsa-util.c: Trying front:0...
I: module-alsa-sink.c: Successfully opened device front:0.
I: module-alsa-sink.c: Successfully enabled mmap() mode.
ALSA lib control.c:909:(snd_ctl_open_noupdate) Invalid CTL front:0
I: alsa-util.c: Unable to attach to mixer front:0: No such file or directory
I: alsa-util.c: Successfully attached to mixer 'hw:0'
I: alsa-util.c: Using mixer control "Master".
I: sink.c: Created sink 0 "alsa_output.pci_1102_4_alsa_playback_0" with sample spec "s16le 2ch 44100Hz"
I: source.c: Created source 0 "alsa_output.pci_1102_4_alsa_playback_0.monitor" with sample spec "s16le 2ch 44100Hz"
I: module-alsa-sink.c: Using 4 fragments of size 4408 bytes.
I: alsa-util.c: ALSA device lacks independant volume controls for each channel, falling back to software volume control.
D: module-alsa-sink.c: Thread starting up

I'm stuck as there is not much documentation on pulseaudio configuration :-/