PDA

View Full Version : Nvidia Dual Monitor Helllllppppp



cable_txg
17th January 2008, 05:36 AM
I've posted this before, tried to figure things out. Now I've come to a point that my Samsung SyncMaster 204B is only showing 640x480 instead of 1600x1200. Could someone please look at my xorg configuration and log file and point me in the right direction!

:( :confused:

Tri5tian
17th January 2008, 06:34 AM
If you are using the official Nvidia drivers then you could use their Settings Utility: Applications > System Tools > Nvidia X Server Settings

You could try this and hopefully it helps (make a backup of original xorg.conf file):


Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Videocard1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200"
EndSubSection
EndSection

Emphyrio
17th January 2008, 07:21 AM
First off, does it run correctly in a single monitor mode? If not, get the system working with only one monitor plugged in. Please note that you can not have anything plugged into the second DVI connector....even if the monitor is turned off. It just will mess things up..don't ask me why, I couldn't tell you.

Install the nvidia drivers and kernel mods. Use the instructions here: http://www.fedorafaq.org/#nvidia

Then reboot. You have to make sure the new kernel mod and drivers are running.

Then back up your xorg.conf. Keep this working copy safe so you can always go back.

Then...log outand shut down your system. Plug in the second monitor. Power up. Log in as root. This is important, if you don't changes you make will not be written to xorg.conf correctly.

Then run "nVidia Display Settings". In KDE it will be in the system menu. Not sure about Gnome or XFCE, but you can also run 'nvidia-config-display' from the console too. Make the appropriate changes to the settings, save and exit. This should detect all the modes your monitor will handle.

Logout, reboot. Login as normal. Should be working.

This assumes you have one video card with two outputs....if you have two video cards...er...beats me.

Wayne
17th January 2008, 07:41 AM
Please read the forum guidelines and do not start a new thread on the same topic and disguise it with a poll to make it look different, stick to the same one until your problem is resolved.

Wayne

cable_txg
17th January 2008, 04:27 PM
Please read the forum guidelines and do not start a new thread on the same topic and disguise it with a poll to make it look different, stick to the same one until your problem is resolved.

Wayne
That was not the intention. I have posted about this issue before, but did not get any response. I tried solving it to this stage and needed more input...
Also, most of the information on the forum did not work for me or where for other cards ( I tried some to no avail!)
As for the poll, I was curious to see how it looked myself.....

:(

Wayne
18th January 2008, 01:09 AM
I understand, but rather than start a new thread you should have added extra comments about other steps you'd taken to resolve the problem to your original thread, which would have brought it back to the top and also would help people who may have the answers. I have since closed that other thread as duplicates are not permitted in the forum.

Wayne